extra/digikam to 5.5.0-1

This commit is contained in:
Kevin Mihelich 2017-03-14 12:46:03 +00:00
parent 30e0edccef
commit 98bf05d0c4
2 changed files with 9 additions and 31 deletions

View file

@ -9,31 +9,30 @@
pkgbase=digikam
pkgname=('digikam' 'kipi-plugins')
_pkgver=5.4.0
_pkgver=5.5.0
pkgver=${_pkgver//-/_} # for beta versions
pkgrel=2
pkgrel=1
pkgdesc="Digital photo management application for KDE"
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.digikam.org/"
makedepends=('extra-cmake-modules' 'libkipi' 'libksane' 'liblqr' 'opencv' 'boost'
'doxygen' 'lensfun' 'eigen' 'kdoctools' 'marble' 'kdesignerplugin'
'doxygen' 'lensfun' 'eigen' 'kdoctools' 'marble-common' 'kdesignerplugin'
'kfilemetadata' 'akonadi-contacts' 'qtav' 'threadweaver' 'kcalcore'
'knotifyconfig' 'libmediawiki' 'libkvkontakte')
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${_pkgver}.tar.xz" digikam-find-qtav.patch
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${_pkgver}.tar.xz"
'0001-optionally-enable-OpenGL.patch')
sha1sums=('6c58ee30cd84b40acf4427f1bb9dbb8b891eb894'
'b170e5eab5a8c40d1c8c8f2d2cfe5e911ad66939'
sha256sums=('df9cbf1b8dbfb9235cebc97e77c02fcb1498c5a905c7fd3b9fb42fd7accc6252'
'eb78bedfc8465c34b2c08d239085ccaf2e745d71')
prepare() {
mkdir -p build
# Fix QtAV location
cd $pkgname-$pkgver
patch -p1 -i ../digikam-find-qtav.patch
# sv docs fail to build
sed -e '/sv/d' -i $pkgname-$pkgver/doc-translated/CMakeLists.txt
# OpenGL switch
cd $pkgname-$pkgver
patch -p1 -d core -i ${srcdir}/0001-optionally-enable-OpenGL.patch
}
@ -58,7 +57,7 @@ build() {
package_digikam() {
pkgdesc="Digital photo management application for KDE"
depends=('liblqr' 'libkipi' 'lensfun' 'opencv' 'akonadi-contacts'
'knotifyconfig' 'libksane' 'kfilemetadata' 'qtav' 'marble' 'threadweaver' 'kcalcore')
'knotifyconfig' 'libksane' 'kfilemetadata' 'qtav' 'marble-common' 'threadweaver' 'kcalcore')
optdepends=('kipi-plugins: export to various online services'
'hugin: panorama tool' 'qt5-imageformats: WEBP format support')

View file

@ -1,21 +0,0 @@
--- digikam-5.4.0/core/cmake/modules/FindQtAV.cmake.0 2017-01-09 22:56:43.303991660 +0000
+++ digikam-5.4.0/core/cmake/modules/FindQtAV.cmake 2017-01-09 22:57:24.843934106 +0000
@@ -24,15 +24,17 @@
HINTS ${_qt5_install_prefix} # For MXE
${_qt5_install_prefix}/../qt5/include # For Mageia
${_qt5_install_prefix}/../../include/qt5 # For Suse
+ ${_qt5_install_prefix}/../../include/qt
${_qt5_install_prefix}/../../../include/x86_64-linux-gnu/qt5 # For Debian
PATH_SUFFIXES QtAV
)
find_path(QTAV_WIDGETS_INCLUDE_DIR
NAMES QtAVWidgets.h
HINTS ${_qt5_install_prefix} # For MXE
${_qt5_install_prefix}/../qt5/include # For Mageia
${_qt5_install_prefix}/../../include/qt5 # For Suse
+ ${_qt5_install_prefix}/../../include/qt
${_qt5_install_prefix}/../../../include/x86_64-linux-gnu/qt5 # For Debian
PATH_SUFFIXES QtAVWidgets
)