mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added community/openlibm
This commit is contained in:
parent
e9e05bf243
commit
98f86e16b3
2 changed files with 62 additions and 0 deletions
|
@ -0,0 +1,25 @@
|
|||
From 53a4684ea8194e7766a5e5f624b28876e09710d5 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 6 Dec 2019 06:42:03 -0700
|
||||
Subject: [PATCH] Remove ARM march and float specification
|
||||
|
||||
---
|
||||
Make.inc | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/Make.inc b/Make.inc
|
||||
index 34888d2..a3c43ae 100644
|
||||
--- a/Make.inc
|
||||
+++ b/Make.inc
|
||||
@@ -57,8 +57,6 @@ endif
|
||||
# OS-specific stuff
|
||||
ifeq ($(findstring arm,$(ARCH)),arm)
|
||||
override ARCH := arm
|
||||
-MARCH ?= armv7-a
|
||||
-CFLAGS_add += -mhard-float
|
||||
endif
|
||||
ifeq ($(findstring powerpc,$(ARCH)),powerpc)
|
||||
override ARCH := powerpc
|
||||
--
|
||||
2.23.0
|
||||
|
37
community/openlibm/PKGBUILD
Normal file
37
community/openlibm/PKGBUILD
Normal file
|
@ -0,0 +1,37 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Contributor: Lex Black <autumn-wind@web.de>
|
||||
# Contributor: Arthur Zamarin <arthurzam@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch out hard ARM march and float specification
|
||||
|
||||
pkgname=openlibm
|
||||
pkgver=0.6.0
|
||||
pkgrel=2.1
|
||||
pkgdesc='Standalone implementation of C mathematical functions'
|
||||
arch=(x86_64)
|
||||
url='https://openlibm.org/'
|
||||
license=(BSD)
|
||||
depends=(glibc)
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/JuliaLang/$pkgname/archive/v$pkgver.tar.gz"
|
||||
'0001-Remove-ARM-march-and-float-specification.patch')
|
||||
sha256sums=('d45439093d1fd15e2ac3acf69955e462401c7a160d3330256cb4a86c51bdae28'
|
||||
'2b16d1e852a88bc6d31e9b25ed60b1a374f46b2034ce3449c2b8dafc6d2007c9')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../0001-Remove-ARM-march-and-float-specification.patch
|
||||
sed -e 's|/usr/local|/usr|' -i Make.inc
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
make prefix=/usr
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
|
||||
install -Dm644 LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname/
|
||||
}
|
Loading…
Reference in a new issue