This commit is contained in:
moonman 2015-04-16 05:40:16 +00:00
commit 9936580809
8 changed files with 42 additions and 133 deletions

View file

@ -7,7 +7,7 @@
# - removed numactl dependency
pkgname=fio
pkgver=2.2.6
pkgver=2.2.7
pkgrel=1
pkgdesc='Scriptable I/O tool for storage benchmarks and drive testing'
arch=(i686 x86_64)
@ -20,7 +20,7 @@ optdepends=(
'gnuplot: generating plots using fio_generate_plots'
)
source=(http://brick.kernel.dk/snaps/fio-$pkgver.tar.bz2)
sha256sums=('5d9a12c9fe2de95d15053ed56de8b06cc4cec5bfa38758a796d3a2eb9ce688db')
sha256sums=('6e3cd5bda0747e61cbfd42c7b3cfe044ea8981d8d3a486f0a2f2fafdb954296f')
prepare() {
cd fio-$pkgver

View file

@ -1,30 +0,0 @@
# Maintainer: Tobias Kieslich <tobias@archlinux.org>
# Contributor: dorphell <dorphell@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove Arch's CFLAGS replacement, doesn't work with our flags
pkgname=libvorbis
pkgver=1.3.4
pkgrel=1
pkgdesc="Vorbis codec library"
arch=('i686' 'x86_64')
license=('BSD')
url="http://www.xiph.org/vorbis/"
depends=('libogg')
options=('!libtool')
source=(http://downloads.xiph.org/releases/vorbis/${pkgname}-${pkgver}.tar.gz)
md5sums=('8851c593a52d1ef9c526d95174873852')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --disable-static
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}

View file

@ -7,8 +7,8 @@
# - set --enable-compile-warnings=no in configure
pkgname=mutter
pkgver=3.16.0
pkgrel=2
pkgver=3.16.1.1
pkgrel=1
pkgdesc="A window manager for GNOME"
arch=(i686 x86_64)
license=('GPL')
@ -21,7 +21,7 @@ groups=('gnome')
options=('!emptydirs')
install=mutter.install
source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
sha256sums=('0b23a2d31980d9de8e92ef940e6f63e3ac0f6446e2afc69ecbc80163f6af3a23')
sha256sums=('795084f6b642ab45e9f73b82b185949a110f2149bc0bce9f70ff30c8ab4c051c')
build() {
cd "$pkgname-$pkgver"

View file

@ -1,10 +0,0 @@
[Desktop Entry]
Encoding=UTF-8
Name=7-Zip FM
GenericName=7-Zip File Manager
Type=Application
Categories=GTK;Utility;Archiving;Compression;
Terminal=false
Icon=p7zip
Exec=7zFM
MimeType=application/gzip;application/x-7z-compressed;application/x-7z-compressed-tar;application/x-arj;application/x-bzip;application/x-bzip-compressed-tar;application/x-bzip1;application/x-bzip1-compressed-tar;application/x-cabinet;application/x-cd-image;application/x-compress;application/x-compressed-tar;application/x-cpio;application/x-deb;application/x-gtar;application/x-gzip;application/x-gzpostscript;application/x-lha;application/x-lhz;application/x-lzma;application/x-lzma-compressed-tar;application/x-ms-wim;application/x-rar;application/x-rar-compressed;application/x-rpm;application/x-tar;application/x-xz;application/x-xz-compressed-tar;application/x-zip;application/x-zip-compressed;application/zip;application/vnd.ms-cab-compressed;

View file

@ -1,72 +1,53 @@
# $Id$
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Thayer Williams <thayer@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
# Contributor: TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - use makefile.linux_any_cpu
pkgname=p7zip
pkgver=9.38.1
pkgrel=2
pkgdesc='Command-line version of the 7zip compressed file archiver'
url='http://p7zip.sourceforge.net/'
license=('GPL' 'custom')
pkgrel=3
pkgdesc="Command-line file archiver with high compression ratio"
arch=('i686' 'x86_64')
depends=('gcc-libs' 'bash')
optdepends=('wxgtk: GUI'
'desktop-file-utils: desktop entries')
makedepends=('yasm' 'nasm' 'wxgtk')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}_${pkgver}_src_all.tar.bz2"
'osversion.patch'
'7zFM.desktop')
sha1sums=('6b1eccf272d8b141a94758f80727ae633568ba69'
'8c086db1c7be0d52d2ac971f44adbdccf6dd82de'
'441e8d89457f165c22015dedd0c1ee88504f333c')
options=('!makeflags')
install=install
url="http://p7zip.sourceforge.net/"
license=('LGPL' 'custom:unRAR')
depends=('gcc-libs' 'sh')
makedepends_i686=('nasm')
makedepends_x86_64=('yasm')
install=$pkgname.install
source=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver}_src_all.tar.bz2)
sha256sums=('fd5019109c9a1bf34ad3257d37a6853eae8151ff50345f0a3ffba7d8c5fdb995')
prepare() {
cd "${srcdir}/${pkgname}_${pkgver}"
cp makefile.linux_any_cpu_gcc_4.X makefile.machine
cd "$srcdir/${pkgname}_$pkgver"
patch -p1 -i ../osversion.patch
sed -i 's/x86_64-linux-gnu//g' CPP/7zip/*/*/*.depend
rm GUI/kde4/p7zip_compress.desktop # FS#43766
cp makefile.linux_any_cpu_gcc_4.X makefile.machine
}
build() {
cd "${srcdir}/${pkgname}_${pkgver}"
make all4 OPTFLAGS="${CXXFLAGS}"
cd "$srcdir/${pkgname}_$pkgver"
make all3 OPTFLAGS="$CFLAGS"
}
package() {
cd "${srcdir}/${pkgname}_${pkgver}"
make install \
DEST_DIR="${pkgdir}" \
DEST_HOME="/usr" \
DEST_MAN="/usr/share/man"
cd "$srcdir/${pkgname}_$pkgver"
# Doc and licenses
cp -a DOC/* "${pkgdir}"/usr/share/doc/p7zip
install -d "${pkgdir}"/usr/share/licenses/p7zip
ln -s -t "${pkgdir}"/usr/share/licenses/p7zip \
/usr/share/doc/p7zip/License.txt \
/usr/share/doc/p7zip/unRarLicense.txt
make install \
DEST_DIR="$pkgdir" \
DEST_HOME=/usr \
DEST_MAN=/usr/share/man
# Integration with stuff...
install -Dm644 GUI/p7zip_32.png "${pkgdir}"/usr/share/icons/hicolor/32x32/apps/p7zip.png
install -d "${pkgdir}"/usr/share/{applications,kde4/services/ServiceMenus}
cp GUI/kde4/* "${pkgdir}"/usr/share/kde4/services/ServiceMenus/
cp ../7zFM.desktop "${pkgdir}"/usr/share/applications/
ln -s 7zCon.sfx "${pkgdir}"/usr/lib/p7zip/7z.sfx
install -d "${pkgdir}"/usr/share/licenses/p7zip
ln -s -t "$pkgdir/usr/share/licenses/p7zip/" \
/usr/share/doc/p7zip/DOC/License.txt \
/usr/share/doc/p7zip/DOC/unRarLicense.txt
find GUI/help -type d -exec chmod 755 {} \;
cp -r GUI/help "${pkgdir}"/usr/lib/p7zip/
chmod -R a+r,u+w,a+X "${pkgdir}/usr"
chmod -R a+r,u+w,a+X "$pkgdir/usr"
}
# vim:set ts=2 sw=2 et:

View file

@ -1,13 +0,0 @@
post_install() {
[[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
[[ -x usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -q -t -f usr/share/icons/hicolor || true
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -1,28 +0,0 @@
diff -Naur old/CPP/7zip/UI/FileManager/FM.cpp new/CPP/7zip/UI/FileManager/FM.cpp
--- old/CPP/7zip/UI/FileManager/FM.cpp 2015-01-18 08:59:09.000000000 -1000
+++ new/CPP/7zip/UI/FileManager/FM.cpp 2015-02-09 11:39:55.575712452 -1000
@@ -348,24 +348,7 @@
bool IsLargePageSupported()
{
- #ifdef _WIN64
return true;
- #else
- OSVERSIONINFO versionInfo;
- versionInfo.dwOSVersionInfoSize = sizeof(versionInfo);
- if (!::GetVersionEx(&versionInfo))
- return false;
- if (versionInfo.dwPlatformId != VER_PLATFORM_WIN32_NT || versionInfo.dwMajorVersion < 5)
- return false;
- if (versionInfo.dwMajorVersion > 5)
- return true;
- if (versionInfo.dwMinorVersion < 1)
- return false;
- if (versionInfo.dwMinorVersion > 1)
- return true;
- // return IsWow64();
- return false;
- #endif
}
#if 0 //#ifndef UNDER_CE

View file

@ -0,0 +1,9 @@
post_upgrade() {
if (($(vercmp $2 9.38.1-3) < 0)); then
echo ':: The 7zFM graphical frontend is no longer included in this package.'
echo ' If you used it, consider installing one of the following packages:'
echo ' 1) file-roller, 2) engrampa, 3) kdeutils-ark.'
fi
}
# vim:set ts=2 sw=2 et: