community/libuhd to 3.13.0.1-3

This commit is contained in:
Kevin Mihelich 2019-01-16 20:38:07 +00:00
parent 47a9095a76
commit 9947a28361
2 changed files with 28 additions and 1 deletions

View file

@ -6,7 +6,7 @@
pkgname=libuhd
pkgver=3.13.0.1
pkgrel=2
pkgrel=3
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
arch=('x86_64')
url="http://www.ettus.com/kb/category/software-documentation/uhd-manual"
@ -17,14 +17,17 @@ makedepends=('cmake' 'boost' 'python2-mako')
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz"
'boost-1.67.patch'
'boost-1.69.patch'
'0001-remove-ineffectual-neon-check.patch')
md5sums=('e7c38546d9dadac41657ee5e53c3f342'
'45fcc6feb0ea9b4ae09e4ba7b010864f'
'ae53a647b13a9187a3c8b965bfbde2c1'
'2cb16216ee735ab1160e572d523155ea')
prepare() {
cd "$srcdir/uhd-$pkgver"
patch -Np1 -i ../boost-1.67.patch
patch -Np1 -i ../boost-1.69.patch
patch -Np1 -i ../0001-remove-ineffectual-neon-check.patch
}

View file

@ -0,0 +1,24 @@
From 5c012cad7858cadcaa85ec295080f3c8b21fdee0 Mon Sep 17 00:00:00 2001
From: Martin Braun <martin.braun@ettus.com>
Date: Wed, 9 Jan 2019 09:17:07 -0800
Subject: [PATCH] lib: experts: Add potentially missing but sometimes inferred
include
This adds an include for boost/core/noncopyable.hpp. Without it, builds
would potentially fail on Boost 1.69++.
---
host/lib/include/uhdlib/experts/expert_nodes.hpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/host/lib/include/uhdlib/experts/expert_nodes.hpp b/host/lib/include/uhdlib/experts/expert_nodes.hpp
index 697ca19c3..8fa183835 100644
--- a/host/lib/include/uhdlib/experts/expert_nodes.hpp
+++ b/host/lib/include/uhdlib/experts/expert_nodes.hpp
@@ -12,6 +12,7 @@
#include <uhd/exception.hpp>
#include <uhd/utils/dirty_tracked.hpp>
#include <uhd/types/time_spec.hpp>
+#include <boost/core/noncopyable.hpp>
#include <boost/function.hpp>
#include <boost/thread/recursive_mutex.hpp>
#include <boost/thread.hpp>