mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed community/dune
This commit is contained in:
parent
f357b411d7
commit
9969304973
2 changed files with 0 additions and 79 deletions
|
@ -1,28 +0,0 @@
|
||||||
From 15c04b09a8c06871635d5fd98c3a37089bbde6d9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jeremie Dimino <jeremie@dimino.org>
|
|
||||||
Date: Thu, 8 Aug 2019 23:31:27 +0100
|
|
||||||
Subject: [PATCH] remove nodynlink optimisation
|
|
||||||
|
|
||||||
Signed-off-by: Jeremie Dimino <jeremie@dimino.org>
|
|
||||||
---
|
|
||||||
src/exe_rules.ml | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/exe_rules.ml b/src/exe_rules.ml
|
|
||||||
index 834afab21..eda12ee4d 100644
|
|
||||||
--- a/src/exe_rules.ml
|
|
||||||
+++ b/src/exe_rules.ml
|
|
||||||
@@ -104,11 +104,11 @@ let executables_rules ~sctx ~dir ~dir_kind ~expander
|
|
||||||
else
|
|
||||||
Some js_of_ocaml
|
|
||||||
in
|
|
||||||
- let dynlink =
|
|
||||||
+ let dynlink = true (*
|
|
||||||
Dune_file.Executables.Link_mode.Set.exists exes.modes ~f:(fun mode ->
|
|
||||||
match mode.kind with
|
|
||||||
| Shared_object -> true
|
|
||||||
- | _ -> false)
|
|
||||||
+ | _ -> false)*)
|
|
||||||
in
|
|
||||||
Compilation_context.create ()
|
|
||||||
~super_context:sctx
|
|
|
@ -1,51 +0,0 @@
|
||||||
# Maintainer: Bruno Pagani <archange@archlinux.org>
|
|
||||||
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - upstream-ish patch for ARMv7
|
|
||||||
# https://github.com/ocaml/dune/issues/2527
|
|
||||||
|
|
||||||
pkgname=dune
|
|
||||||
pkgver=1.11.1
|
|
||||||
pkgrel=2
|
|
||||||
pkgdesc="A composable build system for OCaml (formerly jbuilder)"
|
|
||||||
arch=(x86_64)
|
|
||||||
url="https://github.com/ocaml/dune"
|
|
||||||
license=(Apache)
|
|
||||||
depends=(glibc ocaml ocaml-findlib)
|
|
||||||
provides=(jbuilder)
|
|
||||||
conflicts=(jbuilder)
|
|
||||||
replaces=(jbuilder)
|
|
||||||
source=("${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
|
|
||||||
'15c04b09a8c06871635d5fd98c3a37089bbde6d9.patch')
|
|
||||||
sha256sums=('f2aa962451c98e47a90ca47273b2080e5f9aaeb6e3b6271dc78a44b831cc0d46'
|
|
||||||
'156de7635cb3a135d3e37eeaeef665f613b3e708ca7d5cb5f078b1f1efbeac6d')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd ${pkgname}-${pkgver}
|
|
||||||
if [[ $CARCH == "armv7h" ]]; then
|
|
||||||
patch -p1 -i ../15c04b09a8c06871635d5fd98c3a37089bbde6d9.patch
|
|
||||||
fi
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd ${pkgname}-${pkgver}
|
|
||||||
make release
|
|
||||||
}
|
|
||||||
|
|
||||||
# Tests requires a bunch of (currently) unpackaged dependencies
|
|
||||||
#check() {
|
|
||||||
# cd ${pkgname}-${pkgver/b/-beta}
|
|
||||||
# make test
|
|
||||||
#}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd ${pkgname}-${pkgver}
|
|
||||||
|
|
||||||
make DESTDIR="${pkgdir}" INSTALL_ARGS="--prefix=/usr --libdir='$(ocamlfind printconf destdir)'" install
|
|
||||||
|
|
||||||
# Fix doc and man install
|
|
||||||
rm -r "${pkgdir}"/usr/doc
|
|
||||||
install -dm755 "${pkgdir}"/usr/share
|
|
||||||
mv "${pkgdir}"/usr/{man,share/}
|
|
||||||
}
|
|
Loading…
Reference in a new issue