extra/thunderbird: fix patch

This commit is contained in:
Kevin Mihelich 2014-07-23 01:35:50 +00:00
parent f623fb5ba1
commit 99b5669eff
2 changed files with 42 additions and 26 deletions

View file

@ -36,7 +36,7 @@ sha256sums=('571f8cca980f077ae81999aea69a78153422a75e9e6c07ab74ec6659fe0d6ef4'
'd506b771e765e09e2e039b975e25befade8eec97e8950813a32463604955ab4e'
'9049ab3f9600a1592a54c41a166c76e046c393e1cfe7c4e769155b7317d197ee'
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
'e9c75dbc86d96efec6f8bb4fea949fafe20d72bfefacc427decbd7fab801bd00')
'014a2f160c2f21b854d21c0ae5cd6ad7493586f03cae4399960f75570ee2ce92')
prepare() {
cd comm-esr31

View file

@ -1,23 +1,23 @@
--- mozilla/configure.orig 2014-02-16 19:18:34.782768334 -0700
+++ mozilla/configure 2014-02-16 19:18:53.287522296 -0700
@@ -6675,91 +6675,9 @@
--- mozilla/configure.orig 2014-07-22 18:38:00.711218733 -0600
+++ mozilla/configure 2014-07-22 18:40:37.355699369 -0600
@@ -6970,98 +6970,10 @@
-if test "$CPU_ARCH" = "arm"; then
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:6681: checking for ARM SIMD support in compiler" >&5
-echo "configure:6976: checking for ARM SIMD support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6685 "configure"
-#line 6980 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:6692: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-if { (eval echo configure:6987: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
@ -40,23 +40,23 @@
- fi
-
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
-echo "configure:6715: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9]*\).*/\1/p'`
-echo "configure:7010: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
- echo "$ac_t"""$ARM_ARCH"" 1>&6
-
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:6720: checking for ARM NEON support in compiler" >&5
-echo "configure:7015: checking for ARM NEON support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6724 "configure"
-#line 7019 "configure"
-#include "confdefs.h"
-
-int main() {
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:6731: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-if { (eval echo configure:7026: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
@ -79,8 +79,15 @@
-
- if test -n "$ARM_ARCH"; then
- if test "$ARM_ARCH" -lt 7; then
- BUILD_ARM_NEON=0
- BUILD_ARM_NEON=
- else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define BUILD_ARM_NEON 1
-EOF
-
- BUILD_ARM_NEON=1
- fi
- fi
@ -88,33 +95,33 @@
-
-fi # CPU_ARCH = arm
-
-
+HAVE_ARM_NEON=0
+BUILD_ARM_NEON=0
+HAVE_ARM_SIMD=0
--- mozilla/js/src/configure.orig 2014-02-16 19:15:10.325465791 -0700
+++ mozilla/js/src/configure 2014-02-16 19:15:28.820223476 -0700
@@ -5900,90 +5900,9 @@
--- mozilla/js/src/configure.orig 2014-07-22 18:38:00.736218651 -0600
+++ mozilla/js/src/configure 2014-07-22 18:41:43.420479891 -0600
@@ -6153,99 +6153,9 @@
-if test "$CPU_ARCH" = "arm"; then
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:5906: checking for ARM SIMD support in compiler" >&5
-echo "configure:6159: checking for ARM SIMD support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 5910 "configure"
-#line 6163 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:5917: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-if { (eval echo configure:6170: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
@ -137,23 +144,23 @@
- fi
-
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
-echo "configure:5940: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9]*\).*/\1/p'`
-echo "configure:6193: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
- echo "$ac_t"""$ARM_ARCH"" 1>&6
-
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:5945: checking for ARM NEON support in compiler" >&5
-echo "configure:6198: checking for ARM NEON support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 5949 "configure"
-#line 6202 "configure"
-#include "confdefs.h"
-
-int main() {
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:5956: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-if { (eval echo configure:6209: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
@ -176,8 +183,15 @@
-
- if test -n "$ARM_ARCH"; then
- if test "$ARM_ARCH" -lt 7; then
- BUILD_ARM_NEON=0
- BUILD_ARM_NEON=
- else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
-cat >> confdefs.h <<\EOF
-#define BUILD_ARM_NEON 1
-EOF
-
- BUILD_ARM_NEON=1
- fi
- fi
@ -185,6 +199,8 @@
-
-fi # CPU_ARCH = arm
-
-
-
+HAVE_ARM_NEON=0
+BUILD_ARM_NEON=0
+HAVE_ARM_SIMD=0