mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/firefox: fixes
This commit is contained in:
parent
c553fdeb51
commit
99b89ab39b
2 changed files with 4 additions and 29 deletions
|
@ -5,8 +5,6 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - mozconfig changes for ARM
|
||||
# - patches to build on ARM
|
||||
# - remove makedepend on cargo
|
||||
# - use tarball source
|
||||
|
||||
buildarch=12
|
||||
|
@ -19,7 +17,7 @@ pkgdesc="Standalone web browser from mozilla.org"
|
|||
arch=(i686 x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
url="https://www.mozilla.org/firefox/"
|
||||
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
|
||||
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
|
||||
nss hunspell sqlite ttf-font libpulse)
|
||||
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
|
||||
autoconf2.13 rust mercurial clang llvm jack)
|
||||
|
@ -32,10 +30,8 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
|
|||
wifi-disentangle.patch wifi-fix-interface.patch
|
||||
0001-Bug-1384062-Make-SystemResourceMonitor.stop-more-res.patch
|
||||
no-plt.diff plugin-crash.diff glibc-2.26-fix.diff
|
||||
$pkgname.desktop firefox-symbolic.svg firefox-install-dir.patch
|
||||
rhbz-1354671.patch
|
||||
https://src.fedoraproject.org/rpms/firefox/raw/master/f/build-cubeb-pulse-arm.patch)
|
||||
sha256sums=('891836df85f8798c49f7b25661820f64d1311d59703c716eda471819b93ccda2'
|
||||
$pkgname.desktop firefox-symbolic.svg firefox-install-dir.patch)
|
||||
sha256sums=('6f7d284c31383a9860d7b52f05f866526d5a7c31e3ef2959d79122ba074f5ca1'
|
||||
'f068b84ad31556095145d8fefc012dd3d1458948533ed3fff6cbc7250b6e73ed'
|
||||
'e98a3453d803cc7ddcb81a7dc83f883230dd8591bdf936fc5a868428979ed1f1'
|
||||
'aba767995ffb1a55345e30aaba667f43d469e23bd9b1b68263cf71b8118acc96'
|
||||
|
@ -44,10 +40,7 @@ sha256sums=('891836df85f8798c49f7b25661820f64d1311d59703c716eda471819b93ccda2'
|
|||
'cd7ff441da66a287f8712e60cdc9e216c30355d521051e2eaae28a66d81915e8'
|
||||
'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef'
|
||||
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
|
||||
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
|
||||
'22d5e5c07e759422027867121b24cdbcab8812670ca8e2e92825029f30eecbbd'
|
||||
'434298ee0e91990967af03614c0d3232024e35dd38ca9f7dce52a8a7363e2382')
|
||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
|
@ -134,9 +127,7 @@ END
|
|||
echo 'ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"' >> .mozconfig
|
||||
elif [[ $CARCH == "aarch64" ]]; then
|
||||
echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
|
||||
patch -p1 -i ../rhbz-1354671.patch
|
||||
fi
|
||||
patch -p1 -i ../build-cubeb-pulse-arm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
@@ -, +, @@
|
||||
---
|
||||
layout/base/nsIPresShell.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
--- a/layout/base/nsIPresShell.h
|
||||
+++ a/layout/base/nsIPresShell.h
|
||||
@@ -224,7 +224,7 @@ public:
|
||||
* to the same aSize value. AllocateFrame returns zero-filled memory.
|
||||
* AllocateFrame is infallible and will abort on out-of-memory.
|
||||
*/
|
||||
- void* AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
||||
+ void* __attribute__((optimize("no-lifetime-dse"))) AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
||||
{
|
||||
void* result = mFrameArena.AllocateByFrameID(aID, aSize);
|
||||
RecordAlloc(result);
|
||||
--
|
Loading…
Reference in a new issue