extra/pyqt5 to 5.7.1-1

This commit is contained in:
Kevin Mihelich 2017-01-23 13:32:48 +00:00
parent d89c5c7a9d
commit 9a0abdbb31
2 changed files with 4 additions and 19 deletions

View file

@ -10,9 +10,9 @@
pkgbase=pyqt5
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
pkgver=5.7
pkgver=5.7.1
_pkgver=$pkgver
pkgrel=3
pkgrel=1
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
@ -20,15 +20,12 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
'python2-dbus' 'python-dbus' 'qt5-connectivity'
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-qt5.7.1.patch)
md5sums=('e3dc21f31fd714659f0688e1eb31bacf'
'6f00ffd5def3ccb853c5e0d794f897b2')
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz")
md5sums=('b3171b67c74aa63a3cd2f386660c898b')
prepare() {
# The additional include path was removed due to this line, I don't really know why they are doing this...
sed -i '/target_config.dbus_inc_dirs = \[\]/d' PyQt5_gpl-${_pkgver}/configure.py
# support Qt 5.7.1
patch -p0 -i pyqt-qt5.7.1.patch
cp -a PyQt5_gpl-${_pkgver}{,-py2}
}

View file

@ -1,12 +0,0 @@
--- PyQt5_gpl-5.7/sip/QtCore/QtCoremod.sip 2016-12-24 12:39:12.725734296 +0000
+++ PyQt5_gpl-5.7/sip/QtCore/QtCoremod.sip 2016-12-24 12:40:17.502273973 +0000
@@ -22,7 +22,7 @@
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", version=1)
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_7_0}
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_7_0 Qt_5_7_1}
%Platforms {WS_X11 WS_WIN WS_MACX}