mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
removed extra/analitza
This commit is contained in:
parent
9aa8b3518b
commit
9a16ea3e11
2 changed files with 0 additions and 70 deletions
|
@ -1,26 +0,0 @@
|
|||
From fffe7737f11b844c3007b588310c927be437df86 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Apr 2017 10:15:01 -0600
|
||||
Subject: [PATCH] Link against GLESv2 for Linux
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
analitzaplot/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/analitzaplot/CMakeLists.txt b/analitzaplot/CMakeLists.txt
|
||||
index 560401b4..0c1256af 100644
|
||||
--- a/analitzaplot/CMakeLists.txt
|
||||
+++ b/analitzaplot/CMakeLists.txt
|
||||
@@ -63,7 +63,7 @@ target_link_libraries ( AnalitzaPlot
|
||||
Analitza
|
||||
)
|
||||
|
||||
-if(CMAKE_SYSTEM_NAME STREQUAL Android)
|
||||
+if(CMAKE_SYSTEM_NAME STREQUAL Android OR CMAKE_SYSTEM_NAME STREQUAL Linux)
|
||||
target_link_libraries(AnalitzaPlot GLESv2)
|
||||
elseif(WIN32)
|
||||
target_link_libraries(AnalitzaPlot ${GLEW_LIBRARIES})
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -1,44 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to link against GLES for Linux
|
||||
|
||||
pkgname=analitza
|
||||
pkgver=17.08.3
|
||||
pkgrel=1
|
||||
pkgdesc="A library to add mathematical features to your program"
|
||||
url="https://edu.kde.org/"
|
||||
arch=(i686 x86_64)
|
||||
license=(GPL LGPL FDL)
|
||||
depends=(qt5-svg qt5-declarative)
|
||||
makedepends=(extra-cmake-modules kdoctools python eigen qt5-tools)
|
||||
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
|
||||
'0001-Link-against-GLESv2-for-Linux.patch')
|
||||
sha256sums=('7b583610f50fe03f110684248a3ca328f066713b997d3d96bc5e40e5f4301fc8'
|
||||
'SKIP'
|
||||
'3bce76a8106ada89727a5f781441ce8af8c1d619230e25bbecb48aee5b7511d0')
|
||||
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
|
||||
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
patch -p1 -d $pkgname-$pkgver -i ../0001-Link-against-GLESv2-for-Linux.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
cmake ../$pkgname-$pkgver \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DBUILD_TESTING=OFF \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
Loading…
Reference in a new issue