mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/gap to 4.10.0-6
This commit is contained in:
parent
6e617d9ef3
commit
9a2fdf947c
2 changed files with 34 additions and 3 deletions
|
@ -8,18 +8,20 @@
|
||||||
pkgbase=gap
|
pkgbase=gap
|
||||||
pkgname=(gap gap-doc gap-packages)
|
pkgname=(gap gap-doc gap-packages)
|
||||||
pkgver=4.10.0
|
pkgver=4.10.0
|
||||||
pkgrel=5
|
pkgrel=6
|
||||||
pkgdesc="Groups, Algorithms, Programming: a system for computational discrete algebra"
|
pkgdesc="Groups, Algorithms, Programming: a system for computational discrete algebra"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="https://www.gap-system.org/"
|
url="https://www.gap-system.org/"
|
||||||
license=(GPL)
|
license=(GPL)
|
||||||
source=("https://www.gap-system.org/pub/gap/gap-${pkgver%.*}/tar.gz/gap-$pkgver.tar.gz" gap.sh
|
source=("https://www.gap-system.org/pub/gap/gap-${pkgver%.*}/tar.gz/gap-$pkgver.tar.gz" gap.sh
|
||||||
gap-sagemath-1.patch gap-sagemath-2.patch gap-sagemath-3.patch)
|
gap-sagemath-1.patch gap-sagemath-2.patch gap-sagemath-3.patch
|
||||||
|
gap-polymake-3.3.patch)
|
||||||
sha256sums=('314b8d949c0bb01ef8bee199b29571d42714df660aba0d76ded254f58295904f'
|
sha256sums=('314b8d949c0bb01ef8bee199b29571d42714df660aba0d76ded254f58295904f'
|
||||||
'143fb8a79a52c007903cce13407850df309ef803a9b00398d05169355917de46'
|
'143fb8a79a52c007903cce13407850df309ef803a9b00398d05169355917de46'
|
||||||
'e5f0a71ae5cdcc6596330834ef9fb0a0183890a9cf874a7eb88b819b0030a33b'
|
'e5f0a71ae5cdcc6596330834ef9fb0a0183890a9cf874a7eb88b819b0030a33b'
|
||||||
'3b66e6b320f56119b1d8eb804a94ee3a7ea71af10bd4f99a61bae32840e62c87'
|
'3b66e6b320f56119b1d8eb804a94ee3a7ea71af10bd4f99a61bae32840e62c87'
|
||||||
'511414a8d085a9ef9de5f921fdd45e4bbb3f33c2d88b821da06dfc267c182ddc')
|
'511414a8d085a9ef9de5f921fdd45e4bbb3f33c2d88b821da06dfc267c182ddc'
|
||||||
|
'c92849b2643e0e21ffdcfa230fb23fe4a276ec15402f178d5d69ddb0e537fbbe')
|
||||||
makedepends=(libxaw givaro mpfi normaliz boost c-xsc zeromq fplll polymake wget chrpath)
|
makedepends=(libxaw givaro mpfi normaliz boost c-xsc zeromq fplll polymake wget chrpath)
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -34,6 +36,9 @@ prepare() {
|
||||||
patch -p1 -i ../gap-sagemath-1.patch
|
patch -p1 -i ../gap-sagemath-1.patch
|
||||||
patch -p1 -i ../gap-sagemath-2.patch
|
patch -p1 -i ../gap-sagemath-2.patch
|
||||||
patch -p1 -i ../gap-sagemath-3.patch
|
patch -p1 -i ../gap-sagemath-3.patch
|
||||||
|
|
||||||
|
cd pkg/PolymakeInterface*
|
||||||
|
patch -p2 -i "$srcdir"/gap-polymake-3.3.patch # Fix build of PolymakeInterface with polymake 3.3
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
26
community/gap/gap-polymake-3.3.patch
Normal file
26
community/gap/gap-polymake-3.3.patch
Normal file
|
@ -0,0 +1,26 @@
|
||||||
|
diff --git a/PolymakeInterface/src/polymake_fan.cpp b/PolymakeInterface/src/polymake_fan.cpp
|
||||||
|
index e3914d7b..9e1b164b 100644
|
||||||
|
--- a/PolymakeInterface/src/polymake_fan.cpp
|
||||||
|
+++ b/PolymakeInterface/src/polymake_fan.cpp
|
||||||
|
@@ -93,7 +93,7 @@ Obj REAL_FAN_BY_RAYS_AND_CONES( Polymake_Data* data, Obj rays, Obj cones ){
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
- incMatr[i] += INT_INTOBJ( numb ) - 1;
|
||||||
|
+ incMatr[i] += (pm::Set<int>)pm::scalar2set(INT_INTOBJ( numb ) - 1);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/PolymakeInterface/src/polymake_matroid.cpp b/PolymakeInterface/src/polymake_matroid.cpp
|
||||||
|
index 4f33795b..5ea2e8d2 100644
|
||||||
|
--- a/PolymakeInterface/src/polymake_matroid.cpp
|
||||||
|
+++ b/PolymakeInterface/src/polymake_matroid.cpp
|
||||||
|
@@ -52,7 +52,7 @@ Obj REAL_CREATE_MATROID_ABSTRACT( Polymake_Data* data, Obj size, Obj elements ){
|
||||||
|
int current_length = LEN_PLIST( current_basis_list );
|
||||||
|
|
||||||
|
for( int i=1;i<=current_length;i++){
|
||||||
|
- incMatr[current_basis] += INT_INTOBJ( ELM_PLIST( current_basis_list, i ) ) - 1;
|
||||||
|
+ incMatr[current_basis] += (pm::Set<int>)pm::scalar2set(INT_INTOBJ( ELM_PLIST( current_basis_list, i ) ) - 1);
|
||||||
|
}
|
||||||
|
|
||||||
|
}
|
Loading…
Reference in a new issue