mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-aarch64-rc to 4.6.rc6-1
This commit is contained in:
parent
af5b35cc4b
commit
9a9a4299c5
6 changed files with 39 additions and 265 deletions
|
@ -1,7 +1,7 @@
|
||||||
From c789031f4cfa8c7933c9857dd86f4151dae63a65 Mon Sep 17 00:00:00 2001
|
From 2bda5e9a99a6302da09b214ab269eb783f0bf50e Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
From: Peter Robinson <pbrobinson@gmail.com>
|
||||||
Date: Sun, 3 May 2015 18:35:23 +0100
|
Date: Sun, 3 May 2015 18:35:23 +0100
|
||||||
Subject: [PATCH 1/4] arm64: acpi drop expert patch
|
Subject: [PATCH] arm64: acpi drop expert patch
|
||||||
|
|
||||||
---
|
---
|
||||||
drivers/acpi/Kconfig | 2 +-
|
drivers/acpi/Kconfig | 2 +-
|
||||||
|
@ -21,5 +21,5 @@ index 82b96ee..bf5dc1a 100644
|
||||||
select PNP
|
select PNP
|
||||||
default y
|
default y
|
||||||
--
|
--
|
||||||
2.7.0
|
2.8.0
|
||||||
|
|
||||||
|
|
|
@ -1,132 +0,0 @@
|
||||||
From bf131edcef6243ffad675d6aa010c89a8e0c7331 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kumar Gala <galak@codeaurora.org>
|
|
||||||
Date: Tue, 3 Mar 2015 15:39:07 -0600
|
|
||||||
Subject: [PATCH 2/4] devicetree: bindings: Document qcom,msm-id and
|
|
||||||
qcom,board-id
|
|
||||||
|
|
||||||
The top level qcom,msm-id and qcom,board-id are utilized by bootloaders
|
|
||||||
on Qualcomm MSM platforms to determine which device tree should be
|
|
||||||
utilized and passed to the kernel.
|
|
||||||
|
|
||||||
Cc: <devicetree@vger.kernel.org>
|
|
||||||
Signed-off-by: Kumar Gala <galak@codeaurora.org>
|
|
||||||
---
|
|
||||||
Documentation/devicetree/bindings/arm/msm/ids.txt | 65 +++++++++++++++++++++++
|
|
||||||
include/dt-bindings/arm/qcom-ids.h | 33 ++++++++++++
|
|
||||||
2 files changed, 98 insertions(+)
|
|
||||||
create mode 100644 Documentation/devicetree/bindings/arm/msm/ids.txt
|
|
||||||
create mode 100644 include/dt-bindings/arm/qcom-ids.h
|
|
||||||
|
|
||||||
diff --git a/Documentation/devicetree/bindings/arm/msm/ids.txt b/Documentation/devicetree/bindings/arm/msm/ids.txt
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..9ee8428
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/Documentation/devicetree/bindings/arm/msm/ids.txt
|
|
||||||
@@ -0,0 +1,65 @@
|
|
||||||
+* MSM-ID
|
|
||||||
+
|
|
||||||
+The qcom,msm-id entry specifies the MSM chipset and hardware revision. It can
|
|
||||||
+optionally be an array of these to indicate multiple hardware that use the same
|
|
||||||
+device tree. It is expected that the bootloader will use this information at
|
|
||||||
+boot-up to decide which device tree to use when given multiple device trees,
|
|
||||||
+some of which may not be compatible with the actual hardware. It is the
|
|
||||||
+bootloader's responsibility to pass the correct device tree to the kernel.
|
|
||||||
+
|
|
||||||
+PROPERTIES
|
|
||||||
+
|
|
||||||
+- qcom,msm-id:
|
|
||||||
+ Usage: required
|
|
||||||
+ Value type: <prop-encoded-array> (<chipset_id, rev_id> [, <c2, r2> ..])
|
|
||||||
+ Definition:
|
|
||||||
+ The "chipset_id" consists of three fields as below:
|
|
||||||
+
|
|
||||||
+ bits 0-15 = The unique MSM chipset id.
|
|
||||||
+ bits 16-31 = Reserved. Should be 0
|
|
||||||
+
|
|
||||||
+ chipset_id is an exact match value
|
|
||||||
+
|
|
||||||
+ The "rev_id" is a chipset specific 32-bit id that represents
|
|
||||||
+ the version of the chipset.
|
|
||||||
+
|
|
||||||
+ The rev_id is a best match id. The bootloader will look for
|
|
||||||
+ the closest possible patch.
|
|
||||||
+
|
|
||||||
+* BOARD-ID
|
|
||||||
+
|
|
||||||
+The qcom,board-id entry specifies the board type and revision information. It
|
|
||||||
+can optionally be an array of these to indicate multiple boards that use the
|
|
||||||
+same device tree. It is expected that the bootloader will use this information
|
|
||||||
+at boot-up to decide which device tree to use when given multiple device trees,
|
|
||||||
+some of which may not be compatible with the actual hardware. It is the
|
|
||||||
+bootloader's responsibility to pass the correct device tree to the kernel.
|
|
||||||
+
|
|
||||||
+PROPERTIES
|
|
||||||
+
|
|
||||||
+- qcom,board-id:
|
|
||||||
+ Usage: required
|
|
||||||
+ Value type: <prop-encoded-array> (<board_id, subtype_id> [, <b2, s2> ..])
|
|
||||||
+ Definition:
|
|
||||||
+ The "board_id" consists of three fields as below:
|
|
||||||
+
|
|
||||||
+ bits 31-24 = Unusued.
|
|
||||||
+ bits 23-16 = Platform Version Major
|
|
||||||
+ bits 15-8 = Platfrom Version Minor
|
|
||||||
+ bits 7-0 = Platform Type
|
|
||||||
+
|
|
||||||
+ Platform Type field is an exact match value. The Platform
|
|
||||||
+ Major/Minor field is a best match. The bootloader will look
|
|
||||||
+ for the closest possible match.
|
|
||||||
+
|
|
||||||
+ The "subtype_id" is unique to a Platform Type/Chipset ID. For
|
|
||||||
+ a given Platform Type, there will typically only be a single
|
|
||||||
+ board and the subtype_id will be 0. However in some cases board
|
|
||||||
+ variants may need to be distinquished by different subtype_id
|
|
||||||
+ values.
|
|
||||||
+
|
|
||||||
+ subtype_id is an exact match value.
|
|
||||||
+
|
|
||||||
+EXAMPLE:
|
|
||||||
+ qcom,board-id = <15 2>;
|
|
||||||
+ qcom,msm-id = <0x1007e 0>;
|
|
||||||
diff --git a/include/dt-bindings/arm/qcom-ids.h b/include/dt-bindings/arm/qcom-ids.h
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..a18f34e
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/include/dt-bindings/arm/qcom-ids.h
|
|
||||||
@@ -0,0 +1,33 @@
|
|
||||||
+/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
|
|
||||||
+ *
|
|
||||||
+ * This program is free software; you can redistribute it and/or modify
|
|
||||||
+ * it under the terms of the GNU General Public License version 2 and
|
|
||||||
+ * only version 2 as published by the Free Software Foundation.
|
|
||||||
+ *
|
|
||||||
+ * This program is distributed in the hope that it will be useful,
|
|
||||||
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
||||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
||||||
+ * GNU General Public License for more details.
|
|
||||||
+ */
|
|
||||||
+#ifndef __DT_BINDINGS_QCOM_IDS_H
|
|
||||||
+#define __DT_BINDINGS_QCOM_IDS_H
|
|
||||||
+
|
|
||||||
+/* qcom,msm-id */
|
|
||||||
+#define QCOM_ID_MSM8916 206
|
|
||||||
+#define QCOM_ID_APQ8016 247
|
|
||||||
+#define QCOM_ID_MSM8216 248
|
|
||||||
+#define QCOM_ID_MSM8116 249
|
|
||||||
+#define QCOM_ID_MSM8616 250
|
|
||||||
+
|
|
||||||
+/* qcom,board-id */
|
|
||||||
+#define QCOM_BRD_ID(a, major, minor) \
|
|
||||||
+ (((major & 0xff) << 16) | ((minor & 0xff) << 8) | QCOM_BRD_ID_##a)
|
|
||||||
+
|
|
||||||
+#define QCOM_BRD_ID_MTP 8
|
|
||||||
+#define QCOM_BRD_ID_DRAGONBRD 10
|
|
||||||
+#define QCOM_BRD_ID_SBC 24
|
|
||||||
+
|
|
||||||
+#define QCOM_BRD_SUBTYPE_DEFAULT 0
|
|
||||||
+#define QCOM_BRD_SUBTYPE_MTP8916_SMB1360 1
|
|
||||||
+
|
|
||||||
+#endif
|
|
||||||
--
|
|
||||||
2.7.0
|
|
||||||
|
|
|
@ -1,55 +0,0 @@
|
||||||
From 5a44db76201981d7afdc38ded3ff2100c8ec8370 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kumar Gala <galak@codeaurora.org>
|
|
||||||
Date: Wed, 11 Mar 2015 15:51:20 -0500
|
|
||||||
Subject: [PATCH 3/4] arm64: dts: Add Qualcomm MSM8916 & MTP8916 ids
|
|
||||||
|
|
||||||
Add qcom,msm-id and qcom,board-id to allow bootloader to identify which
|
|
||||||
device tree to boot on the MTP8916 boards.
|
|
||||||
|
|
||||||
Signed-off-by: Kumar Gala <galak@codeaurora.org>
|
|
||||||
---
|
|
||||||
arch/arm64/boot/dts/qcom/msm8916-mtp.dts | 3 +++
|
|
||||||
arch/arm64/boot/dts/qcom/msm8916.dtsi | 5 +++++
|
|
||||||
2 files changed, 8 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/arch/arm64/boot/dts/qcom/msm8916-mtp.dts b/arch/arm64/boot/dts/qcom/msm8916-mtp.dts
|
|
||||||
index b0a064d..2cdaa65 100644
|
|
||||||
--- a/arch/arm64/boot/dts/qcom/msm8916-mtp.dts
|
|
||||||
+++ b/arch/arm64/boot/dts/qcom/msm8916-mtp.dts
|
|
||||||
@@ -13,10 +13,13 @@
|
|
||||||
|
|
||||||
/dts-v1/;
|
|
||||||
|
|
||||||
+#include <dt-bindings/arm/qcom-ids.h>
|
|
||||||
#include "msm8916-mtp.dtsi"
|
|
||||||
|
|
||||||
/ {
|
|
||||||
model = "Qualcomm Technologies, Inc. MSM 8916 MTP";
|
|
||||||
compatible = "qcom,msm8916-mtp", "qcom,msm8916-mtp/1",
|
|
||||||
"qcom,msm8916", "qcom,mtp";
|
|
||||||
+ qcom,board-id = <QCOM_BRD_ID(MTP, 1, 0) QCOM_BRD_SUBTYPE_DEFAULT>,
|
|
||||||
+ <QCOM_BRD_ID(MTP, 1, 0) QCOM_BRD_SUBTYPE_MTP8916_SMB1360>;
|
|
||||||
};
|
|
||||||
diff --git a/arch/arm64/boot/dts/qcom/msm8916.dtsi b/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
|
||||||
index 9153214..719bd9f 100644
|
|
||||||
--- a/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
|
||||||
+++ b/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
|
||||||
@@ -14,10 +14,15 @@
|
|
||||||
#include <dt-bindings/interrupt-controller/arm-gic.h>
|
|
||||||
#include <dt-bindings/clock/qcom,gcc-msm8916.h>
|
|
||||||
#include <dt-bindings/reset/qcom,gcc-msm8916.h>
|
|
||||||
+#include <dt-bindings/arm/qcom-ids.h>
|
|
||||||
|
|
||||||
/ {
|
|
||||||
model = "Qualcomm Technologies, Inc. MSM8916";
|
|
||||||
compatible = "qcom,msm8916";
|
|
||||||
+ qcom,msm-id = <QCOM_ID_MSM8916 0>,
|
|
||||||
+ <QCOM_ID_MSM8216 0>,
|
|
||||||
+ <QCOM_ID_MSM8116 0>,
|
|
||||||
+ <QCOM_ID_MSM8616 0>;
|
|
||||||
|
|
||||||
interrupt-parent = <&intc>;
|
|
||||||
|
|
||||||
--
|
|
||||||
2.7.0
|
|
||||||
|
|
|
@ -1,50 +0,0 @@
|
||||||
From a3cc1740dc9a65fc2ce33eb128870cdd95ef5145 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andy Gross <agross@codeaurora.org>
|
|
||||||
Date: Tue, 31 Mar 2015 14:26:15 -0500
|
|
||||||
Subject: [PATCH 4/4] arm64: dts: qcom: Add APQ8016 SBC support
|
|
||||||
|
|
||||||
This patch set adds support for the APQ8016 SBC.
|
|
||||||
|
|
||||||
Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|
||||||
[Srinivas Kandagatla]: rebased on top of kumars original patch
|
|
||||||
Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
|
|
||||||
---
|
|
||||||
arch/arm64/boot/dts/qcom/apq8016-sbc.dts | 3 ++-
|
|
||||||
arch/arm64/boot/dts/qcom/msm8916.dtsi | 4 +++-
|
|
||||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/arch/arm64/boot/dts/qcom/apq8016-sbc.dts b/arch/arm64/boot/dts/qcom/apq8016-sbc.dts
|
|
||||||
index 825f489..b0cac53 100644
|
|
||||||
--- a/arch/arm64/boot/dts/qcom/apq8016-sbc.dts
|
|
||||||
+++ b/arch/arm64/boot/dts/qcom/apq8016-sbc.dts
|
|
||||||
@@ -12,10 +12,11 @@
|
|
||||||
*/
|
|
||||||
|
|
||||||
/dts-v1/;
|
|
||||||
-
|
|
||||||
+#include <dt-bindings/arm/qcom-ids.h>
|
|
||||||
#include "apq8016-sbc.dtsi"
|
|
||||||
|
|
||||||
/ {
|
|
||||||
model = "Qualcomm Technologies, Inc. APQ 8016 SBC";
|
|
||||||
compatible = "qcom,apq8016-sbc", "qcom,apq8016", "qcom,sbc";
|
|
||||||
+ qcom,board-id = <QCOM_BRD_ID(SBC, 1, 0) QCOM_BRD_SUBTYPE_DEFAULT>;
|
|
||||||
};
|
|
||||||
diff --git a/arch/arm64/boot/dts/qcom/msm8916.dtsi b/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
|
||||||
index 719bd9f..6716515 100644
|
|
||||||
--- a/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
|
||||||
+++ b/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
|
||||||
@@ -22,7 +22,9 @@
|
|
||||||
qcom,msm-id = <QCOM_ID_MSM8916 0>,
|
|
||||||
<QCOM_ID_MSM8216 0>,
|
|
||||||
<QCOM_ID_MSM8116 0>,
|
|
||||||
- <QCOM_ID_MSM8616 0>;
|
|
||||||
+ <QCOM_ID_MSM8616 0>,
|
|
||||||
+ <QCOM_ID_APQ8016 0>;
|
|
||||||
+
|
|
||||||
|
|
||||||
interrupt-parent = <&intc>;
|
|
||||||
|
|
||||||
--
|
|
||||||
2.7.0
|
|
||||||
|
|
|
@ -4,7 +4,7 @@
|
||||||
buildarch=8
|
buildarch=8
|
||||||
|
|
||||||
_rcver=4.6
|
_rcver=4.6
|
||||||
_rcrel=5
|
_rcrel=6
|
||||||
|
|
||||||
pkgbase=linux-aarch64-rc
|
pkgbase=linux-aarch64-rc
|
||||||
_srcname=linux-4.$((${_rcver##*.}-1))
|
_srcname=linux-4.$((${_rcver##*.}-1))
|
||||||
|
@ -22,18 +22,12 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||||
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz"
|
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz"
|
||||||
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
|
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
|
||||||
'0001-arm64-acpi-drop-expert-patch.patch'
|
'0001-arm64-acpi-drop-expert-patch.patch'
|
||||||
'0002-devicetree-bindings-Document-qcom-msm-id-and-qcom-bo.patch'
|
|
||||||
'0003-arm64-dts-Add-Qualcomm-MSM8916-MTP8916-ids.patch'
|
|
||||||
'0004-arm64-dts-qcom-Add-APQ8016-SBC-support.patch'
|
|
||||||
'config'
|
'config'
|
||||||
'linux.preset')
|
'linux.preset')
|
||||||
md5sums=('a60d48eee08ec0536d5efb17ca819aef'
|
md5sums=('a60d48eee08ec0536d5efb17ca819aef'
|
||||||
'c2b73e066519c911302f0dd8aaa9d2cd'
|
'60d2e4b5eeb4ff2b58cf85a03d9c6a4b'
|
||||||
'c8e84e01e8f88b47edba6a479942cc6e'
|
'dedf9caa72844bcf970f1515cd1bcfd5'
|
||||||
'66de90ece2f3dcae72ee4c27ddd37b38'
|
'7069d808d31ab122ef84dbb820e0e720'
|
||||||
'29d5fafca011d80a8cfbffb5ebbfd327'
|
|
||||||
'f2f044e19e0e8d5e81034e5870c644c7'
|
|
||||||
'610c127bb09d10a83864804dc8ba893a'
|
|
||||||
'25d8f6983c9a616946848c0e075a949c')
|
'25d8f6983c9a616946848c0e075a949c')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -44,9 +38,6 @@ prepare() {
|
||||||
|
|
||||||
# ALARM patches
|
# ALARM patches
|
||||||
git apply ../0001-arm64-acpi-drop-expert-patch.patch
|
git apply ../0001-arm64-acpi-drop-expert-patch.patch
|
||||||
git apply ../0002-devicetree-bindings-Document-qcom-msm-id-and-qcom-bo.patch
|
|
||||||
git apply ../0003-arm64-dts-Add-Qualcomm-MSM8916-MTP8916-ids.patch
|
|
||||||
git apply ../0004-arm64-dts-qcom-Add-APQ8016-SBC-support.patch
|
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
|
|
@ -63,6 +63,7 @@ CONFIG_GENERIC_IRQ_SHOW=y
|
||||||
CONFIG_GENERIC_IRQ_SHOW_LEVEL=y
|
CONFIG_GENERIC_IRQ_SHOW_LEVEL=y
|
||||||
CONFIG_GENERIC_IRQ_MIGRATION=y
|
CONFIG_GENERIC_IRQ_MIGRATION=y
|
||||||
CONFIG_HARDIRQS_SW_RESEND=y
|
CONFIG_HARDIRQS_SW_RESEND=y
|
||||||
|
CONFIG_GENERIC_IRQ_CHIP=y
|
||||||
CONFIG_IRQ_DOMAIN=y
|
CONFIG_IRQ_DOMAIN=y
|
||||||
CONFIG_IRQ_DOMAIN_HIERARCHY=y
|
CONFIG_IRQ_DOMAIN_HIERARCHY=y
|
||||||
CONFIG_GENERIC_MSI_IRQ=y
|
CONFIG_GENERIC_MSI_IRQ=y
|
||||||
|
@ -532,6 +533,7 @@ CONFIG_PM_DEBUG=y
|
||||||
CONFIG_PM_TEST_SUSPEND=y
|
CONFIG_PM_TEST_SUSPEND=y
|
||||||
CONFIG_PM_SLEEP_DEBUG=y
|
CONFIG_PM_SLEEP_DEBUG=y
|
||||||
# CONFIG_DPM_WATCHDOG is not set
|
# CONFIG_DPM_WATCHDOG is not set
|
||||||
|
CONFIG_PM_OPP=y
|
||||||
CONFIG_PM_CLK=y
|
CONFIG_PM_CLK=y
|
||||||
CONFIG_PM_GENERIC_DOMAINS=y
|
CONFIG_PM_GENERIC_DOMAINS=y
|
||||||
# CONFIG_WQ_POWER_EFFICIENT_DEFAULT is not set
|
# CONFIG_WQ_POWER_EFFICIENT_DEFAULT is not set
|
||||||
|
@ -547,7 +549,15 @@ CONFIG_ARCH_SUSPEND_POSSIBLE=y
|
||||||
#
|
#
|
||||||
# CPU Idle
|
# CPU Idle
|
||||||
#
|
#
|
||||||
# CONFIG_CPU_IDLE is not set
|
CONFIG_CPU_IDLE=y
|
||||||
|
CONFIG_CPU_IDLE_GOV_LADDER=y
|
||||||
|
CONFIG_CPU_IDLE_GOV_MENU=y
|
||||||
|
CONFIG_DT_IDLE_STATES=y
|
||||||
|
|
||||||
|
#
|
||||||
|
# ARM CPU Idle Drivers
|
||||||
|
#
|
||||||
|
CONFIG_ARM_CPUIDLE=y
|
||||||
# CONFIG_ARCH_NEEDS_CPU_IDLE_COUPLED is not set
|
# CONFIG_ARCH_NEEDS_CPU_IDLE_COUPLED is not set
|
||||||
|
|
||||||
#
|
#
|
||||||
|
@ -572,8 +582,10 @@ CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y
|
||||||
# CPU frequency scaling drivers
|
# CPU frequency scaling drivers
|
||||||
#
|
#
|
||||||
# CONFIG_CPUFREQ_DT is not set
|
# CONFIG_CPUFREQ_DT is not set
|
||||||
# CONFIG_ARM_BIG_LITTLE_CPUFREQ is not set
|
CONFIG_ARM_BIG_LITTLE_CPUFREQ=y
|
||||||
|
CONFIG_ARM_DT_BL_CPUFREQ=y
|
||||||
# CONFIG_ARM_KIRKWOOD_CPUFREQ is not set
|
# CONFIG_ARM_KIRKWOOD_CPUFREQ is not set
|
||||||
|
CONFIG_ARM_SCPI_CPUFREQ=y
|
||||||
CONFIG_ARM_TEGRA20_CPUFREQ=y
|
CONFIG_ARM_TEGRA20_CPUFREQ=y
|
||||||
CONFIG_ACPI_CPPC_CPUFREQ=y
|
CONFIG_ACPI_CPPC_CPUFREQ=y
|
||||||
CONFIG_NET=y
|
CONFIG_NET=y
|
||||||
|
@ -1484,6 +1496,7 @@ CONFIG_REGMAP_I2C=y
|
||||||
CONFIG_REGMAP_SPI=y
|
CONFIG_REGMAP_SPI=y
|
||||||
CONFIG_REGMAP_SPMI=y
|
CONFIG_REGMAP_SPMI=y
|
||||||
CONFIG_REGMAP_MMIO=y
|
CONFIG_REGMAP_MMIO=y
|
||||||
|
CONFIG_REGMAP_IRQ=y
|
||||||
CONFIG_DMA_SHARED_BUFFER=y
|
CONFIG_DMA_SHARED_BUFFER=y
|
||||||
# CONFIG_FENCE_TRACE is not set
|
# CONFIG_FENCE_TRACE is not set
|
||||||
CONFIG_DMA_CMA=y
|
CONFIG_DMA_CMA=y
|
||||||
|
@ -3028,7 +3041,7 @@ CONFIG_I2C_SCMI=y
|
||||||
# CONFIG_I2C_CADENCE is not set
|
# CONFIG_I2C_CADENCE is not set
|
||||||
# CONFIG_I2C_CBUS_GPIO is not set
|
# CONFIG_I2C_CBUS_GPIO is not set
|
||||||
CONFIG_I2C_DESIGNWARE_CORE=m
|
CONFIG_I2C_DESIGNWARE_CORE=m
|
||||||
# CONFIG_I2C_DESIGNWARE_PLATFORM is not set
|
CONFIG_I2C_DESIGNWARE_PLATFORM=m
|
||||||
CONFIG_I2C_DESIGNWARE_PCI=m
|
CONFIG_I2C_DESIGNWARE_PCI=m
|
||||||
# CONFIG_I2C_EMEV2 is not set
|
# CONFIG_I2C_EMEV2 is not set
|
||||||
CONFIG_I2C_GPIO=m
|
CONFIG_I2C_GPIO=m
|
||||||
|
@ -3174,7 +3187,7 @@ CONFIG_GPIO_GENERIC=y
|
||||||
# CONFIG_GPIO_74XX_MMIO is not set
|
# CONFIG_GPIO_74XX_MMIO is not set
|
||||||
# CONFIG_GPIO_ALTERA is not set
|
# CONFIG_GPIO_ALTERA is not set
|
||||||
# CONFIG_GPIO_AMDPT is not set
|
# CONFIG_GPIO_AMDPT is not set
|
||||||
# CONFIG_GPIO_DWAPB is not set
|
CONFIG_GPIO_DWAPB=y
|
||||||
CONFIG_GPIO_GENERIC_PLATFORM=y
|
CONFIG_GPIO_GENERIC_PLATFORM=y
|
||||||
# CONFIG_GPIO_GRGPIO is not set
|
# CONFIG_GPIO_GRGPIO is not set
|
||||||
CONFIG_GPIO_PL061=y
|
CONFIG_GPIO_PL061=y
|
||||||
|
@ -3291,8 +3304,8 @@ CONFIG_POWER_RESET_MSM=y
|
||||||
CONFIG_POWER_RESET_RESTART=y
|
CONFIG_POWER_RESET_RESTART=y
|
||||||
CONFIG_POWER_RESET_VEXPRESS=y
|
CONFIG_POWER_RESET_VEXPRESS=y
|
||||||
CONFIG_POWER_RESET_XGENE=y
|
CONFIG_POWER_RESET_XGENE=y
|
||||||
# CONFIG_POWER_RESET_SYSCON is not set
|
CONFIG_POWER_RESET_SYSCON=y
|
||||||
# CONFIG_POWER_RESET_SYSCON_POWEROFF is not set
|
CONFIG_POWER_RESET_SYSCON_POWEROFF=y
|
||||||
# CONFIG_POWER_AVS is not set
|
# CONFIG_POWER_AVS is not set
|
||||||
CONFIG_HWMON=y
|
CONFIG_HWMON=y
|
||||||
CONFIG_HWMON_VID=m
|
CONFIG_HWMON_VID=m
|
||||||
|
@ -3460,7 +3473,9 @@ CONFIG_THERMAL_GOV_BANG_BANG=y
|
||||||
CONFIG_THERMAL_GOV_USER_SPACE=y
|
CONFIG_THERMAL_GOV_USER_SPACE=y
|
||||||
CONFIG_THERMAL_GOV_POWER_ALLOCATOR=y
|
CONFIG_THERMAL_GOV_POWER_ALLOCATOR=y
|
||||||
CONFIG_CPU_THERMAL=y
|
CONFIG_CPU_THERMAL=y
|
||||||
# CONFIG_THERMAL_EMULATION is not set
|
# CONFIG_CLOCK_THERMAL is not set
|
||||||
|
# CONFIG_DEVFREQ_THERMAL is not set
|
||||||
|
CONFIG_THERMAL_EMULATION=y
|
||||||
CONFIG_HISI_THERMAL=y
|
CONFIG_HISI_THERMAL=y
|
||||||
# CONFIG_IMX_THERMAL is not set
|
# CONFIG_IMX_THERMAL is not set
|
||||||
# CONFIG_TEGRA_SOCTHERM is not set
|
# CONFIG_TEGRA_SOCTHERM is not set
|
||||||
|
@ -3589,7 +3604,7 @@ CONFIG_MFD_RTSX_USB=m
|
||||||
# CONFIG_MFD_RC5T583 is not set
|
# CONFIG_MFD_RC5T583 is not set
|
||||||
# CONFIG_MFD_RK808 is not set
|
# CONFIG_MFD_RK808 is not set
|
||||||
# CONFIG_MFD_RN5T618 is not set
|
# CONFIG_MFD_RN5T618 is not set
|
||||||
# CONFIG_MFD_SEC_CORE is not set
|
CONFIG_MFD_SEC_CORE=y
|
||||||
# CONFIG_MFD_SI476X_CORE is not set
|
# CONFIG_MFD_SI476X_CORE is not set
|
||||||
CONFIG_MFD_SM501=m
|
CONFIG_MFD_SM501=m
|
||||||
CONFIG_MFD_SM501_GPIO=y
|
CONFIG_MFD_SM501_GPIO=y
|
||||||
|
@ -3661,6 +3676,9 @@ CONFIG_REGULATOR_GPIO=y
|
||||||
CONFIG_REGULATOR_QCOM_RPM=y
|
CONFIG_REGULATOR_QCOM_RPM=y
|
||||||
CONFIG_REGULATOR_QCOM_SMD_RPM=y
|
CONFIG_REGULATOR_QCOM_SMD_RPM=y
|
||||||
CONFIG_REGULATOR_QCOM_SPMI=y
|
CONFIG_REGULATOR_QCOM_SPMI=y
|
||||||
|
# CONFIG_REGULATOR_S2MPA01 is not set
|
||||||
|
CONFIG_REGULATOR_S2MPS11=y
|
||||||
|
# CONFIG_REGULATOR_S5M8767 is not set
|
||||||
# CONFIG_REGULATOR_TPS51632 is not set
|
# CONFIG_REGULATOR_TPS51632 is not set
|
||||||
# CONFIG_REGULATOR_TPS62360 is not set
|
# CONFIG_REGULATOR_TPS62360 is not set
|
||||||
# CONFIG_REGULATOR_TPS65023 is not set
|
# CONFIG_REGULATOR_TPS65023 is not set
|
||||||
|
@ -5183,7 +5201,7 @@ CONFIG_MMC=y
|
||||||
# MMC/SD/SDIO Card Drivers
|
# MMC/SD/SDIO Card Drivers
|
||||||
#
|
#
|
||||||
CONFIG_MMC_BLOCK=y
|
CONFIG_MMC_BLOCK=y
|
||||||
CONFIG_MMC_BLOCK_MINORS=8
|
CONFIG_MMC_BLOCK_MINORS=32
|
||||||
CONFIG_MMC_BLOCK_BOUNCE=y
|
CONFIG_MMC_BLOCK_BOUNCE=y
|
||||||
CONFIG_SDIO_UART=m
|
CONFIG_SDIO_UART=m
|
||||||
# CONFIG_MMC_TEST is not set
|
# CONFIG_MMC_TEST is not set
|
||||||
|
@ -5353,6 +5371,7 @@ CONFIG_RTC_DRV_EM3027=m
|
||||||
CONFIG_RTC_DRV_RV3029C2=m
|
CONFIG_RTC_DRV_RV3029C2=m
|
||||||
CONFIG_RTC_DRV_RV3029_HWMON=y
|
CONFIG_RTC_DRV_RV3029_HWMON=y
|
||||||
# CONFIG_RTC_DRV_RV8803 is not set
|
# CONFIG_RTC_DRV_RV8803 is not set
|
||||||
|
# CONFIG_RTC_DRV_S5M is not set
|
||||||
|
|
||||||
#
|
#
|
||||||
# SPI RTC drivers
|
# SPI RTC drivers
|
||||||
|
@ -5673,13 +5692,14 @@ CONFIG_COMMON_CLK=y
|
||||||
CONFIG_COMMON_CLK_VERSATILE=y
|
CONFIG_COMMON_CLK_VERSATILE=y
|
||||||
CONFIG_CLK_SP810=y
|
CONFIG_CLK_SP810=y
|
||||||
CONFIG_CLK_VEXPRESS_OSC=y
|
CONFIG_CLK_VEXPRESS_OSC=y
|
||||||
# CONFIG_COMMON_CLK_SCPI is not set
|
CONFIG_COMMON_CLK_SCPI=y
|
||||||
# CONFIG_COMMON_CLK_SI5351 is not set
|
# CONFIG_COMMON_CLK_SI5351 is not set
|
||||||
# CONFIG_COMMON_CLK_SI514 is not set
|
# CONFIG_COMMON_CLK_SI514 is not set
|
||||||
# CONFIG_COMMON_CLK_SI570 is not set
|
# CONFIG_COMMON_CLK_SI570 is not set
|
||||||
# CONFIG_COMMON_CLK_CDCE706 is not set
|
# CONFIG_COMMON_CLK_CDCE706 is not set
|
||||||
# CONFIG_COMMON_CLK_CDCE925 is not set
|
# CONFIG_COMMON_CLK_CDCE925 is not set
|
||||||
# CONFIG_COMMON_CLK_CS2000_CP is not set
|
# CONFIG_COMMON_CLK_CS2000_CP is not set
|
||||||
|
# CONFIG_COMMON_CLK_S2MPS11 is not set
|
||||||
# CONFIG_CLK_QORIQ is not set
|
# CONFIG_CLK_QORIQ is not set
|
||||||
CONFIG_COMMON_CLK_XGENE=y
|
CONFIG_COMMON_CLK_XGENE=y
|
||||||
# CONFIG_COMMON_CLK_NXP is not set
|
# CONFIG_COMMON_CLK_NXP is not set
|
||||||
|
@ -5793,11 +5813,11 @@ CONFIG_EXTCON=y
|
||||||
# Extcon Device Drivers
|
# Extcon Device Drivers
|
||||||
#
|
#
|
||||||
CONFIG_EXTCON_ADC_JACK=m
|
CONFIG_EXTCON_ADC_JACK=m
|
||||||
CONFIG_EXTCON_GPIO=m
|
CONFIG_EXTCON_GPIO=y
|
||||||
# CONFIG_EXTCON_MAX3355 is not set
|
# CONFIG_EXTCON_MAX3355 is not set
|
||||||
# CONFIG_EXTCON_RT8973A is not set
|
# CONFIG_EXTCON_RT8973A is not set
|
||||||
# CONFIG_EXTCON_SM5502 is not set
|
# CONFIG_EXTCON_SM5502 is not set
|
||||||
CONFIG_EXTCON_USB_GPIO=m
|
CONFIG_EXTCON_USB_GPIO=y
|
||||||
# CONFIG_MEMORY is not set
|
# CONFIG_MEMORY is not set
|
||||||
CONFIG_IIO=y
|
CONFIG_IIO=y
|
||||||
CONFIG_IIO_BUFFER=y
|
CONFIG_IIO_BUFFER=y
|
||||||
|
|
Loading…
Reference in a new issue