mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-armv5 to 4.0.0-1
This commit is contained in:
parent
f96adb64c7
commit
9aa258a5dc
4 changed files with 283 additions and 305 deletions
|
@ -727,7 +727,7 @@ index 0000000..e5dcb4e
|
||||||
+static int pga_event(struct snd_soc_dapm_widget *w,
|
+static int pga_event(struct snd_soc_dapm_widget *w,
|
||||||
+ struct snd_kcontrol *kcontrol, int event)
|
+ struct snd_kcontrol *kcontrol, int event)
|
||||||
+{
|
+{
|
||||||
+ struct mxs_adc_priv *mxs_adc = snd_soc_codec_get_drvdata(w->codec);
|
+ struct mxs_adc_priv *mxs_adc = snd_soc_codec_get_drvdata(snd_soc_dapm_to_codec(w->dapm));
|
||||||
+
|
+
|
||||||
+ switch (event) {
|
+ switch (event) {
|
||||||
+ case SND_SOC_DAPM_PRE_PMU:
|
+ case SND_SOC_DAPM_PRE_PMU:
|
||||||
|
@ -753,7 +753,7 @@ index 0000000..e5dcb4e
|
||||||
+static int adc_event(struct snd_soc_dapm_widget *w,
|
+static int adc_event(struct snd_soc_dapm_widget *w,
|
||||||
+ struct snd_kcontrol *kcontrol, int event)
|
+ struct snd_kcontrol *kcontrol, int event)
|
||||||
+{
|
+{
|
||||||
+ struct mxs_adc_priv *mxs_adc = snd_soc_codec_get_drvdata(w->codec);
|
+ struct mxs_adc_priv *mxs_adc = snd_soc_codec_get_drvdata(snd_soc_dapm_to_codec(w->dapm));
|
||||||
+
|
+
|
||||||
+ switch (event) {
|
+ switch (event) {
|
||||||
+ case SND_SOC_DAPM_PRE_PMU:
|
+ case SND_SOC_DAPM_PRE_PMU:
|
||||||
|
|
|
@ -4,10 +4,10 @@
|
||||||
buildarch=2
|
buildarch=2
|
||||||
|
|
||||||
pkgbase=linux-armv5
|
pkgbase=linux-armv5
|
||||||
_srcname=linux-3.19
|
_srcname=linux-4.0
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="ARMv5 multi-platform"
|
_desc="ARMv5 multi-platform"
|
||||||
pkgver=3.19.3
|
pkgver=4.0.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=('arm')
|
arch=('arm')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
|
@ -15,37 +15,33 @@ license=('GPL2')
|
||||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
||||||
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
#"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
||||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
||||||
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
|
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
|
||||||
'0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch'
|
'0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch'
|
||||||
'0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
|
'0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
|
||||||
'0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
|
'0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
|
||||||
'0001-imx23-I2C-fixes.patch'
|
'0001-imx23-I2C-fixes.patch'
|
||||||
'archlinuxarm.patch'
|
|
||||||
'config')
|
'config')
|
||||||
md5sums=('d3fc8316d4d4d04b65cbc2d70799e763'
|
md5sums=('a86916bd12798220da9eb4a1eec3616d'
|
||||||
'1fec75551b2f55fced43df8394b1fd9a'
|
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'e3911eef007c122d23fd8ad7e91d69bf'
|
'114af68d721fdc22548994b847807929'
|
||||||
'3a1e689563354c2f9f2d2764e1baa334'
|
'3a1e689563354c2f9f2d2764e1baa334'
|
||||||
'a88071c80e1c2b22637894ae148c74b8'
|
'a88071c80e1c2b22637894ae148c74b8'
|
||||||
'e64077ce856769fc3af2a15ae95d8310'
|
'e64077ce856769fc3af2a15ae95d8310'
|
||||||
'e319a8e1a596a39a8951fc6454664b15'
|
'1b4db68ad21f2abee8824b3b449dad65')
|
||||||
'01476a17d426724da14cf0176ba06d5a')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
# add upstream patch
|
# add upstream patch
|
||||||
git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
|
#git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
|
||||||
|
|
||||||
# ALARM patches
|
# ALARM patches
|
||||||
git apply ../0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch
|
git apply ../0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch
|
||||||
git apply ../0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
|
git apply ../0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
|
||||||
git apply ../0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
|
git apply ../0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
|
||||||
git apply ../0001-imx23-I2C-fixes.patch
|
git apply ../0001-imx23-I2C-fixes.patch
|
||||||
patch -p1 -i ../archlinuxarm.patch
|
|
||||||
|
|
||||||
# AUFS patches
|
# AUFS patches
|
||||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||||
|
|
|
@ -1,80 +0,0 @@
|
||||||
diff -ruN a/drivers/ata/sata_mv.c b/drivers/ata/sata_mv.c
|
|
||||||
--- a/drivers/ata/sata_mv.c 2013-11-03 16:41:51.000000000 -0700
|
|
||||||
+++ b/drivers/ata/sata_mv.c 2013-11-08 01:39:48.868014917 -0700
|
|
||||||
@@ -71,6 +71,7 @@
|
|
||||||
#include <scsi/scsi_cmnd.h>
|
|
||||||
#include <scsi/scsi_device.h>
|
|
||||||
#include <linux/libata.h>
|
|
||||||
+#include <linux/leds.h>
|
|
||||||
|
|
||||||
#define DRV_NAME "sata_mv"
|
|
||||||
#define DRV_VERSION "1.28"
|
|
||||||
@@ -1161,6 +1162,8 @@
|
|
||||||
{
|
|
||||||
int want_ncq = (protocol == ATA_PROT_NCQ);
|
|
||||||
|
|
||||||
+ ledtrig_ide_activity();
|
|
||||||
+
|
|
||||||
if (pp->pp_flags & MV_PP_FLAG_EDMA_EN) {
|
|
||||||
int using_ncq = ((pp->pp_flags & MV_PP_FLAG_NCQ_EN) != 0);
|
|
||||||
if (want_ncq != using_ncq)
|
|
||||||
diff -ruN a/drivers/leds/trigger/Kconfig b/drivers/leds/trigger/Kconfig
|
|
||||||
--- a/drivers/leds/trigger/Kconfig 2013-11-03 16:41:51.000000000 -0700
|
|
||||||
+++ b/drivers/leds/trigger/Kconfig 2013-11-08 01:39:48.958018410 -0700
|
|
||||||
@@ -35,7 +35,6 @@
|
|
||||||
|
|
||||||
config LEDS_TRIGGER_IDE_DISK
|
|
||||||
bool "LED IDE Disk Trigger"
|
|
||||||
- depends on IDE_GD_ATA
|
|
||||||
depends on LEDS_TRIGGERS
|
|
||||||
help
|
|
||||||
This allows LEDs to be controlled by IDE disk activity.
|
|
||||||
diff -ruN a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
|
|
||||||
--- a/drivers/mmc/core/core.c 2013-11-03 16:41:51.000000000 -0700
|
|
||||||
+++ b/drivers/mmc/core/core.c 2013-11-08 01:39:49.008020351 -0700
|
|
||||||
@@ -805,7 +805,7 @@
|
|
||||||
*/
|
|
||||||
limit_us = 3000000;
|
|
||||||
else
|
|
||||||
- limit_us = 100000;
|
|
||||||
+ limit_us = 200000;
|
|
||||||
|
|
||||||
/*
|
|
||||||
* SDHC cards always use these fixed values.
|
|
||||||
diff -ruN a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
|
|
||||||
--- a/drivers/mmc/core/sd.c 2013-11-03 16:41:51.000000000 -0700
|
|
||||||
+++ b/drivers/mmc/core/sd.c 2013-11-08 01:39:49.008020351 -0700
|
|
||||||
@@ -358,6 +358,15 @@
|
|
||||||
return -ENOMEM;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ /*
|
|
||||||
+ * Some SDHC cards, notably those with a Sandisk SD controller
|
|
||||||
+ * (also found in Kingston products) need a bit of slack
|
|
||||||
+ * before successfully handling the SWITCH command. So far,
|
|
||||||
+ * cards identifying themselves as "SD04G" and "SD08G" are
|
|
||||||
+ * affected
|
|
||||||
+ */
|
|
||||||
+ udelay(100);
|
|
||||||
+
|
|
||||||
err = mmc_sd_switch(card, 1, 0, 1, status);
|
|
||||||
if (err)
|
|
||||||
goto out;
|
|
||||||
diff -ruN a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
|
||||||
--- a/drivers/mmc/host/mvsdio.c 2013-11-03 16:41:51.000000000 -0700
|
|
||||||
+++ b/drivers/mmc/host/mvsdio.c 2013-11-08 01:39:49.028021127 -0700
|
|
||||||
@@ -25,6 +25,7 @@
|
|
||||||
#include <linux/of_irq.h>
|
|
||||||
#include <linux/mmc/host.h>
|
|
||||||
#include <linux/mmc/slot-gpio.h>
|
|
||||||
+#include <linux/mmc/sd.h>
|
|
||||||
#include <linux/pinctrl/consumer.h>
|
|
||||||
|
|
||||||
#include <asm/sizes.h>
|
|
||||||
@@ -148,6 +149,7 @@
|
|
||||||
|
|
||||||
dev_dbg(host->dev, "cmd %d (hw state 0x%04x)\n",
|
|
||||||
cmd->opcode, mvsd_read(MVSD_HW_STATE));
|
|
||||||
+ if (cmd->opcode == SD_SWITCH) mdelay(1); /* Voodoo */
|
|
||||||
|
|
||||||
cmdreg = MVSD_CMD_INDEX(cmd->opcode);
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue