mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/gst-plugins-bad to 1.4.5-4
This commit is contained in:
parent
a70d80c5f6
commit
9ab972dff5
2 changed files with 50 additions and 4 deletions
|
@ -6,17 +6,28 @@
|
|||
|
||||
pkgname=gst-plugins-bad
|
||||
pkgver=1.4.5
|
||||
pkgrel=2
|
||||
pkgrel=4
|
||||
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('LGPL')
|
||||
url="http://gstreamer.freedesktop.org/"
|
||||
depends=('mjpegtools' 'gst-plugins-base-libs' 'curl' 'chromaprint' 'libmms' 'faad2' 'mpg123' 'faac' 'celt' 'libdca' 'soundtouch' 'spandsp' 'libdvdnav' 'libmodplug' 'libgme' 'opus' 'wayland' 'neon' 'libofa' 'fluidsynth' 'openjpeg' 'libwebp' 'libsrtp' 'gnutls' 'wildmidi' 'glu' 'sbc')
|
||||
depends=('mjpegtools' 'gst-plugins-base-libs' 'curl' 'chromaprint' 'libmms' 'faad2' 'mpg123' 'faac' 'celt' 'libdca' 'soundtouch' 'spandsp' 'libdvdnav' 'libmodplug' 'libgme' 'opus' 'wayland' 'neon' 'libofa' 'fluidsynth' 'openjpeg' 'libwebp' 'libsrtp' 'gnutls' 'wildmidi' 'glu' 'sbc' 'rtmpdump' 'libgudev')
|
||||
makedepends=('schroedinger' 'libexif' 'libdvdread' 'libvdpau' 'libmpeg2' 'python' 'wildmidi' 'librsvg'
|
||||
'gobject-introspection' 'gtk-doc' 'gtk3' 'clutter' 'opencv' 'libtiger' 'ladspa' 'openal' 'libusb')
|
||||
options=(!emptydirs)
|
||||
source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz)
|
||||
sha256sums=('152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c')
|
||||
source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz
|
||||
fix-faad2-version-check.patch)
|
||||
sha256sums=('152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c'
|
||||
'741492ae7a9518603fc51d87ae331d882f075547ea7fdec19c60f399085f18cc')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=748571
|
||||
patch -Np1 -i ../fix-faad2-version-check.patch
|
||||
|
||||
autoreconf -vi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
|
35
extra/gst-plugins-bad/fix-faad2-version-check.patch
Normal file
35
extra/gst-plugins-bad/fix-faad2-version-check.patch
Normal file
|
@ -0,0 +1,35 @@
|
|||
From 1f738ca5b8711ca5532a326cd646312e60484863 Mon Sep 17 00:00:00 2001
|
||||
From: Wim Taymans <wtaymans@redhat.com>
|
||||
Date: Wed, 13 May 2015 16:23:26 +0200
|
||||
Subject: fix faad2 version check
|
||||
|
||||
On fedora 22, the output of cpp inserts extra debug comments, which
|
||||
makes our regexp for the faad2 version check fail. This in turn causes
|
||||
it to compile with the wrong arguments passed which then causes stack
|
||||
corruption and crashes.
|
||||
|
||||
Fix this by only checking for the version (which should be by itself on
|
||||
a single line). This is potentially less safe, it might be possible that
|
||||
a similar string would appear in a later version in the header file.
|
||||
|
||||
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f5ce28c..d295253 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2008,9 +2008,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
|
||||
AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
|
||||
for minor in 10 9 8 7 6 5 0; do
|
||||
if test x$faad2_minor_version = "x"; then
|
||||
- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
|
||||
+ AC_EGREP_CPP([\"2\.$minor\"$], [
|
||||
#include <$faad_hdr>
|
||||
- GST_CHECK_FAAD_VERSION FAAD2_VERSION
|
||||
+ FAAD2_VERSION
|
||||
], [
|
||||
faad2_minor_version=$minor
|
||||
])
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
Loading…
Reference in a new issue