mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/chromium to 89.0.4389.114-1
This commit is contained in:
parent
f42eab08e4
commit
9adbc26fea
3 changed files with 93 additions and 140 deletions
|
@ -15,7 +15,7 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=89.0.4389.90
|
||||
pkgver=89.0.4389.114
|
||||
pkgrel=1
|
||||
_launcher_ver=7
|
||||
_gcc_patchset=7
|
||||
|
@ -36,19 +36,19 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
|
||||
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
|
||||
add-dependency-on-opus-in-webcodecs.patch
|
||||
x11-ozone-fix-two-edge-cases.patch
|
||||
chromium-glibc-2.33.patch
|
||||
chromium-fix-libva-redef.patch
|
||||
use-oauth2-client-switches-as-default.patch
|
||||
0001-crashpad-include-limits.patch
|
||||
0002-Fix-sandbox-Aw-snap-for-sycalls-403-and-407.patch
|
||||
0003-Run-blink-bindings-generation-single-threaded.patch
|
||||
0004-widevine-support-for-arm.patch)
|
||||
sha256sums=('11c6089c5fdd921216aa4eb34b52818a9b091cad655a24aed0982d29e65b279a'
|
||||
sha256sums=('f2f0abe9697a220a8545df74d832c6c8d85a4fb11845e7e398752d746e72ed00'
|
||||
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
|
||||
'f8b1558f6c87b33423da854d42f0f69d47885a96d6bf6ce7f26373e93d47442f'
|
||||
'b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121'
|
||||
'9e4743bdeaf5b668659ad53400e3977006916aac3a7ba045bbc750b7b4cbf274'
|
||||
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
|
||||
'de9eb3612d44616a500c2eccdffac814eb90ad9a868cc1030d17fc6783d544e2'
|
||||
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
|
||||
'112671743908fa9e69e30eb4ddc9539f76f2cc28a3b038df6b610e5b210a77d1'
|
||||
'4088c25d6441d360b5743f7ba9ec2dd3d5e94d38fb3b9ab11da99dd5f1110193'
|
||||
|
@ -123,9 +123,11 @@ prepare() {
|
|||
# https://crbug.com/1164975
|
||||
patch -Np1 -i ../chromium-glibc-2.33.patch
|
||||
|
||||
# https://github.com/kiss-community/repo-community/issues/246
|
||||
patch -Np1 -i ../chromium-fix-libva-redef.patch
|
||||
|
||||
# Upstream fixes
|
||||
patch -Np1 -i ../add-dependency-on-opus-in-webcodecs.patch
|
||||
patch -Np1 -i ../x11-ozone-fix-two-edge-cases.patch
|
||||
|
||||
# Fixes for building with libstdc++ instead of libc++
|
||||
patch -Np1 -i ../patches/chromium-89-quiche-dcheck.patch
|
||||
|
|
86
extra/chromium/chromium-fix-libva-redef.patch
Normal file
86
extra/chromium/chromium-fix-libva-redef.patch
Normal file
|
@ -0,0 +1,86 @@
|
|||
--- a/third_party/libva_protected_content/va_protected_content.h
|
||||
+++ b/third_party/libva_protected_content/va_protected_content.h
|
||||
@@ -132,19 +132,6 @@
|
||||
#define VA_PC_SAMPLE_TYPE_FULLSAMPLE 0x00000001
|
||||
#define VA_PC_SAMPLE_TYPE_SUBSAMPLE 0x00000002
|
||||
|
||||
-/** \brief TeeExec Function Codes. */
|
||||
-typedef enum _VA_TEE_EXEC_FUNCTION_ID {
|
||||
- VA_TEE_EXEC_TEE_FUNCID_PASS_THROUGH_NONE = 0x0,
|
||||
-
|
||||
- // 0x40000000~0x400000FFF reserved for TEE Exec GPU function
|
||||
- VA_TEE_EXEC_GPU_FUNCID_ENCRYPTION_BLT = 0x40000000,
|
||||
- VA_TEE_EXEC_GPU_FUNCID_DECRYPTION_BLT = 0x40000001,
|
||||
-
|
||||
- // 0x40001000~0x400001FFF reserved for TEE Exec TEE function
|
||||
- VA_TEE_EXEC_TEE_FUNCID_PASS_THROUGH = 0x40001000,
|
||||
-
|
||||
-} VA_TEE_EXEC_FUNCTION_ID;
|
||||
-
|
||||
/** \brief values for the encryption return status. */
|
||||
typedef enum {
|
||||
/** \brief Indicate encryption operation is successful.*/
|
||||
@@ -159,63 +146,6 @@
|
||||
VA_ENCRYPTION_STATUS_UNSUPPORT
|
||||
} VAEncryptionStatus;
|
||||
|
||||
-/** \brief structure for encrypted segment info. */
|
||||
-typedef struct _VAEncryptionSegmentInfo {
|
||||
- /** \brief The offset relative to the start of the bitstream input in
|
||||
- * bytes of the start of the segment*/
|
||||
- uint32_t segment_start_offset;
|
||||
- /** \brief The length of the segments in bytes*/
|
||||
- uint32_t segment_length;
|
||||
- /** \brief The length in bytes of the remainder of an incomplete block
|
||||
- * from a previous segment*/
|
||||
- uint32_t partial_aes_block_size;
|
||||
- /** \brief The length in bytes of the initial clear data */
|
||||
- uint32_t init_byte_length;
|
||||
- /** \brief This will be AES 128 counter for secure decode and secure
|
||||
- * encode when numSegments equals 1 */
|
||||
- uint8_t aes_cbc_iv_or_ctr[16];
|
||||
- /** \brief Reserved bytes for future use, must be zero */
|
||||
- uint32_t va_reserved[VA_PADDING_MEDIUM];
|
||||
-} VAEncryptionSegmentInfo;
|
||||
-
|
||||
-/** \brief encryption parameters, corresponding to
|
||||
- * #VAEncryptionParameterBufferType*/
|
||||
-typedef struct _VAEncryptionParameters {
|
||||
- /** \brief Encryption type, attribute values. */
|
||||
- uint32_t encryption_type;
|
||||
- /** \brief The number of sengments */
|
||||
- uint32_t num_segments;
|
||||
- /** \brief Pointer of segments */
|
||||
- VAEncryptionSegmentInfo* segment_info;
|
||||
- /** \brief The status report index for CENC workload.
|
||||
- * The value is to indicate CENC workload and needs to be
|
||||
- * different for each CENC workload */
|
||||
- uint32_t status_report_index;
|
||||
- /** \brief CENC counter length */
|
||||
- uint32_t size_of_length;
|
||||
- /** \brief Wrapped decrypt blob (Snd)kb */
|
||||
- uint8_t wrapped_decrypt_blob[16];
|
||||
- /** \brief Wrapped Key blob info (Sne)kb */
|
||||
- uint8_t wrapped_encrypt_blob[16];
|
||||
- /** \brief Indicates the number of 16-byte BLOCKS that are encrypted in any
|
||||
- * given encrypted region of segments.
|
||||
- * If this value is zero:
|
||||
- * 1. All bytes in encrypted region of segments are encrypted, i.e. the
|
||||
- * CENC or CBC1 scheme is being used
|
||||
- * 2. blocks_stripe_clear must also be zero.
|
||||
- * If this value is non-zero, blocks_stripe_clear must also be non-zero. */
|
||||
- uint32_t blocks_stripe_encrypted;
|
||||
- /** \brief Indicates the number of 16-byte BLOCKS that are clear in any given
|
||||
- * encrypted region of segments, as defined by the CENS and CBCS schemes in
|
||||
- * the common encryption spec.
|
||||
- * If this value is zero, all bytes in encrypted region of segments are
|
||||
- * encrypted, i.e. the CENC or CBC1 scheme is being used.
|
||||
- */
|
||||
- uint32_t blocks_stripe_clear;
|
||||
- /** \brief Reserved bytes for future use, must be zero */
|
||||
- uint32_t va_reserved[VA_PADDING_MEDIUM];
|
||||
-} VAEncryptionParameters;
|
||||
-
|
||||
/** \brief structure for VA_TEE_EXEC_GPU_FUNCID_ENCRYPTION_BLT */
|
||||
typedef struct _VA_PROTECTED_BLT_PARAMS {
|
||||
uint8_t* src_resource; // The source resource which contains the clear data.
|
|
@ -1,135 +0,0 @@
|
|||
From 5e3a738b1204941aab9f15c0eb3d06e20fefd96e Mon Sep 17 00:00:00 2001
|
||||
From: Scott Violet <sky@chromium.org>
|
||||
Date: Mon, 8 Mar 2021 21:07:39 +0000
|
||||
Subject: [PATCH] x11/ozone: fix two edge cases
|
||||
|
||||
WindowTreeHost::OnHostMovedInPixels() may trigger a nested message
|
||||
loop (tab dragging), which when the stack unravels means this may
|
||||
be deleted. This adds an early out if this happens.
|
||||
|
||||
X11WholeScreenMoveLoop has a similar issue, in so far as notifying
|
||||
the delegate may delete this.
|
||||
|
||||
BUG=1185482
|
||||
TEST=WindowTreeHostPlatform.DeleteHostFromOnHostMovedInPixels
|
||||
|
||||
Change-Id: Ieca1c90b3e4358da50b332abe2941fdbb50c5c25
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2743555
|
||||
Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
|
||||
Commit-Queue: Scott Violet <sky@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#860852}
|
||||
---
|
||||
ui/aura/window_tree_host_platform.cc | 10 ++++-
|
||||
ui/aura/window_tree_host_platform_unittest.cc | 40 ++++++++++++++++++-
|
||||
ui/base/x/x11_whole_screen_move_loop.cc | 4 ++
|
||||
3 files changed, 51 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/ui/aura/window_tree_host_platform.cc b/ui/aura/window_tree_host_platform.cc
|
||||
index ce8395fe07..7589542026 100644
|
||||
--- a/ui/aura/window_tree_host_platform.cc
|
||||
+++ b/ui/aura/window_tree_host_platform.cc
|
||||
@@ -214,13 +214,21 @@ void WindowTreeHostPlatform::OnBoundsChanged(const gfx::Rect& new_bounds) {
|
||||
float current_scale = compositor()->device_scale_factor();
|
||||
float new_scale = ui::GetScaleFactorForNativeView(window());
|
||||
gfx::Rect old_bounds = bounds_in_pixels_;
|
||||
+ auto weak_ref = GetWeakPtr();
|
||||
bounds_in_pixels_ = new_bounds;
|
||||
- if (bounds_in_pixels_.origin() != old_bounds.origin())
|
||||
+ if (bounds_in_pixels_.origin() != old_bounds.origin()) {
|
||||
OnHostMovedInPixels(bounds_in_pixels_.origin());
|
||||
+ // Changing the bounds may destroy this.
|
||||
+ if (!weak_ref)
|
||||
+ return;
|
||||
+ }
|
||||
if (bounds_in_pixels_.size() != old_bounds.size() ||
|
||||
current_scale != new_scale) {
|
||||
pending_size_ = gfx::Size();
|
||||
OnHostResizedInPixels(bounds_in_pixels_.size());
|
||||
+ // Changing the size may destroy this.
|
||||
+ if (!weak_ref)
|
||||
+ return;
|
||||
}
|
||||
DCHECK_GT(on_bounds_changed_recursion_depth_, 0);
|
||||
if (--on_bounds_changed_recursion_depth_ == 0) {
|
||||
diff --git a/ui/aura/window_tree_host_platform_unittest.cc b/ui/aura/window_tree_host_platform_unittest.cc
|
||||
index eda14e2f0c..4de039c88a 100644
|
||||
--- a/ui/aura/window_tree_host_platform_unittest.cc
|
||||
+++ b/ui/aura/window_tree_host_platform_unittest.cc
|
||||
@@ -34,7 +34,7 @@ class TestWindowTreeHost : public WindowTreeHostPlatform {
|
||||
// OnHostWill/DidProcessBoundsChange. Additionally, this triggers a bounds
|
||||
// change from within OnHostResized(). Such a scenario happens in production
|
||||
// code.
|
||||
-class TestWindowTreeHostObserver : public aura::WindowTreeHostObserver {
|
||||
+class TestWindowTreeHostObserver : public WindowTreeHostObserver {
|
||||
public:
|
||||
TestWindowTreeHostObserver(WindowTreeHostPlatform* host,
|
||||
ui::PlatformWindow* platform_window)
|
||||
@@ -51,7 +51,7 @@ class TestWindowTreeHostObserver : public aura::WindowTreeHostObserver {
|
||||
return on_host_will_process_bounds_change_count_;
|
||||
}
|
||||
|
||||
- // aura::WindowTreeHostObserver:
|
||||
+ // WindowTreeHostObserver:
|
||||
void OnHostResized(WindowTreeHost* host) override {
|
||||
if (!should_change_bounds_in_on_resized_)
|
||||
return;
|
||||
@@ -92,5 +92,41 @@ TEST_F(WindowTreeHostPlatformTest, HostWillProcessBoundsChangeRecursion) {
|
||||
EXPECT_EQ(1, observer.on_host_will_process_bounds_change_count());
|
||||
}
|
||||
|
||||
+// Deletes WindowTreeHostPlatform from OnHostMovedInPixels().
|
||||
+class DeleteHostWindowTreeHostObserver : public WindowTreeHostObserver {
|
||||
+ public:
|
||||
+ explicit DeleteHostWindowTreeHostObserver(
|
||||
+ std::unique_ptr<TestWindowTreeHost> host)
|
||||
+ : host_(std::move(host)) {
|
||||
+ host_->AddObserver(this);
|
||||
+ }
|
||||
+ ~DeleteHostWindowTreeHostObserver() override = default;
|
||||
+
|
||||
+ TestWindowTreeHost* host() { return host_.get(); }
|
||||
+
|
||||
+ // WindowTreeHostObserver:
|
||||
+ void OnHostMovedInPixels(WindowTreeHost* host,
|
||||
+ const gfx::Point& new_origin_in_pixels) override {
|
||||
+ host_->RemoveObserver(this);
|
||||
+ host_.reset();
|
||||
+ }
|
||||
+
|
||||
+ private:
|
||||
+ std::unique_ptr<TestWindowTreeHost> host_;
|
||||
+
|
||||
+ DISALLOW_COPY_AND_ASSIGN(DeleteHostWindowTreeHostObserver);
|
||||
+};
|
||||
+
|
||||
+// Verifies WindowTreeHostPlatform can be safely deleted when calling
|
||||
+// OnHostMovedInPixels().
|
||||
+// Regression test for https://crbug.com/1185482
|
||||
+TEST_F(WindowTreeHostPlatformTest, DeleteHostFromOnHostMovedInPixels) {
|
||||
+ std::unique_ptr<TestWindowTreeHost> host =
|
||||
+ std::make_unique<TestWindowTreeHost>();
|
||||
+ DeleteHostWindowTreeHostObserver observer(std::move(host));
|
||||
+ observer.host()->SetBoundsInPixels(gfx::Rect(1, 2, 3, 4));
|
||||
+ EXPECT_EQ(nullptr, observer.host());
|
||||
+}
|
||||
+
|
||||
} // namespace
|
||||
} // namespace aura
|
||||
diff --git a/ui/base/x/x11_whole_screen_move_loop.cc b/ui/base/x/x11_whole_screen_move_loop.cc
|
||||
index 5ed215db66..db678799db 100644
|
||||
--- a/ui/base/x/x11_whole_screen_move_loop.cc
|
||||
+++ b/ui/base/x/x11_whole_screen_move_loop.cc
|
||||
@@ -78,9 +78,13 @@ X11WholeScreenMoveLoop::~X11WholeScreenMoveLoop() {
|
||||
void X11WholeScreenMoveLoop::DispatchMouseMovement() {
|
||||
if (!last_motion_in_screen_)
|
||||
return;
|
||||
+ auto weak_ref = weak_factory_.GetWeakPtr();
|
||||
delegate_->OnMouseMovement(last_motion_in_screen_->root_location(),
|
||||
last_motion_in_screen_->flags(),
|
||||
last_motion_in_screen_->time_stamp());
|
||||
+ // The delegate may delete this during dispatch.
|
||||
+ if (!weak_ref)
|
||||
+ return;
|
||||
last_motion_in_screen_.reset();
|
||||
}
|
||||
|
Loading…
Reference in a new issue