removed extra/dhcp

This commit is contained in:
Kevin Mihelich 2022-03-11 00:07:32 +00:00
parent 77922d48e1
commit 9af5591f71
9 changed files with 0 additions and 347 deletions

View file

@ -1,13 +0,0 @@
diff --git a/client/scripts/linux b/client/scripts/linux
index 5fb16121..c4cef632 100755
--- a/client/scripts/linux
+++ b/client/scripts/linux
@@ -362,7 +362,7 @@ case "$reason" in
interface_up_wait_time=5
for i in $(seq 0 ${interface_up_wait_time})
do
- ifconfig ${interface} | grep RUNNING >/dev/null 2>&1
+ ${ip} link show dev ${interface} | grep -q LOWER_UP 2>&1
if [ $? -eq 0 ]; then
break;
fi

View file

@ -1,117 +0,0 @@
From 6c7e61578b1b449272dbb40dd8b98d03dad8a57a Mon Sep 17 00:00:00 2001
From: Thomas Markwalder <tmark@isc.org>
Date: Thu, 30 Jul 2020 10:01:36 -0400
Subject: [PATCH] [#117] Fixed gcc 10 compilation issues
client/dhclient.c
relay/dhcrelay.c
extern'ed local_port,remote_port
common/discover.c
init local_port,remote_port to 0
server/mdb.c
extern'ed dhcp_type_host
server/mdb6.c
create_prefix6() - eliminated memcpy string overflow error
---
RELNOTES | 5 +++++
client/dhclient.c | 5 +++--
common/discover.c | 4 ++--
relay/dhcrelay.c | 4 ++--
server/mdb.c | 2 +-
server/mdb6.c | 2 +-
6 files changed, 14 insertions(+), 8 deletions(-)
diff --git a/RELNOTES b/RELNOTES
index 9d0a0414..6919dba7 100644
--- a/RELNOTES
+++ b/RELNOTES
@@ -103,6 +103,11 @@ ISC DHCP is open source software maintained by Internet Systems
Consortium. This product includes cryptographic software written
by Eric Young (eay@cryptsoft.com).
+ Changes since 4.4.2 (Bug Fixes)
+
+- Minor corrections to allow compilation under gcc 10.
+ [Gitlab #117]
+
Changes since 4.4.2b1 (Bug Fixes)
- Added a clarification on DHCPINFORMs and server authority to
diff --git a/client/dhclient.c b/client/dhclient.c
index 189e5270..7a7837cb 100644
--- a/client/dhclient.c
+++ b/client/dhclient.c
@@ -83,8 +83,9 @@ static const char message [] = "Internet Systems Consortium DHCP Client";
static const char url [] = "For info, please visit https://www.isc.org/software/dhcp/";
#endif /* UNIT_TEST */
-u_int16_t local_port = 0;
-u_int16_t remote_port = 0;
+extern u_int16_t local_port;
+extern u_int16_t remote_port;
+
#if defined(DHCPv6) && defined(DHCP4o6)
int dhcp4o6_state = -1; /* -1 = stopped, 0 = polling, 1 = started */
#endif
diff --git a/common/discover.c b/common/discover.c
index ca4f4d55..22f09767 100644
--- a/common/discover.c
+++ b/common/discover.c
@@ -45,8 +45,8 @@ struct interface_info *fallback_interface = 0;
int interfaces_invalidated;
int quiet_interface_discovery;
-u_int16_t local_port;
-u_int16_t remote_port;
+u_int16_t local_port = 0;
+u_int16_t remote_port = 0;
u_int16_t relay_port = 0;
int dhcpv4_over_dhcpv6 = 0;
int (*dhcp_interface_setup_hook) (struct interface_info *, struct iaddr *);
diff --git a/relay/dhcrelay.c b/relay/dhcrelay.c
index 883d5058..7211e3bb 100644
--- a/relay/dhcrelay.c
+++ b/relay/dhcrelay.c
@@ -95,8 +95,8 @@ enum { forward_and_append, /* Forward and append our own relay option. */
forward_untouched, /* Forward without changes. */
discard } agent_relay_mode = forward_and_replace;
-u_int16_t local_port;
-u_int16_t remote_port;
+extern u_int16_t local_port;
+extern u_int16_t remote_port;
/* Relay agent server list. */
struct server_list {
diff --git a/server/mdb.c b/server/mdb.c
index ff8a707f..8266d764 100644
--- a/server/mdb.c
+++ b/server/mdb.c
@@ -67,7 +67,7 @@ static host_id_info_t *host_id_info = NULL;
int numclasseswritten;
-omapi_object_type_t *dhcp_type_host;
+extern omapi_object_type_t *dhcp_type_host;
isc_result_t enter_class(cd, dynamicp, commit)
struct class *cd;
diff --git a/server/mdb6.c b/server/mdb6.c
index da7baf6e..ebe01e56 100644
--- a/server/mdb6.c
+++ b/server/mdb6.c
@@ -1945,7 +1945,7 @@ create_prefix6(struct ipv6_pool *pool, struct iasubopt **pref,
}
new_ds.data = new_ds.buffer->data;
memcpy(new_ds.buffer->data, ds.data, ds.len);
- memcpy(new_ds.buffer->data + ds.len, &tmp, sizeof(tmp));
+ memcpy(&new_ds.buffer->data[0] + ds.len, &tmp, sizeof(tmp));
data_string_forget(&ds, MDL);
data_string_copy(&ds, &new_ds, MDL);
data_string_forget(&new_ds, MDL);
--
GitLab

View file

@ -1,125 +0,0 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Daniel Isenmann <daniel @archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch FTBFS in bundled bind when built without atomics
# - disable atomics on v5/v6
# - above changes can probably be removed once bundled bind moves beyond 9.11.14
pkgbase=dhcp
pkgname=('dhcp' 'dhclient')
# separate patch levels with a period to maintain proper versioning.
_realver=4.4.2-P1
pkgver=${_realver/-/.}
pkgrel=4
arch=('x86_64')
license=('custom:isc-dhcp')
url='https://www.isc.org/dhcp/'
makedepends=('bash' 'iproute2' 'openldap')
options=('!lto')
validpgpkeys=('7E1C91AC8030A5A59D1EFAB9750F3C87723E4012') # Internet Systems Consortium, Inc. (Signing key, 2021-2022) <codesign@isc.org>
source=("https://downloads.isc.org/isc/${pkgbase}/${_realver}/${pkgbase}-${_realver}.tar.gz"{,.asc}
'0002-iproute2.patch'
'0003-117-fixed-gcc-10-compilation-issues.patch'
'fix-variable-name-in-conditional-block.patch'
'dhcp-sysusers.conf'
'dhcp-tmpfiles.conf'
'dhcpd4.service'
'dhcpd6.service'
'dhclient@.service')
sha256sums=('b05e04337539545a8faa0d6ac518defc61a07e5aec66a857f455e7f218c85a1a'
'SKIP'
'837a64189b949afae951655546967cc8f17f2f2cf370faabff00575364f0fcf7'
'ab652f408a0730caa996df11bea608f279c5547acc849d5562a592ea19f67727'
'895e655f320f3de0053d512d1915a3706f710f24c560ad811a48593a16ef3b34'
'b16083e6bb572ffacaa7cd97e7fde5fcfa1b6dbeb166f162e2ec6e8ec4b928d6'
'abcd30e9e8428e34d22ab4d3074ef4bd84c2b11f5868597111b47d6f56d204da'
'03fce30efab819b2d928085b0bab962a33ce56fc376acae98ad9b30aa278c9c8'
'f98a4438f4f69cab7cc5cce6927df4790ee993ebc8f88a169e63043c53d25625'
'86cd0b1e0ea1d47ab096f6ee925eee60545116fb887a155761eda589b30e4f0e')
prepare() {
cd "${srcdir}/${pkgbase}-${_realver}"
# no ifconfig, use ip from iproute2
patch -Np1 -i ../0002-iproute2.patch
# [#117] Fixed gcc 10 compilation issues
patch -Np1 -i ../0003-117-fixed-gcc-10-compilation-issues.patch
cd bind
bsdtar -xf bind.tar.gz
cd bind-9.*
patch -p1 -i "${srcdir}/fix-variable-name-in-conditional-block.patch"
}
build() {
cd "${srcdir}/${pkgbase}-${_realver}"
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG='--with-bind-extra-config="--disable-atomic"'
./configure \
--prefix=/usr \
--sbindir=/usr/bin \
--sysconfdir=/etc \
--enable-binary-leases \
--enable-paranoia \
--with-ldap \
--with-ldapcrypto \
--with-srv-lease-file=/var/lib/dhcp/dhcpd.leases \
--with-srv6-lease-file=/var/lib/dhcp/dhcpd6.leases \
--with-cli-lease-file=/var/lib/dhclient/dhclient.leases \
--with-cli6-lease-file=/var/lib/dhclient/dhclient6.leases $CONFIG
make -j1
}
package_dhcp(){
pkgdesc="A DHCP server, client, and relay agent"
depends=('glibc' 'libldap')
backup=('etc/dhcpd.conf' 'etc/dhcpd6.conf')
cd "${srcdir}/${pkgbase}-${_realver}"
make DESTDIR="${pkgdir}" install
install -D -m644 "${srcdir}/dhcp-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/dhcp.conf"
install -D -m644 "${srcdir}/dhcp-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/dhcp.conf"
install -D -m644 "${srcdir}/dhcpd4.service" "${pkgdir}/usr/lib/systemd/system/dhcpd4.service"
install -D -m644 "${srcdir}/dhcpd6.service" "${pkgdir}/usr/lib/systemd/system/dhcpd6.service"
# move and install config files in place
mv "${pkgdir}/etc/dhcpd.conf.example" "${pkgdir}/etc/dhcpd.conf"
install -D -m644 doc/examples/dhcpd-dhcpv6.conf "${pkgdir}/etc/dhcpd6.conf"
# Remove dhclient
make -C client DESTDIR="${pkgdir}" uninstall
# install license
install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/dhcp/LICENSE"
}
package_dhclient(){
pkgdesc="A standalone DHCP client from the dhcp package"
depends=('glibc' 'bash' 'iproute2' 'run-parts')
provides=('dhcp-client')
cd "${srcdir}/${pkgbase}-${_realver}"
make -C client DESTDIR="${pkgdir}" install
install -m755 -d "${pkgdir}/usr/share/dhclient"
mv "${pkgdir}/etc/dhclient.conf.example" "${pkgdir}/usr/share/dhclient/"
install -d "${pkgdir}/var/lib/dhclient"
# install dhclient linux script
install -m755 client/scripts/linux "${pkgdir}/usr/bin/dhclient-script"
# install license
install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/dhclient/LICENSE"
# install systemd service unit
install -m644 -D "$srcdir/dhclient@.service" "${pkgdir}/usr/lib/systemd/system/dhclient@.service"
}

View file

@ -1,13 +0,0 @@
[Unit]
Description=dhclient on %I
Wants=network.target
Before=network.target
[Service]
ExecStart=/usr/bin/dhclient -pf /run/dhclient@%i/dhclient.pid -d %I
RuntimeDirectory=dhclient@%i
ProtectSystem=on
ProtectHome=on
[Install]
WantedBy=multi-user.target

View file

@ -1 +0,0 @@
u dhcp - "DHCP daemon" /

View file

@ -1,3 +0,0 @@
d /var/lib/dhcp 0750 dhcp dhcp -
f /var/lib/dhcp/dhcpd.leases 0640 dhcp dhcp -
f /var/lib/dhcp/dhcpd6.leases 0640 dhcp dhcp -

View file

@ -1,25 +0,0 @@
[Unit]
Description=IPv4 DHCP server
After=network.target network-online.target
Wants=network-online.target
[Service]
Type=forking
ExecStart=/usr/bin/dhcpd -4 -q -cf /etc/dhcpd.conf -pf /run/dhcpd4/dhcpd.pid
RuntimeDirectory=dhcpd4
PIDFile=/run/dhcpd4/dhcpd.pid
User=dhcp
AmbientCapabilities=CAP_NET_BIND_SERVICE CAP_NET_RAW
ProtectSystem=full
ProtectHome=on
KillSignal=SIGINT
# We pull in network-online.target for a configured network connection.
# However this is not guaranteed to be the network connection our
# networks are configured for. So try to restart on failure with a delay
# of two seconds. Rate limiting kicks in after 12 seconds.
RestartSec=2s
Restart=on-failure
StartLimitInterval=12s
[Install]
WantedBy=multi-user.target

View file

@ -1,25 +0,0 @@
[Unit]
Description=IPv6 DHCP server
After=network.target network-online.target
Wants=network-online.target
[Service]
Type=forking
ExecStart=/usr/bin/dhcpd -6 -q -cf /etc/dhcpd6.conf -pf /run/dhcpd6/dhcpd.pid
RuntimeDirectory=dhcpd6
PIDFile=/run/dhcpd6/dhcpd.pid
User=dhcp
AmbientCapabilities=CAP_NET_BIND_SERVICE CAP_NET_RAW
ProtectSystem=full
ProtectHome=on
KillSignal=SIGINT
# We pull in network-online.target for a configured network connection.
# However this is not guaranteed to be the network connection our
# networks are configured for. So try to restart on failure with a delay
# of two seconds. Rate limiting kicks in after 12 seconds.
RestartSec=2s
Restart=on-failure
StartLimitInterval=12s
[Install]
WantedBy=multi-user.target

View file

@ -1,25 +0,0 @@
From 261c84d91d1b4581df9f7f0ec031908299de7726 Mon Sep 17 00:00:00 2001
From: Mark Andrews <marka@isc.org>
Date: Thu, 19 Dec 2019 09:27:44 +1100
Subject: [PATCH] fix variable name in conditional block
---
lib/isc/stats.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/isc/stats.c b/lib/isc/stats.c
index 5bce3c1100..a7ab97ce53 100644
--- a/lib/isc/stats.c
+++ b/lib/isc/stats.c
@@ -297,7 +297,7 @@ setcounter(isc_stats_t *stats,
isc_atomic_store((int32_t *)&stats->counters[counter].lo,
(uint32_t)(value & 0xffffffff));
# else
- stats->counters[counter] = val;
+ stats->counters[counter] = value;
# endif
#endif
}
--
2.24.1