mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed extra/ruby
This commit is contained in:
parent
8a35dac6f4
commit
9af6ed5dd6
2 changed files with 0 additions and 143 deletions
|
@ -1,39 +0,0 @@
|
|||
From bc148b24448c68bc2720a10db4424d8a6d5772b3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 14 Jan 2019 21:34:02 -0700
|
||||
Subject: [PATCH] Use only unsigned long for rb_serial_t
|
||||
|
||||
---
|
||||
internal.h | 12 ------------
|
||||
1 file changed, 12 deletions(-)
|
||||
|
||||
diff --git a/internal.h b/internal.h
|
||||
index baefb36c02..f57dc911ef 100644
|
||||
--- a/internal.h
|
||||
+++ b/internal.h
|
||||
@@ -1000,22 +1000,10 @@ struct rb_subclass_entry {
|
||||
rb_subclass_entry_t *next;
|
||||
};
|
||||
|
||||
-#if defined(HAVE_LONG_LONG)
|
||||
-typedef unsigned LONG_LONG rb_serial_t;
|
||||
-#define SERIALT2NUM ULL2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_LL_PREFIX
|
||||
-#define SIZEOF_SERIAL_T SIZEOF_LONG_LONG
|
||||
-#elif defined(HAVE_UINT64_T)
|
||||
-typedef uint64_t rb_serial_t;
|
||||
-#define SERIALT2NUM SIZET2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_64_PREFIX
|
||||
-#define SIZEOF_SERIAL_T SIZEOF_UINT64_T
|
||||
-#else
|
||||
typedef unsigned long rb_serial_t;
|
||||
#define SERIALT2NUM ULONG2NUM
|
||||
#define PRI_SERIALT_PREFIX PRI_LONG_PREFIX
|
||||
#define SIZEOF_SERIAL_T SIZEOF_LONG
|
||||
-#endif
|
||||
|
||||
struct rb_classext_struct {
|
||||
struct st_table *iv_index_tbl;
|
||||
--
|
||||
2.24.1
|
||||
|
|
@ -1,104 +0,0 @@
|
|||
# Contributor: Thomas Dziedzic <gostrc@gmail.com>
|
||||
# Contributor: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: John Proctor <jproctor@prium.net>
|
||||
# Contributor: Jeramy Rutley <jrutley@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix running ruby on 32-bit ARM
|
||||
|
||||
pkgname=(ruby ruby-docs)
|
||||
pkgver=2.7.2
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
url='https://www.ruby-lang.org/en/'
|
||||
license=(BSD custom)
|
||||
depends=(libxcrypt)
|
||||
makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
|
||||
options=(!emptydirs)
|
||||
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
|
||||
0001-Use-only-unsigned-long-for-rb_serial_t.patch)
|
||||
sha512sums=('7972278b096aa768c7adf2befd26003e18781a29ca317640317d30d93d6e963ded197724c8e2f1dfe1e838c5647176d414a74732a62e931fb50d6f2e0f777349'
|
||||
'ae1a9e00ab3bfb1bf29cda872ddf6d64dd6ec5745bd25f00e3692a1d769dd81bbce8921ed63e0f5776ec3e610655087b739fde26ede9649c6c2e095b27381926')
|
||||
|
||||
prepare() {
|
||||
cd ruby-${pkgver}
|
||||
# remove bundled gems, we are going to ship them as separate packages
|
||||
rm -rf gems/
|
||||
# fixes https://bugs.ruby-lang.org/issues/9507
|
||||
[[ $CARCH == 'arm' ]] && patch -Np1 -i ../0001-Use-only-unsigned-long-for-rb_serial_t.patch || true
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ruby-${pkgver}
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--sharedstatedir=/var/lib \
|
||||
--libexecdir=/usr/lib/ruby \
|
||||
--enable-shared \
|
||||
--disable-rpath \
|
||||
--with-dbm-type=gdbm_compat
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd ruby-${pkgver}
|
||||
|
||||
make test
|
||||
}
|
||||
|
||||
package_ruby() {
|
||||
pkgdesc='An object-oriented language for quick and easy programming'
|
||||
depends=(gdbm openssl libffi libyaml gmp zlib rubygems ruby-irb)
|
||||
optdepends=(
|
||||
'ruby-docs: Ruby documentation'
|
||||
'tk: for Ruby/TK'
|
||||
)
|
||||
|
||||
cd ruby-${pkgver}
|
||||
|
||||
make DESTDIR="${pkgdir}" install-nodoc
|
||||
|
||||
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/ruby/LICENSE"
|
||||
install -D -m644 BSDL "${pkgdir}/usr/share/licenses/ruby/BSDL"
|
||||
|
||||
rubyver=${pkgver:0:3}.0
|
||||
|
||||
# remove rubygems as it shipped as a separate package
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{rubygems,rubygems.rb}
|
||||
rm "${pkgdir}"/usr/bin/gem
|
||||
|
||||
# remove bundler as it shipped as a separate package
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{bundler,bundler.rb}
|
||||
rm "${pkgdir}"/usr/bin/{bundle,bundler}
|
||||
rm "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/specifications/default/bundler-*.gemspec
|
||||
rm "${pkgdir}"/usr/share/man/man1/{bundle,bundle-*}.1
|
||||
|
||||
# remove bundled rdoc gem
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{rdoc,rdoc.rb}
|
||||
rm "${pkgdir}"/usr/bin/{rdoc,ri}
|
||||
rm "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/specifications/default/rdoc-*.gemspec
|
||||
|
||||
# remove irb as it is a separate package now
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/${rubyver}/{irb,irb.rb}
|
||||
rm "${pkgdir}"/usr/bin/irb
|
||||
rm "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/specifications/default/irb-*.gemspec
|
||||
rm "${pkgdir}"/usr/share/man/man1/irb.1
|
||||
|
||||
# remove all bundled gems to avoid conflicts with ruby-* Arch packages
|
||||
rm -r "${pkgdir}"/usr/lib/ruby/gems/${rubyver}/gems/*
|
||||
}
|
||||
|
||||
package_ruby-docs() {
|
||||
pkgdesc='Documentation files for ruby'
|
||||
|
||||
cd ruby-${pkgver}
|
||||
|
||||
make DESTDIR="${pkgdir}" install-doc install-capi
|
||||
|
||||
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/ruby-docs/LICENSE"
|
||||
install -D -m644 BSDL "${pkgdir}/usr/share/licenses/ruby-docs/BSDL"
|
||||
}
|
Loading…
Reference in a new issue