mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/rust to 1.61.0-1
This commit is contained in:
parent
355b4adb9d
commit
9af8a069dd
5 changed files with 28 additions and 25 deletions
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||||
index f5ae8103cb05..a41a80a6c359 100644
|
index be965971dbb6..f3fa15a8e2de 100644
|
||||||
--- a/src/bootstrap/dist.rs
|
--- a/src/bootstrap/dist.rs
|
||||||
+++ b/src/bootstrap/dist.rs
|
+++ b/src/bootstrap/dist.rs
|
||||||
@@ -981,7 +981,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
@@ -976,7 +976,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||||
let dirent = dirent.expect("read dir entry");
|
let dirent = dirent.expect("read dir entry");
|
||||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||||
|
|
|
@ -8,10 +8,10 @@ Subject: [PATCH] cargo: Change libexec dir
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/src/cargo/ops/registry/auth.rs b/src/cargo/ops/registry/auth.rs
|
diff --git a/src/cargo/ops/registry/auth.rs b/src/cargo/ops/registry/auth.rs
|
||||||
index d10b1988e920..b58e05857233 100644
|
index 648e051e6dc2..a7b24e07e552 100644
|
||||||
--- a/src/cargo/ops/registry/auth.rs
|
--- a/src/cargo/ops/registry/auth.rs
|
||||||
+++ b/src/cargo/ops/registry/auth.rs
|
+++ b/src/cargo/ops/registry/auth.rs
|
||||||
@@ -223,7 +223,7 @@ fn sysroot_credential(
|
@@ -224,7 +224,7 @@ fn sysroot_credential(
|
||||||
.parent()
|
.parent()
|
||||||
.and_then(|p| p.parent())
|
.and_then(|p| p.parent())
|
||||||
.ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;
|
.ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;
|
||||||
|
|
|
@ -24,11 +24,11 @@ targets, as things break when this is done:
|
||||||
4 files changed, 12 insertions(+), 3 deletions(-)
|
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||||
index 7a0d9a212c9d..a53bd70b224a 100644
|
index 4182a5d07118..0556c95d5b5b 100644
|
||||||
--- a/compiler/rustc_session/src/config.rs
|
--- a/compiler/rustc_session/src/config.rs
|
||||||
+++ b/compiler/rustc_session/src/config.rs
|
+++ b/compiler/rustc_session/src/config.rs
|
||||||
@@ -1741,7 +1741,7 @@ pub fn parse_target_triple(
|
@@ -1847,7 +1847,7 @@ pub fn parse_target_triple(
|
||||||
early_error(error_format, &format!("target file {:?} does not exist", path))
|
early_error(error_format, &format!("target file {path:?} does not exist"))
|
||||||
})
|
})
|
||||||
}
|
}
|
||||||
- Some(target) => TargetTriple::TargetTriple(target),
|
- Some(target) => TargetTriple::TargetTriple(target),
|
||||||
|
@ -37,23 +37,23 @@ index 7a0d9a212c9d..a53bd70b224a 100644
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||||
index 165505ee7313..00a7f5c2f8c1 100644
|
index 0998c618f31a..91c79c7e4ff0 100644
|
||||||
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||||
@@ -9,7 +9,7 @@ pub fn target() -> Target {
|
@@ -9,7 +9,7 @@ pub fn target() -> Target {
|
||||||
base.stack_probes = StackProbeType::Call;
|
base.stack_probes = StackProbeType::Call;
|
||||||
|
|
||||||
Target {
|
Target {
|
||||||
- llvm_target: "i686-unknown-linux-gnu".to_string(),
|
- llvm_target: "i686-unknown-linux-gnu".into(),
|
||||||
+ llvm_target: "i686-pc-linux-gnu".to_string(),
|
+ llvm_target: "i686-pc-linux-gnu".into(),
|
||||||
pointer_width: 32,
|
pointer_width: 32,
|
||||||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||||
f64:32:64-f80:32-n8:16:32-S128"
|
f64:32:64-f80:32-n8:16:32-S128"
|
||||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||||
index 92678aed5b1a..52714d175dcc 100644
|
index bd5b712c143c..a78d0c20aa5d 100644
|
||||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||||
@@ -2392,6 +2392,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
@@ -2424,6 +2424,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||||
Ok(TargetTriple::TargetPath(canonicalized_path))
|
Ok(TargetTriple::TargetPath(canonicalized_path))
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -70,15 +70,15 @@ index 92678aed5b1a..52714d175dcc 100644
|
||||||
///
|
///
|
||||||
/// If this target is a path, the file name (without extension) is returned.
|
/// If this target is a path, the file name (without extension) is returned.
|
||||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||||
index aefbb398286a..6d902647eeea 100644
|
index e525cfdde14f..2dfe25f4f238 100644
|
||||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||||
@@ -15,7 +15,7 @@ pub fn target() -> Target {
|
@@ -15,7 +15,7 @@ pub fn target() -> Target {
|
||||||
| SanitizerSet::THREAD;
|
| SanitizerSet::THREAD;
|
||||||
|
|
||||||
Target {
|
Target {
|
||||||
- llvm_target: "x86_64-unknown-linux-gnu".to_string(),
|
- llvm_target: "x86_64-unknown-linux-gnu".into(),
|
||||||
+ llvm_target: "x86_64-pc-linux-gnu".to_string(),
|
+ llvm_target: "x86_64-pc-linux-gnu".into(),
|
||||||
pointer_width: 64,
|
pointer_width: 64,
|
||||||
data_layout: "e-m:e-p270:32:32-p271:32:32-p272:64:64-i64:64-f80:128-n8:16:32:64-S128"
|
data_layout: "e-m:e-p270:32:32-p271:32:32-p272:64:64-i64:64-f80:128-n8:16:32:64-S128"
|
||||||
.to_string(),
|
.into(),
|
||||||
|
|
|
@ -9,7 +9,7 @@ We don't ship rust-lld.
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||||
index 71aa279144bb..6ea5b5fa602c 100644
|
index de7b7374af31..9ea181ab8d8f 100644
|
||||||
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||||
@@ -99,8 +99,7 @@ pub fn options() -> TargetOptions {
|
@@ -99,8 +99,7 @@ pub fn options() -> TargetOptions {
|
||||||
|
@ -17,8 +17,8 @@ index 71aa279144bb..6ea5b5fa602c 100644
|
||||||
limit_rdylib_exports: false,
|
limit_rdylib_exports: false,
|
||||||
|
|
||||||
- // we use the LLD shipped with the Rust toolchain by default
|
- // we use the LLD shipped with the Rust toolchain by default
|
||||||
- linker: Some("rust-lld".to_owned()),
|
- linker: Some("rust-lld".into()),
|
||||||
+ linker: Some("wasm-ld".to_owned()),
|
+ linker: Some("wasm-ld".into()),
|
||||||
lld_flavor: LldFlavor::Wasm,
|
lld_flavor: LldFlavor::Wasm,
|
||||||
linker_is_gnu: false,
|
linker_is_gnu: false,
|
||||||
|
|
||||||
|
|
|
@ -16,7 +16,7 @@ highmem=1
|
||||||
pkgbase=rust
|
pkgbase=rust
|
||||||
pkgname=(rust rust-src)
|
pkgname=(rust rust-src)
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgver=1.60.0
|
pkgver=1.61.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||||
url=https://www.rust-lang.org/
|
url=https://www.rust-lang.org/
|
||||||
|
@ -36,14 +36,14 @@ source=(
|
||||||
0002-compiler-Change-LLVM-targets.patch
|
0002-compiler-Change-LLVM-targets.patch
|
||||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||||
)
|
)
|
||||||
sha256sums=('20ca826d1cf674daf8e22c4f8c4b9743af07973211c839b85839742314c838b7'
|
sha256sums=('ad0b4351675aa9abdf4c7e066613bd274c4391c5506db152983426376101daed'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'7b33955031f9a9c5d63077dedb0f99d77e4e7c996266952c1cec55626dca5dfc'
|
'7b33955031f9a9c5d63077dedb0f99d77e4e7c996266952c1cec55626dca5dfc'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'0f8cfbe0387dd62909fe9cb9523223ae1c2319494e2caf5fa4d0592198631b3e'
|
'c901a9bb036c29ca092f7dbc8b447efdd9aa1044a902a88f9d024cb22681dc19'
|
||||||
'7a69e38716957ff074c5f932a82bbea1d9a3713a3f39d9085977cdc8df336c43'
|
'60c6dfc100d292284af2187cfefc1d0d928139ca557d27bc6bef88edefccff70'
|
||||||
'2ef851be0562d13431c5c81df0161f92984e79845fe986182225f2dae58a9452'
|
'8dcb566da29a92ecf3eb6afe094d9c7766d08230d90fd666bfd022c018ae676a'
|
||||||
'f8ea25693ba42c7e185aa8677218783fe0cd60a3370926cb6996ec898b43d691')
|
'26bf232d144b81a303ed91f6a331ddf004c5d9fefd41a11e36b61812a34459aa')
|
||||||
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||||
474E22316ABF4785A88C6E8EA2C794A986419D8A # Tom Stellard <tstellar@redhat.com>
|
474E22316ABF4785A88C6E8EA2C794A986419D8A # Tom Stellard <tstellar@redhat.com>
|
||||||
B6C8F98282B944E3B0D5C2530FC3042E345AD05D) # Hans Wennborg <hans@chromium.org>
|
B6C8F98282B944E3B0D5C2530FC3042E345AD05D) # Hans Wennborg <hans@chromium.org>
|
||||||
|
@ -100,6 +100,9 @@ jemalloc = true
|
||||||
# https://github.com/rust-lang/rust/issues/54872
|
# https://github.com/rust-lang/rust/issues/54872
|
||||||
codegen-units-std = 1
|
codegen-units-std = 1
|
||||||
|
|
||||||
|
# musl target produces warnings
|
||||||
|
deny-warnings = false
|
||||||
|
|
||||||
[dist]
|
[dist]
|
||||||
compression-formats = ["gz"]
|
compression-formats = ["gz"]
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue