extra/clisp to 2.49-5 (clisp-gcc5.patch)

This commit is contained in:
Jason Plum 2015-09-17 18:15:45 -04:00
parent 4959f6e24e
commit 9b2d414368
2 changed files with 42 additions and 1 deletions

View file

@ -7,7 +7,7 @@
pkgname=clisp
pkgver=2.49
pkgrel=4
pkgrel=5
pkgdesc="ANSI Common Lisp interpreter, compiler and debugger"
arch=('i686' 'x86_64')
license=('GPL')
@ -17,12 +17,15 @@ provides=('common-lisp')
makedepends=('ffcall')
options=('!makeflags' '!emptydirs')
source=("http://downloads.sourceforge.net/sourceforge/clisp/clisp-${pkgver}.tar.bz2"
'clisp-gcc5.patch'
'clisp-arm.patch')
md5sums=('1962b99d5e530390ec3829236d168649'
'f576778ab7fc879d9509decfd559d32e'
'f52b37840eaae76410f14f1adc8a00e2')
prepare() {
cd $srcdir/${pkgname}-${pkgver}
patch -Np1 -i ../clisp-gcc5.patch
patch -p0 -i ../clisp-arm.patch
ulimit -s unlimited
}

View file

@ -0,0 +1,38 @@
--- ./src/makemake.in.orig 2013-02-16 15:26:28.000000000 -0700
+++ ./src/makemake.in 2015-02-11 17:20:00.000000000 -0700
@@ -1217,7 +1217,7 @@ if [ $XCC_GCC = true ] ; then
if [ $CROSS = false ] ; then
case "$XCC_GCC_VERSION" in
# gcc 2.7 introduced an annoying warning, but gcc 2.8 has a workaround:
- 2.[8-9]* | 3.* | 4.* | egcs-2.*)
+ 2.[8-9]* | 3.* | 4.* | 5.* | egcs-2.*)
XCFLAGS=$XCFLAGS' -Wno-sign-compare -Wno-format-nonliteral'
;;
* ) ;;
@@ -1226,7 +1226,7 @@ if [ $XCC_GCC = true ] ; then
if [ $CROSS = false -a $CC_CPLUSPLUS = true ] ; then
case "$XCC_GCC_VERSION" in
# g++ 3.4 introduced an annoying warning, but has a workaround:
- 3.[4-9]* | 4.*)
+ 3.[4-9]* | 4.* | 5.*)
XCFLAGS=$XCFLAGS' -Wno-invalid-offsetof'
;;
* ) ;;
@@ -1241,7 +1241,7 @@ if [ $XCC_GCC = true ] ; then
# gcc-2.7.2 has a strength-reduction bug (fixed in gcc-2.7.2.1,
# also fixed through the specs file of some Linux distributions).
XCFLAGS=$XCFLAGS' -O2 -fexpensive-optimizations -fno-strength-reduce' ;;
- 2.3.[2-9]* | 2.[4-9]* | 3.* | 4.* | egcs-2.*)
+ 2.3.[2-9]* | 2.[4-9]* | 3.* | 4.* | 5.* | egcs-2.*)
XCFLAGS=$XCFLAGS' -O2 -fexpensive-optimizations' ;;
* )
XCFLAGS=$XCFLAGS' -O' ;;
@@ -1295,7 +1295,7 @@ if [ $XCC_GCC = true ] ; then
esac
fi # with_debug
case "$XCC_GCC_VERSION" in
- 3* | 4*)
+ 3* | 4* | 5*)
# When not optimizing on linux, or with Apple's gcc 4 on MacOS X,
# or with GCC 4 when "gcc -Os" is used:
# C_CODE_ALIGNMENT is wrong. &EVAL-WHEN = 0x806D512