aur updates

This commit is contained in:
Kevin Mihelich 2013-08-13 01:17:55 +00:00
parent 98d526c4d1
commit 9b36fe8016
22 changed files with 189 additions and 265 deletions

View file

@ -2,8 +2,8 @@
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
pkgname=asterisk
pkgver=11.4.0
pkgrel=4
pkgver=11.5.0
pkgrel=1
pkgdesc="A complete PBX solution"
arch=('i686' 'x86_64')
backup=('etc/asterisk/acl.conf' 'etc/asterisk/adsi.conf' 'etc/asterisk/agents.conf' 'etc/asterisk/alarmreceiver.conf' 'etc/asterisk/alsa.conf' 'etc/asterisk/amd.conf' 'etc/asterisk/app_mysql.conf' 'etc/asterisk/app_skel.conf'
@ -27,7 +27,7 @@ source=(http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-$
${pkgname}.service \
${pkgname}.logrotated)
install=${pkgname}.install
sha256sums=('081ba8de5f349ff23de8e000d8cda38a2ca34858174e9379b2662a732557e9d4'
sha256sums=('a82c1ddd9fb1d98f0dab6e0255a127fb7c7eaa687b3d515182458244062b4194'
'74e0b278d553499f0c648a6e3d55c0dbb11b0c6dc93a85b020a21eafadb83783'
'caa24cfec5c6b4f8cea385269e39557362acad7e2a552994c3bc24080e3bdd4e')

View file

@ -1,24 +0,0 @@
# Maintainer: Calimero <calimerotekni@free.fr>
plugrel=1
noautobuild=1
pkgname=aufs3-util
pkgver=20111216
pkgrel=1
pkgdesc="Another Unionfs Implementation that supports NFS branches"
arch=('i686' 'x86_64')
url="http://aufs.sourceforge.net/"
license=('GPL2')
source=("http://calimeroteknik.free.fr/src/${pkgname}-${pkgver}.tar.gz")
md5sums=('aa0018796455a3709c9c29e457fe3a95')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}

View file

@ -2,32 +2,43 @@
# Maintainer: Nathan Owe <ndowens.aur at gmail dot com>
pkgname=flexget
_pkgname=FlexGet
pkgver=1.1.9
pkgrel=4
pkgver=1.1.83
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.)"
arch=(any)
url="http://flexget.com/"
depends=('python2' 'python2-cherrypy' 'python2-progressbar'
'python2-pynzb' 'python2-pyrss2gen' 'python2-sqlalchemy-0.7.9'
'python2-html5lib' 'python2-beautifulsoup4>=4.1'
'python2-beautifulsoup3>=3.2' 'python2-yaml' 'python2-feedparser'
'python2-flask' 'python2-requests' 'python2-certifi>=0.0.7'
'python2-chardet>=1.0.0' 'python2-dateutil' 'python2-tvrage'
'python2-jsonschema')
optdepends=('pytransmissionrpc: Transmission support')
makedepends=('python2-distribute')
license=('MIT')
#install=('flexget.install')
source=("http://download.flexget.com/archive/${_pkgname}-${pkgver}.tar.gz")
depends=('python2'
# documented in FlexGet.egg-info/requires.txt
'python2-beautifulsoup3>=3.2'
'python2-beautifulsoup4>=4.2.1'
'python2-cherrypy'
'python2-dateutil>2.0'
'python2-feedparser>=5.1.3'
'python2-flask'
'python2-html5lib>=0.11'
'python2-jinja'
'python2-jsonschema>=2.0' #AUR#
'python2-progressbar'
'python2-pynzb' #AUR#
'python2-pyrss2gen' #AUR#
'python2-requests>=1.0'
'python2-sqlalchemy-0.7.9' #AUR# # support current 0.8.x someday? FIXME
'python2-tvrage' #AUR#
'python2-yaml'
# undocumented in FlexGet.egg-info/requires.txt
'python2-certifi>=0.0.7' #AUR# # possibly required by python2-requests
#'python2-chardet>=1.0.0' # reason? imdb_lookup.py says installing it might help...
)
optdepends=('python2-guppy: for memusage plugin' #AUR#
'python2-transmissionrpc: Transmission support' #AUR#
)
makedepends=('python2-distribute')
source=("http://download.flexget.com/${_pkgname}-${pkgver}.tar.gz")
md5sums=('2c90f9207f46b8fc9d1ed21befd441ed')
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root=${pkgdir}/ optimize=1
chmod ugo+r ${pkgdir}/usr/lib/python2.7/site-packages/FlexGet-1.1-py2.7.egg-info/*
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}/" optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
md5sums=('8c0988137ae3c51d0573afa7b4eb0cdd')

View file

@ -1,23 +1,13 @@
include Makefile.include
CFLAGS+=-std=c++0x -DSTANDALONE -D__STDC_CONSTANT_MACROS \
-D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC \
-D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 \
-DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall \
-mfpu=vfp -mno-apcs-stack-check -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG \
-DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_MEM_H \
-DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H \
-DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX \
-DOMX_SKIP64BIT -ftree-vectorize -pipe -DUSE_EXTERNAL_OMX \
-DTARGET_RASPBERRY_PI -DHAVE_PLATFORM_RASPBERRY_PI \
-DUSE_EXTERNAL_LIBBCM_HOST -Wno-psabi
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
#### Ugly ffmpeg-compat hack. Feel free to fix properly
CFLAGS +=-DAV_CODEC_ID_SSA=0x3a2d7c7c -DAV_CODEC_ID_SUBRIP=0x3a2d7c7c
LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
LDFLAGS+=-L./ -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
INCLUDES+=-I./ -Ilinux
DIST ?= omxplayer-dist
SRC=linux/XMemUtils.cpp \
utils/log.cpp \
DynamicDll.cpp \
@ -39,9 +29,10 @@ SRC=linux/XMemUtils.cpp \
OMXPlayerVideo.cpp \
OMXPlayerAudio.cpp \
OMXPlayerSubtitles.cpp \
Srt.cpp \
SubtitleRenderer.cpp \
Unicode.cpp \
Srt.cpp \
KeyConfig.cpp \
omxplayer.cpp \
OBJS+=$(filter %.o,$(SRC:.cpp=.o))
@ -52,27 +43,23 @@ all: omxplayer.bin
@rm -f $@
$(CXX) $(CFLAGS) $(INCLUDES) -c $< -o $@ -Wno-deprecated-declarations
list_test:
$(CXX) -O3 -o list_test list_test.cpp
version:
sh gen_version.sh > version.h
omxplayer.bin: $(OBJS)
$(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos \
-lrt -lpthread -rdynamic -lavutil -lavcodec -lavformat \
-lswscale -lswresample -lpcre -lm -lc
omxplayer.bin: version $(OBJS)
$(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
#arm-unknown-linux-gnueabi-strip omxplayer.bin
clean:
for i in $(OBJS); do (if test -e "$$i"; then ( rm $$i ); fi ); done
@rm -f omxplayer.old.log omxplayer.log
@rm -f omxplayer.bin
@rm -rf omxplayer-dist
@rm -rf $(DIST)
@rm -f omxplayer-dist.tar.gz
install:
install -d $(DESTDIR)/usr/bin
install -d $(DESTDIR)/usr/share/doc/omxplayer
install omxplayer $(DESTDIR)/usr/bin/
install omxplayer.dist.sh $(DESTDIR)/usr/bin/
install omxplayer.bin $(DESTDIR)/usr/bin/
install README.md COPYING $(DESTDIR)/usr/share/doc/omxplayer/

View file

@ -19,11 +19,9 @@ CFLAGS += -pipe -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux \
-mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -mno-apcs-stack-check \
-O3 -mstructure-size-boundary=32 -mno-sched-prolog
LDFLAGS += -L/opt/vc/lib/ -Wl,-rpath /opt/vc/lib/ \
-L/usr/lib/ffmpeg-compat -Wl,-rpath /usr/lib/ffmpeg-compat
LDFLAGS += -L/opt/vc/lib/ -Wl,-rpath /opt/vc/lib/
INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vcos/ \
-I/opt/vc/include/interface/vcos/pthreads \
-I /usr/include/ffmpeg-compat/ -I /usr/include/freetype2/ \
-I /opt/vc/include/interface/vmcs_host/linux
-I/opt/vc/include/interface/vcos/pthreads \
-I/usr/include/freetype2 -I/opt/vc/include/interface/vmcs_host/linux

View file

@ -1,51 +1,49 @@
# Maintainer: Jonathan Hudson <jh+arch@daria.co.uk>
# Contributor: Huulivoide <jesse.jaara@gmail.com>
buildarch=16
pkgname=omxplayer-git
pkgver=20130708
pkgver=20130803
pkgrel=1
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
arch=('arm' 'armv6h')
url="https://github.com/huceke/omxplayer.git"
url="https://github.com/popcornmix/omxplayer"
license=(GPL2)
depends=(ffmpeg pcre rtmpdump fbset ffmpeg-compat freetype2)
depends=(ffmpeg-compat raspberrypi-firmware-tools fbset)
makedepends=(git boost)
optdepends=(ttf-freefont)
provides=(omxplayer)
conflicts=(omxplayer omxplayer-bin)
source=(omxplayer.arch Makefile.arch Makefile.include.arch)
md5sums=('305f8fedbc4638434475c4a83ee78578'
'5a15874072dec90013b8bec7383f1459'
'3af60fb0782a32471bba9913c25ce322'
)
_gitroot="https://github.com/huceke/omxplayer.git"
_gitname="omxplayer"
source=(git://github.com/popcornmix/omxplayer.git
omxplayer.arch Makefile.arch Makefile.include.arch)
build() {
cd "$srcdir"
msg "Connecting to GIT server...."
if [ -d $_gitname ] ; then
( cd $_gitname && git pull ) || warning "Git pull failed!"
else
git clone --depth=1 $_gitroot
fi
msg "GIT checkout done or server timeout"
pkgver() {
cd omxplayer
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
prepare() {
cd "${srcdir}/omxplayer"
cd $_gitname
# msg "Applying font path patch"
# patch -Np1 -i ../omxfont.patch || msg "and I don't care"
msg "Starting make..."
cp omxplayer omxplayer.dist.sh
cp Makefile Makefile.dist
cp Makefile.include Makefile.include.dist
cp ../Makefile.arch Makefile
cp ../Makefile.include.arch Makefile.include
cp ../omxplayer.arch omxplayer
}
build() {
cd "${srcdir}/omxplayer"
make
}
package() {
cd "$srcdir/$_gitname"
make DESTDIR="$pkgdir" install
cd "${srcdir}/omxplayer"
make DESTDIR="${pkgdir}" install
}
md5sums=('SKIP'
'305f8fedbc4638434475c4a83ee78578'
'cfd349a05cd8c456c6df25eec3fa6d86'
'ef4586f5e8b042e4940c0e43f3185bf1')

View file

@ -2,26 +2,23 @@
pkgname=open-iscsi
pkgver=2.0.873
_pkgver=2.0-873
pkgrel=4
pkgrel=5
pkgdesc="userland tools"
arch=('i686' 'x86_64')
url="http://www.open-iscsi.org"
license=('GPL')
depends=('bash')
install=$pkgname.install
backup=('etc/iscsi/iscsid.conf' 'etc/iscsi/initiatorname.iscsi' 'etc/conf.d/open-iscsi')
backup=('etc/iscsi/iscsid.conf' 'etc/iscsi/initiatorname.iscsi')
source=("http://www.open-iscsi.org/bits/${pkgname}-${_pkgver}.tar.gz" \
"open-iscsi" "open-iscsi.conf.d" "open-iscsi.service")
"open-iscsi.service")
options=('docs')
sha256sums=('7dd9f2f97da417560349a8da44ea4fcfe98bfd5ef284240a2cc4ff8e88ac7cd9'
'649536c4abc9c4d9f994cc1c0033449d46c120b73a836854a228f7e103711314'
'289ba27b72a3bd9d251e08b3d61dd3ae2f6ad545e5ffe2edaa2b79638996654c'
'7b8e37dd10a909a67ba7f7126f699920639be39adfa65f1d2b2bcd8846e58db7')
build() {
cd ${srcdir}/${pkgname}-${_pkgver}
# include iscsistart in the package
sed -i -e '/^PROGRAMS = /s/$/ usr\/iscsistart/' Makefile
@ -29,10 +26,13 @@ build() {
sed -i -e 's/\(\.\/configure\)/ \1 --without-slp/g' Makefile
make user
}
package() {
cd ${srcdir}/${pkgname}-${_pkgver}
make DESTDIR=${pkgdir} install_user
install -D -m755 ${srcdir}/open-iscsi ${pkgdir}/etc/rc.d/open-iscsi
install -D -m644 ${srcdir}/open-iscsi.conf.d ${pkgdir}/etc/conf.d/open-iscsi
install -D -m644 ${srcdir}/${pkgname}-${_pkgver}/etc/iscsid.conf ${pkgdir}/etc/iscsi
install -D -m644 ${srcdir}/open-iscsi.service ${pkgdir}/usr/lib/systemd/system/open-iscsi.service

View file

@ -6,12 +6,6 @@ post_install() {
echo ">>> Setting Initiatorname '$name'"
echo "InitiatorName=$name" > /etc/iscsi/initiatorname.iscsi
fi
echo
echo "Configure /etc/conf.d/open-iscsi to enable:"
echo " - portal discovery"
echo " - automatic login to available targets"
echo " - automount of targets"
echo
}
post_upgrade() {

View file

@ -1,28 +1,42 @@
# Maintainer: Wieland Hoffmann <the_mineo@web.de>
# Maintainer: Danilo Luvizotto <danilo.luvizotto@gmail.com>
# Contributor: Wieland Hoffmann <the_mineo@web.de>
# Contributor: G_Syme <demichan(at)mail(dot)upb(dot)de>
plugrel=1
pkgname=p910nd
pkgver=0.95
pkgrel=1
pkgrel=7
pkgdesc="A small printer daemon intended for diskless workstations that passes jobs directly to the printer"
arch=('i686' 'x86_64')
arch=('i686' 'x86_64' 'armv5' 'armv5h' 'armv6' 'armv6h' 'armv7' 'armv7h')
url="http://p910nd.sourceforge.net"
license=('GPL2')
backup=('etc/conf.d/p910nd')
options=('emptydirs')
source=(http://downloads.sf.net/$pkgname/$pkgname-$pkgver.tar.bz2 \
$pkgname.init)
$pkgname.service \
$pkgname.conf)
CONFIGDIR=/etc/conf.d
INITSCRIPT=""
SCRIPTDIR=""
build() {
cd $srcdir/$pkgname-$pkgver
sed -e "s|/var/lock/subsys|/var/lock/$pkgname|" -i $pkgname.c
make CONFIGDIR=/etc/conf.d SCRIPTDIR=/etc/rc.d
make CONFIGDIR=/etc/conf.d SCRIPTDIR=/etc/rc.d DESTDIR=$pkgdir install
install -m755 $srcdir/$pkgname.init $pkgdir/etc/rc.d/$pkgname
sed -e 's|$(INSTALL) $(INITSCRIPT) $(DESTDIR)$(SCRIPTDIR)/$(PROG)||' -i Makefile
make CONFIGDIR=$CONFIGDIR INITSCRIPT=$INITSCRIPT SCRIPTDIR=$SCRIPTDIR
sed -e 's|P910ND_OPTS=""|P910ND_OPTS="-f /dev/usb/lp0"|' -i $pkgname.conf
}
package() {
cd $srcdir/$pkgname-$pkgver
make CONFIGDIR=$CONFIGDIR INITSCRIPT=$INITSCRIPT SCRIPTDIR=$SCRIPTDIR DESTDIR=$pkgdir install
install -d -m755 $pkgdir/var/lock/$pkgname
install -d -m755 $pkgdir/usr/lib/systemd/system
install -d -m755 $pkgdir/usr/lib/tmpfiles.d
install -m644 $srcdir/$pkgname.service $pkgdir/usr/lib/systemd/system/$pkgname.service
install -m644 $srcdir/$pkgname.conf $pkgdir/usr/lib/tmpfiles.d/$pkgname.conf
chmod 1777 $pkgdir/var/lock
}
md5sums=('c7ac6afdf7730ac8387a8e87198d4491'
'e44be17ad714c366300289cb8aaa3f3a')
'e37030a69b7bf302cfb23d88e25ebbdf'
'ea1db6d612058532c525efedd54990f2')

1
aur/p910nd/p910nd.conf Normal file
View file

@ -0,0 +1 @@
d /run/lock/p910nd 0755 root root -

View file

@ -1,38 +0,0 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
. /etc/conf.d/p910nd
PID=`pidof -o %PPID /usr/sbin/p910nd`
case "$1" in
start)
stat_busy "Starting P910N Daemon"
[ -z "$PID" ] && /usr/sbin/p910nd $P910ND_OPTS $P910ND_NUM &>/dev/null
if [ $? -gt 0 ]; then
stat_fail
else
add_daemon p910nd
stat_done
fi
;;
stop)
stat_busy "Stopping P910N Daemon"
[ ! -z "$PID" ] && kill $PID &> /dev/null
if [ $? -gt 0 ]; then
stat_fail
else
rm_daemon p910nd
stat_done
fi
;;
restart)
$0 stop
sleep 3
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac
exit 0
# vim: ft=sh ts=2 sw=2

11
aur/p910nd/p910nd.service Normal file
View file

@ -0,0 +1,11 @@
[Unit]
Description=A small printer daemon intended for diskless workstations that passes jobs directly to the printer
After=network.target
[Service]
Type=forking
EnvironmentFile=/etc/conf.d/p910nd
ExecStart=/usr/bin/p910nd $P910ND_OPTS $P910ND_NUM
[Install]
WantedBy=multi-user.target

View file

@ -3,16 +3,15 @@
_perlmod=Config-General
_modnamespace=Config
pkgname=perl-config-general
pkgver=2.51
pkgrel=3
pkgver=2.52
pkgrel=1
pkgdesc="Config::General - Generic Config Module"
arch=('any')
url="http://search.cpan.org/dist/$_perlmod"
license=('GPL' 'PerlArtistic')
options=('!emptydirs')
depends=('perl>=5.10.0')
url="http://search.cpan.org/dist/$_perlmod"
source=("http://cpan.perl.org/modules/by-module/$_modnamespace/$_perlmod-$pkgver.tar.gz")
sha512sums=('71a0d607ab69b82aa6ff3eb74efe7d90b67859331ae3fe2d6d14829e71eedacdeb98506e38c6506b4b7400ed31cd20de09b5b8ef86fe6a23599677aa8e5f5982')
sha512sums=('9a4d6fd823c58c5aba78528997b17b7db8f303dd58d1763f797cf917ebd5f3257b17afc85dcec6f5607b7fdb874dfa60b540e98366a6bb3cf6000175fb32a7c5')
build() {
cd "$srcdir/$_perlmod-$pkgver"
@ -24,8 +23,7 @@ build() {
check() {
cd "$srcdir/$_perlmod-$pkgver"
# An upstream bug causes 1 test to fail, so error out silently.
make test || return 0
make test
}
package() {

View file

@ -1,19 +1,19 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=python2-configshell-fb
_pkgname=configshell-fb
pkgver=1.1.fb5
pkgver=1.1.fb8
pkgrel=1
epoch=
pkgdesc="python framework for building simple CLI applications (free branch)"
arch=('any')
url="https://github.com/agrover/configshell-fb"
license=('AGPL3')
license=('Apache')
depends=('python2-simpleparse' 'python2-urwid')
provides=('python2-configshell')
conflicts=('python2-configshell')
options=()
source=($_pkgname-$pkgver.tar.gz::https://github.com/agrover/$_pkgname/archive/v$pkgver.tar.gz)
md5sums=('93dff95676042227b95d0abbfc134ad8')
md5sums=('1ad1f82df8d3199a28042921bd7516d2')
build() {
cd "$srcdir/$_pkgname-$pkgver"

View file

@ -1,20 +1,18 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=python2-rtslib
pkgver=2.1
pkgrel=5
pkgver=2.2
pkgrel=1
epoch=
pkgdesc="RisingTide Systems generic SCSI target API in python"
arch=('any')
url="http://www.risingtidesystems.com/git/?p=rtslib.git;a=summary"
license=('AGPL3')
license=('Apache')
depends=('python2-ipaddr' 'python2-netifaces' 'python2-configobj')
provides=()
conflicts=()
backup=()
options=()
install=
source=('gz-modules-upstream.patch')
md5sums=('4add05b9cbd12258dc993f19728fbafe')
_pkgname=rtslib
@ -25,7 +23,6 @@ build() {
bsdtar -xf "$srcdir/$_pkgname-$pkgver.tgz"
cd "$srcdir/$_pkgname"
patch -p1 < ../gz-modules-upstream.patch
python2 setup.py build
}

View file

@ -1,31 +0,0 @@
commit ee65af95e71018c1727825752b31ec55f608e323
Author: Jerome Martin <jxm@risingtidesystems.com>
Date: Tue Nov 1 11:39:16 2011 +0100
Added gzipped kernel fabric modules support.
* Now looks for any module name no matter what the file extension is, i.e.
*.ko.gz not just *.ko on the filesystem.
* Reported by Arch Linux user "Johannes Dewender" <arch@jonnyjd.net>
diff --git a/rtslib/utils.py b/rtslib/utils.py
index 17156fb..5c778f5 100644
--- a/rtslib/utils.py
+++ b/rtslib/utils.py
@@ -604,8 +604,14 @@ def list_available_kernel_modules():
'''
kver = os.uname()[2]
depfile = "/lib/modules/%s/modules.dep" % kver
- return [module.split(".")[0] for module in
- re.findall(r"[a-zA-Z0-9_-]+\.ko:", fread(depfile))]
+ handle = open(depfile)
+ try:
+ lines = handle.readlines()
+ finally:
+ handle.close()
+
+ return [os.path.basename(line.partition(":")[0]).partition(".")[0]
+ for line in lines]
def list_loaded_kernel_modules():
'''

View file

@ -0,0 +1,24 @@
# Maintainer: Bogdan Szczurek <thebodzio@gmail.com>
pkgname=python2-transmissionrpc
pkgver=0.10
pkgrel=1
pkgdesc="Module to communicate with Transmission BT client via JSON-RPC"
arch=(any)
url="https://bitbucket.org/blueluna/transmissionrpc/wiki/Home"
license=('MIT')
depends=('python2' 'python2-six')
makedepends=('python2-setuptools')
conflicts=('pytransmissionrpc')
replaces=('pytransmissionrpc')
source=(https://bitbucket.org/blueluna/${pkgname:8}/get/release-${pkgver}.tar.gz)
package() {
cd "$srcdir/blueluna-${pkgname:8}-f74c8cbb721e"
python2 setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et:
md5sums=('65c887ded3ccda6211ac635bc39d3b54')

View file

@ -1,22 +0,0 @@
# Maintainer: Andrwe Lord Weber <lord-weber-andrwe [at] ndrwe [dot] org>
# Contributor: dan saul <aur dot cryingwolf at org>
plugrel=1
_realname=transmissionrpc
pkgname=py${_realname}
pkgver=0.8
pkgrel=1
pkgdesc="A python module that communicate with Transmission through json-rpc e.g. for FlexGet."
arch=(any)
url="http://bitbucket.org/blueluna/transmissionrpc/wiki/Home"
license=MIT
depends=("python2")
source=(http://pypi.python.org/packages/source/t/transmissionrpc/${_realname}-${pkgver}.tar.gz)
md5sums=('3fe59c513144388b4e8e2970e8bb9ebe')
build() {
cd ${srcdir}/${_realname}-${pkgver}/ || return 1
mkdir -p ${pkgdir}/usr/lib/python2.7/site-packages || return 1
cp -r ${_realname} ${pkgdir}/usr/lib/python2.7/site-packages || return 1
}

View file

@ -5,7 +5,7 @@
pkgname=sickbeard-git
pkgver=3412.fb37d33
pkgrel=2
pkgrel=4
pkgdesc="A PVR application that downloads and manages your TV shows"
arch=('any')
url="http://code.google.com/p/sickbeard/"
@ -24,21 +24,27 @@ sha256sums=('SKIP'
'24f20de2445ff3998aad5d87d94e0fea3b22eb1d0a451ed33ec301ac36a7398d')
pkgver() {
cd "$srcdir"/$pkgname
cd $pkgname
echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
cd $pkgname
# Fix python2 shebang
sed -i 's/python/python2/g' autoProcessTV/sabToSickBeard.py
sed -i 's/python/python2/g' autoProcessTV/hellaToSickBeard.py
}
package() {
mkdir -p "$pkgdir"/opt/sickbeard
cp -r "$srcdir"/$pkgname/* "$pkgdir"/opt/sickbeard
chmod 775 "$pkgdir"/opt/sickbeard
cp -r $pkgname/* "$pkgdir"/opt/sickbeard
sed -i 's/python/python2/g' "$pkgdir"/opt/sickbeard/autoProcessTV/sabToSickBeard.py
sed -i 's/python/python2/g' "$pkgdir"/opt/sickbeard/autoProcessTV/hellaToSickBeard.py
install -D -m644 "$srcdir"/sickbeard-system.service "$pkgdir"/usr/lib/systemd/system/sickbeard.service
install -D -m644 "$srcdir"/sickbeard-user.service "$pkgdir"/usr/lib/systemd/user/sickbeard.service
install -D -m644 "$srcdir"/sickbeard.tmpfile "$pkgdir"/usr/lib/tmpfiles.d/sickbeard.conf
install -D -m644 sickbeard-system.service "$pkgdir"/usr/lib/systemd/system/sickbeard.service
install -D -m644 sickbeard-user.service "$pkgdir"/usr/lib/systemd/user/sickbeard.service
install -D -m644 sickbeard.tmpfile "$pkgdir"/usr/lib/tmpfiles.d/sickbeard.conf
find "$pkgdir" -type d -name '.git' -exec rm -r '{}' +
}

View file

@ -1,12 +1,12 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=targetcli
pkgver=2.0rc1
pkgrel=3
pkgver=2.1
pkgrel=1
epoch=
pkgdesc="The targetcli administration shell."
arch=('any')
url="http://linux-iscsi.org/wiki/RTSadmin"
license=('AGPL3')
license=('Apache')
groups=()
depends=('python2-rtslib' 'lio-utils' 'python2-configshell')
optdepends=()

View file

@ -1,18 +1,18 @@
# Maintainer: David Herrmann <dh.herrmann@googlemail.com>
pkgname=xf86-input-xwiimote
pkgver=0.2
pkgver=0.4
pkgrel=1
pkgdesc='X.Org Nintendo Wii Remote input driver'
arch=('i686' 'x86_64')
url="http://github.com/dvdhrm/xf86-input-xwiimote"
license=('BSD')
depends=('xwiimote>=0.3' 'udev')
url="http://github.com/dvdhrm/$pkgname"
license=('MIT')
depends=('xwiimote>=2' 'udev')
makedepends=('xorg-server-devel>=1.10.99.902')
conflicts=('xorg-server<1.10.99.902')
options=(!libtool)
source=(https://github.com/downloads/dvdhrm/$pkgname/$pkgname-$pkgver.tar.bz2)
#source=($pkgname-$pkgver.tar.bz2)
md5sums=('af97ba6d95f74a588aff721793bf6d3d')
source=(https://github.com/dvdhrm/$pkgname/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz)
#source=($pkgname-$pkgver.tar.xz)
md5sums=('7b9810cef1744d315e6ca7c69c44d8e8')
build() {
cd "$srcdir/$pkgname-$pkgver"

View file

@ -1,20 +1,20 @@
# Maintainer: David Herrmann <dh.herrmann@googlemail.com>
pkgname=xwiimote
pkgver=0.3
pkgver=2
pkgrel=1
pkgdesc='Userspace utilities to control connected Nintendo Wii Remotes'
arch=('i686' 'x86_64')
url="http://github.com/dvdhrm/xwiimote"
license=('BSD')
url="http://dvdhrm.github.io/$pkgname"
license=('MIT')
depends=('udev' 'ncurses')
options=(!libtool)
source=(https://github.com/downloads/dvdhrm/xwiimote/$pkgname-$pkgver.tar.bz2)
#source=($pkgname-$pkgver.tar.bz2)
md5sums=('b4e82260ed4e2acb81a4c802e01d3d61')
source=(https://github.com/dvdhrm/xwiimote/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz)
#source=($pkgname-$pkgver.tar.xz)
md5sums=('763f2c1acedfea9c8cee448a674efb76')
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr
./configure --prefix=/usr --with-doxygen=no
make
}