mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/boost to 1.47.0-2
This commit is contained in:
parent
a257ee9dec
commit
9b87c021cd
2 changed files with 35 additions and 6 deletions
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 132748 2011-07-25 19:08:12Z ibiru $
|
||||
# $Id: PKGBUILD 137203 2011-09-06 17:17:14Z andrea $
|
||||
# Maintainer: kevin <kevin@archlinux.org>
|
||||
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
|
||||
# Contributor: Kritoke <kritoke@gamebox.net>
|
||||
|
@ -14,13 +14,15 @@ pkgbase=boost
|
|||
pkgname=('boost-libs' 'boost')
|
||||
pkgver=1.47.0
|
||||
_boostver=${pkgver//./_}
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.boost.org/"
|
||||
makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib')
|
||||
source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
|
||||
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
|
||||
exceptions.patch)
|
||||
license=('custom')
|
||||
md5sums=('ff180a5276bec773a7625cac7e2288e8')
|
||||
md5sums=('ff180a5276bec773a7625cac7e2288e8'
|
||||
'9b44c28b36303152050c8c82469569c5')
|
||||
|
||||
_stagedir="${srcdir}/stagedir"
|
||||
|
||||
|
@ -29,14 +31,16 @@ build() {
|
|||
cd "${srcdir}/${pkgbase}_${_boostver}/tools"
|
||||
echo "using python : 2.7 : /usr/bin/python2 ;" >> build/v2/user-config.jam
|
||||
echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
|
||||
echo "using mpi ;" >> build/v2/user-config.jam
|
||||
|
||||
# http://web.archiveorange.com/archive/v/Q0J4VE5bwsy3zxRXqUgd
|
||||
cd "${srcdir}"/${pkgbase}_${_boostver}
|
||||
patch -p0 -i "${srcdir}"/exceptions.patch
|
||||
|
||||
# build bjam
|
||||
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine"
|
||||
./build.sh cc
|
||||
|
||||
_bindir="bin.linuxarm"
|
||||
[ "${CARCH}" = "x86_64" ] && _bindir="bin.linuxx86_64"
|
||||
|
||||
install -d "${_stagedir}"/usr/bin
|
||||
install ${_bindir}/bjam "${_stagedir}"/usr/bin/bjam
|
||||
|
|
25
extra/boost/exceptions.patch
Normal file
25
extra/boost/exceptions.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
diff -up boost/numeric/conversion/converter_policies.hpp\~ boost/numeric/conversion/converter_policies.hpp
|
||||
--- boost/numeric/conversion/converter_policies.hpp~ 2008-10-13 11:00:03.000000000 +0200
|
||||
+++ boost/numeric/conversion/converter_policies.hpp 2011-07-22 11:46:40.961876274 +0200
|
||||
@@ -20,6 +20,7 @@
|
||||
|
||||
#include "boost/mpl/if.hpp"
|
||||
#include "boost/mpl/integral_c.hpp"
|
||||
+#include "boost/throw_exception.hpp"
|
||||
|
||||
namespace boost { namespace numeric
|
||||
{
|
||||
@@ -159,9 +160,9 @@ struct def_overflow_handler
|
||||
void operator() ( range_check_result r ) // throw(negative_overflow,positive_overflow)
|
||||
{
|
||||
if ( r == cNegOverflow )
|
||||
- throw negative_overflow() ;
|
||||
+ boost::throw_exception( negative_overflow() ) ;
|
||||
else if ( r == cPosOverflow )
|
||||
- throw positive_overflow() ;
|
||||
+ boost::throw_exception( positive_overflow() ) ;
|
||||
}
|
||||
} ;
|
||||
|
||||
|
||||
Diff finished. Fri Jul 22 11:46:49 2011
|
Loading…
Reference in a new issue