mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/calligra to 3.1.0-25
This commit is contained in:
parent
5d1b485196
commit
9b9482a234
2 changed files with 77 additions and 4 deletions
|
@ -10,14 +10,14 @@
|
|||
pkgname=calligra
|
||||
pkgdesc="A set of applications for productivity and creative usage"
|
||||
pkgver=3.1.0
|
||||
pkgrel=24
|
||||
pkgrel=25
|
||||
arch=(x86_64)
|
||||
url='https://www.calligra-suite.org/'
|
||||
license=(FDL1.2 GPL2 LGPL)
|
||||
depends=(kcmutils knotifyconfig kross kactivities kdiagram libspnav kdelibs4support
|
||||
gsl openexr kcontacts qca-qt5 poppler-qt5 libodfgen qt5-webkit cauchy khtml)
|
||||
makedepends=(extra-cmake-modules kdoctools kdesignerplugin boost openjpeg akonadi-contacts
|
||||
libwpg okular eigen marble-common pstoedit libvisio libetonyek libwps libgit2)
|
||||
libwpg okular eigen marble-common pstoedit libvisio libetonyek libwps libgit2 kinit)
|
||||
optdepends=('libwpg: Corel WordPerfect Graphics image importer'
|
||||
'libwps: Microsoft Works file word processor format import'
|
||||
'libvisio: Microsoft Visio import filter'
|
||||
|
@ -40,6 +40,7 @@ for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb n
|
|||
replaces+=(calligra-l10n-$_lang)
|
||||
done
|
||||
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
|
||||
calligra-2.9.11-gcc6_arm.patch
|
||||
calligra-qt5.11.patch
|
||||
calligra-qt5.13.patch
|
||||
calligra-poppler-0.69.patch::"https://cgit.kde.org/calligra.git/patch/?id=a6157182"
|
||||
|
@ -47,9 +48,10 @@ source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.x
|
|||
calligra-poppler-0.72.patch
|
||||
calligra-poppler-0.73.patch
|
||||
calligra-poppler-0.82.patch
|
||||
'calligra-2.9.11-gcc6_arm.patch')
|
||||
calligra-poppler-0.83.patch)
|
||||
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
|
||||
'SKIP'
|
||||
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d'
|
||||
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
|
||||
'd32a9cda1343f224f5a0cfa2b8122c5571a0dbb09c9948414d6770d9c3814f4d'
|
||||
'127cc5e0946fbf741279306b4e9d592f5f901a7fab09039fcfc6c7e60193fa80'
|
||||
|
@ -57,7 +59,7 @@ sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
|
|||
'87a09710b9e7e825a46344ddec08eb98b3454d6d067b0177d284733b2342cece'
|
||||
'ef95f49f69c9f2a5b530e416003f2d6d106bb3c85e8458ae27494c64c8b474a8'
|
||||
'a2f02dccd8f7748b187dba805220ded95c41bbddc084091794691164184d1b82'
|
||||
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
|
||||
'3877210cc58c11472909c62bdc1678a05deb30051f0180c47893e51bae9182d1')
|
||||
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
|
||||
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
|
||||
|
||||
|
@ -79,6 +81,8 @@ prepare() {
|
|||
patch -p1 -i ../calligra-poppler-0.73.patch
|
||||
# Fix build with poppler 0.82
|
||||
patch -p1 -i ../calligra-poppler-0.82.patch
|
||||
# Fix build with poppler 0.83
|
||||
patch -p1 -i ../calligra-poppler-0.83.patch
|
||||
|
||||
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
|
||||
}
|
||||
|
|
69
extra/calligra/calligra-poppler-0.83.patch
Normal file
69
extra/calligra/calligra-poppler-0.83.patch
Normal file
|
@ -0,0 +1,69 @@
|
|||
Source: Timo Gurr <tgurr@exherbo.org>
|
||||
Upstream: Reported, https://bugs.kde.org/show_bug.cgi?id=414795
|
||||
Reason: Fix build with poppler 0.83.0
|
||||
|
||||
diff -Naur calligra-3.1.0/filters/karbon/pdf/PdfImport.cpp calligra-3.1.0.new/filters/karbon/pdf/PdfImport.cpp
|
||||
--- calligra-3.1.0/filters/karbon/pdf/PdfImport.cpp 2019-12-04 12:41:13.000000000 +0100
|
||||
+++ calligra-3.1.0.new/filters/karbon/pdf/PdfImport.cpp 2019-12-04 12:39:03.000000000 +0100
|
||||
@@ -60,19 +60,17 @@
|
||||
}
|
||||
|
||||
// read config file
|
||||
- globalParams = new GlobalParams();
|
||||
+ globalParams.reset(new GlobalParams());
|
||||
if (! globalParams)
|
||||
return KoFilter::NotImplemented;
|
||||
|
||||
GooString * fname = new GooString(QFile::encodeName(m_chain->inputFile()).data());
|
||||
PDFDoc * pdfDoc = new PDFDoc(fname, 0, 0, 0);
|
||||
if (! pdfDoc) {
|
||||
- delete globalParams;
|
||||
return KoFilter::StupidError;
|
||||
}
|
||||
|
||||
if (! pdfDoc->isOk()) {
|
||||
- delete globalParams;
|
||||
delete pdfDoc;
|
||||
return KoFilter::StupidError;
|
||||
}
|
||||
@@ -99,7 +97,6 @@
|
||||
|
||||
delete dev;
|
||||
delete pdfDoc;
|
||||
- delete globalParams;
|
||||
globalParams = 0;
|
||||
|
||||
return KoFilter::OK;
|
||||
diff -Naur calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.cpp
|
||||
--- calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp 2019-12-04 12:41:14.000000000 +0100
|
||||
+++ calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.cpp 2019-12-04 12:35:30.000000000 +0100
|
||||
@@ -172,7 +172,7 @@
|
||||
*d->body << "/>" << endl;
|
||||
}
|
||||
|
||||
-QString SvgOutputDev::convertPath(GfxPath *path)
|
||||
+QString SvgOutputDev::convertPath(const GfxPath *path)
|
||||
{
|
||||
if (! path)
|
||||
return QString();
|
||||
@@ -180,7 +180,7 @@
|
||||
QString output;
|
||||
|
||||
for (int i = 0; i < path->getNumSubpaths(); ++i) {
|
||||
- GfxSubpath * subpath = path->getSubpath(i);
|
||||
+ const GfxSubpath * subpath = path->getSubpath(i);
|
||||
if (subpath->getNumPoints() > 0) {
|
||||
output += QString("M%1 %2").arg(subpath->getX(0)).arg(subpath->getY(0));
|
||||
int j = 1;
|
||||
diff -Naur calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.h calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.h
|
||||
--- calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.h 2019-12-04 12:41:14.000000000 +0100
|
||||
+++ calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.h 2019-12-04 12:30:41.000000000 +0100
|
||||
@@ -83,7 +83,7 @@
|
||||
/// Dumps content to svg file
|
||||
void dumpContent();
|
||||
private:
|
||||
- QString convertPath(GfxPath *path);
|
||||
+ QString convertPath(const GfxPath *path);
|
||||
QString convertMatrix(const QMatrix &matrix);
|
||||
QString convertMatrix(const double * matrix);
|
||||
QString printFill();
|
Loading…
Reference in a new issue