mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added alarm/brcm-patchram-plus
This commit is contained in:
parent
742e5632cd
commit
9b9ddb4c9f
2 changed files with 63 additions and 0 deletions
25
alarm/brcm-patchram-plus/0001-fix-includes.patch
Normal file
25
alarm/brcm-patchram-plus/0001-fix-includes.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 2c1ba636c623e579444230c4f5e8f23974464126 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 30 Jun 2015 20:04:08 -0600
|
||||
Subject: [PATCH] fix includes
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
bluetooth/brcm_patchram_plus.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/bluetooth/brcm_patchram_plus.c b/bluetooth/brcm_patchram_plus.c
|
||||
index b4fa5a8..f31d8ef 100644
|
||||
--- a/bluetooth/brcm_patchram_plus.c
|
||||
+++ b/bluetooth/brcm_patchram_plus.c
|
||||
@@ -112,6 +112,7 @@
|
||||
#include <fcntl.h>
|
||||
|
||||
#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#ifdef ANDROID
|
||||
#include <termios.h>
|
||||
--
|
||||
2.4.4
|
||||
|
38
alarm/brcm-patchram-plus/PKGBUILD
Normal file
38
alarm/brcm-patchram-plus/PKGBUILD
Normal file
|
@ -0,0 +1,38 @@
|
|||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
||||
buildarch=4
|
||||
|
||||
pkgname=brcm-patchram-plus
|
||||
pkgver=r1.4070e71
|
||||
pkgrel=1
|
||||
pkgdesc="Chromium OS Broadcom patchram utility"
|
||||
arch=('armv7h')
|
||||
depends=('bluez-libs')
|
||||
makedepends=('git')
|
||||
url='https://chromium.googlesource.com/chromiumos/third_party/broadcom/'
|
||||
license=('custom:chromiumos')
|
||||
source=("git+https://chromium.googlesource.com/chromiumos/third_party/broadcom"
|
||||
'0001-fix-includes.patch')
|
||||
md5sums=('SKIP'
|
||||
'bb1e24dce6c639ac4ab163eaf81fc3fd')
|
||||
|
||||
pkgver() {
|
||||
cd broadcom
|
||||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd broadcom
|
||||
git apply ../0001-fix-includes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd broadcom/bluetooth
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd broadcom/bluetooth
|
||||
install -dm755 ${pkgdir}/usr/bin
|
||||
install -m755 brcm_patchram_plus ${pkgdir}/usr/bin
|
||||
}
|
Loading…
Reference in a new issue