mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
removed community/rawtherapee
This commit is contained in:
parent
f756bd7e4e
commit
9be96dee30
2 changed files with 0 additions and 90 deletions
|
@ -1,34 +0,0 @@
|
|||
From 65261a822ebb355a22e1b876fff78d15fc1f2fe3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 11 Dec 2015 20:06:54 -0700
|
||||
Subject: [PATCH] char fix for ARM
|
||||
|
||||
---
|
||||
rtengine/dcraw.cc | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/rtengine/dcraw.cc b/rtengine/dcraw.cc
|
||||
index 8e0a36d..b47d856 100644
|
||||
--- a/rtengine/dcraw.cc
|
||||
+++ b/rtengine/dcraw.cc
|
||||
@@ -1925,7 +1925,7 @@ void CLASS hasselblad_correct()
|
||||
blur than this, but this does not need any buffer and makes nice-looking
|
||||
radial gradients */
|
||||
ushort *corners_weight = (ushort *)malloc(bw*bh*9*sizeof(*corners_weight));
|
||||
- const char corners_mix[9][4][2] = { { {0,0}, {0,1}, {1,0}, {1,1} },
|
||||
+ const signed char corners_mix[9][4][2] = { { {0,0}, {0,1}, {1,0}, {1,1} },
|
||||
{ {0,1}, {1,1}, {-1,-1}, {-1,-1} },
|
||||
{ {0,1}, {0,2}, {1,1}, {1,2} },
|
||||
{ {1,0}, {1,1}, {-1,-1}, {-1,-1} },
|
||||
@@ -2434,7 +2434,7 @@ void CLASS quicktake_100_load_raw()
|
||||
|
||||
void CLASS kodak_radc_load_raw()
|
||||
{
|
||||
- static const char src[] = {
|
||||
+ static const signed char src[] = {
|
||||
1,1, 2,3, 3,4, 4,2, 5,7, 6,5, 7,6, 7,8,
|
||||
1,0, 2,1, 3,3, 4,4, 5,2, 6,7, 7,6, 8,5, 8,8,
|
||||
2,1, 2,3, 3,0, 3,2, 3,4, 4,6, 5,5, 6,7, 6,8,
|
||||
--
|
||||
2.6.2
|
||||
|
|
@ -1,56 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Lukas Jirkovsky <l.jirkovsky AT gmail.com>
|
||||
# Contributor: Bogdan Szczurek <thebodzio(at)gmail.com>
|
||||
# Contributor: Vaclav Kramar <vaclav.kramar@tiscali.cz>
|
||||
# Contributor: Archie <mymaud@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - fix for unsigned char on ARM
|
||||
|
||||
pkgname=rawtherapee
|
||||
pkgver=4.2+448.g26d182d
|
||||
_pkgver=26d182dabc6f133c27bffa3aac3f91b7ae55d578
|
||||
pkgrel=3
|
||||
epoch=1
|
||||
pkgdesc="Raw photo editor"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.rawtherapee.com/"
|
||||
license=('GPL3')
|
||||
depends=('fftw' 'gtkmm' 'libcanberra' 'libiptcdata' 'lcms2' 'hicolor-icon-theme')
|
||||
optdepends=('gtk-engines: workaround theme bug under GNOME')
|
||||
makedepends=('cmake' 'git')
|
||||
#source=("http://rawtherapee.com/shared/source/rawtherapee-${pkgver}.tar.xz")
|
||||
#md5sums=('e6510ed56fdc35aa712b4c0f54c52ac0')
|
||||
source=("rawtherapee::git+https://github.com/Beep6581/RawTherapee.git#commit=$_pkgver"
|
||||
rawtherapee-gcc6.patch::"https://github.com/Beep6581/RawTherapee/commit/5cd202dd.patch"
|
||||
'0001-char-fix-for-ARM.patch')
|
||||
md5sums=('SKIP'
|
||||
'398a38f531f7c8c37b4789f9560914e2'
|
||||
'585a1fc6a1e4e1ce5c479279eba44eb0')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
# Fix build with GCC 6
|
||||
patch -p1 -i ../rawtherapee-gcc6.patch
|
||||
|
||||
git apply ../0001-char-fix-for-ARM.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
mkdir -p "$srcdir/$pkgname-build"
|
||||
cd "$srcdir/$pkgname-build"
|
||||
|
||||
cmake "$srcdir/$pkgname" \
|
||||
-DCMAKE_CXX_FLAGS="-std=c++11" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-build"
|
||||
make DESTDIR="$pkgdir/" install
|
||||
}
|
||||
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
Loading…
Reference in a new issue