core/linux-armv7-rc to 4.1.rc8-1

This commit is contained in:
Kevin Mihelich 2015-06-16 11:45:56 +00:00
parent 9a811214b6
commit 9c15b077ad
9 changed files with 73 additions and 32 deletions

View file

@ -1,7 +1,7 @@
From 3a677d71c6ede91c070ea22f60f343ee0e88a757 Mon Sep 17 00:00:00 2001
From 4b71aa5c2f8c1384113abefee4cc04febe5944dd Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/6] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 1/7] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
};
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From 03e44453292b21a4dad61e0fa79256117ec77c1b Mon Sep 17 00:00:00 2001
From 5c2fcc45bf5f0639fc0779a368fc6708d771e03e Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/6] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
Subject: [PATCH 2/7] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
}
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From 9b0a514ba63698a2b6b4325417e564ff2eec2b94 Mon Sep 17 00:00:00 2001
From ef219483b7217495b3307abba505067c6935dac4 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/6] SMILE Plug device tree file
Subject: [PATCH 3/7] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index a1c776b..6ab2088 100644
index 992736b..2373ab3 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -613,6 +613,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
@@ -625,6 +625,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-mirabox.dtb \
@ -205,5 +205,5 @@ index 0000000..d01308a
+ };
+};
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From 056f8039e01eacbc6cacb092dd185fc164fc65e5 Mon Sep 17 00:00:00 2001
From 924f341f6e272bf3356b5f636cfa8e3e62ed02f0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/6] fix mvsdio eMMC timing
Subject: [PATCH 4/7] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index a448498..14441a6 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From 3ff4af4308c4cfd2609c8d1dd56dd75cf067f972 Mon Sep 17 00:00:00 2001
From adcfd377f7e6887ed91ea999f1dece87f6c1748b Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/6] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 5/7] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index 26423ad..e29a323 100644
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
dev->net->dev_addr) == 0) {
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From e7fc48bbd091e2e9bc8bd59f6a6818a6a8a89729 Mon Sep 17 00:00:00 2001
From fe5199f417904bf8ae27a9939cb585959f98400d Mon Sep 17 00:00:00 2001
From: dobatog <dobatog@gmail.com>
Date: Thu, 26 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/6] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
Subject: [PATCH 6/7] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
related to input routing signals.
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
@ -45,5 +45,5 @@ index cc17e7e..891f3aa 100644
/* input mux */
{"Capture Source", "Line", "Line Input"},
--
2.3.5
2.4.3

View file

@ -0,0 +1,33 @@
From a43e9af55ac3116a6ea2d3d0686820ee95e4839a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 14 Jun 2015 13:20:25 -0600
Subject: [PATCH 7/7] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/sun7i-a20-cubietruck.dts | 2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
index 8f74a64..1161296 100644
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
@@ -205,6 +205,7 @@
blue {
label = "cubietruck:blue:usr";
gpios = <&pio 7 21 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "heartbeat";
};
orange {
@@ -220,6 +221,7 @@
green {
label = "cubietruck:green:usr";
gpios = <&pio 7 7 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "mmc0";
};
};
--
2.4.3

View file

@ -4,7 +4,7 @@
buildarch=4
_rcver=4.1
_rcrel=7
_rcrel=8
_rcnrel=armv7-x0
pkgbase=linux-armv7-rc
@ -27,17 +27,19 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0004-fix-mvsdio-eMMC-timing.patch'
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
'0007-set-default-cubietruck-led-triggers.patch'
'config')
md5sums=('a86916bd12798220da9eb4a1eec3616d'
'a831062aea035ee4bae52e59ccf0cf71'
'd9c86d1422a68019d65913eb0a4eb68c'
'ae06c5772832d351d49b8ac0fe4a9ce2'
'7057519a84b74c1a4ec4981396edd845'
'1ce8c458126bfaf005366bc2e70ad866'
'90911aad404f80fcf81488da57bf2906'
'1a9033f9bd00f5397ba5ce5bdc842220'
'648459624ebad128af1faa55a29d0e7d'
'ecd3b00f8dea7a962e2bdc9ba90f967b')
'9bd2e3045ff03759558a5d94a27dfdc4'
'b971bc289adf814e5e5e3315307bf1d4'
'f9ea147ecd7d796df4aa281c9ebf941b'
'25247d01ce6520201f49e6b21d5e467e'
'34489b347a9efb594c31ebf01d8c2e3d'
'32ea5a4455150da7c258b104a1f6e831'
'118b747e801e6ddfd898c9e356220f28'
'fa1c571243107cb76c265acacc48e05e'
'6fb01f0b5cd05de3a44ebf30599eddf9'
'5862f4b2448c084d5cd686eea14beb10')
prepare() {
cd "${srcdir}/${_srcname}"
@ -55,6 +57,7 @@ prepare() {
git apply ../0004-fix-mvsdio-eMMC-timing.patch
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
git apply ../0007-set-default-cubietruck-led-triggers.patch
cat "${srcdir}/config" > ./.config

View file

@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 4.1.0-rc6-1 Kernel Configuration
# Linux/arm 4.1.0-rc8-1 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@ -1913,6 +1913,8 @@ CONFIG_TI_DAC7512=m
# CONFIG_LATTICE_ECP3_CONFIG is not set
CONFIG_SRAM=y
CONFIG_BONE_CAPEMGR=y
# CONFIG_DEV_OVERLAYMGR is not set
CONFIG_TIEQEP=m
CONFIG_C2PORT=m
#
@ -1924,7 +1926,6 @@ CONFIG_EEPROM_LEGACY=m
CONFIG_EEPROM_MAX6875=m
CONFIG_EEPROM_93CX6=m
CONFIG_EEPROM_93XX46=m
CONFIG_EEPROM_SUNXI_SID=y
# CONFIG_CB710_CORE is not set
#
@ -1955,6 +1956,7 @@ CONFIG_ALTERA_STAPL=m
# Argus cape driver for beaglebone black
#
CONFIG_CAPE_BONE_ARGUS=y
# CONFIG_BEAGLEBONE_PINMUX_HELPER is not set
# CONFIG_ECHO is not set
# CONFIG_CXL_BASE is not set
CONFIG_HAVE_IDE=y
@ -3258,6 +3260,7 @@ CONFIG_OF_GPIO=y
CONFIG_GPIOLIB_IRQCHIP=y
# CONFIG_DEBUG_GPIO is not set
CONFIG_GPIO_SYSFS=y
# CONFIG_GPIO_OF_HELPER is not set
CONFIG_GPIO_GENERIC=y
CONFIG_GPIO_MAX730X=m
@ -6250,6 +6253,8 @@ CONFIG_RAS=y
CONFIG_ANDROID=y
CONFIG_ANDROID_BINDER_IPC=y
CONFIG_ANDROID_BINDER_IPC_32BIT=y
CONFIG_NVMEM=y
CONFIG_NVMEM_SUNXI_SID=y
#
# Firmware Drivers