mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/python to 3.2.3-1
This commit is contained in:
parent
a3a6da0e6f
commit
9c39598e38
2 changed files with 4 additions and 23 deletions
|
@ -10,8 +10,8 @@
|
|||
plugrel=1
|
||||
|
||||
pkgname=python
|
||||
pkgver=3.2.2
|
||||
pkgrel=2
|
||||
pkgver=3.2.3
|
||||
pkgrel=1
|
||||
_pybasever=3.2
|
||||
pkgdesc="Next generation of the python high-level scripting language"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -23,10 +23,8 @@ optdepends=('tk: for tkinter' 'sqlite3')
|
|||
provides=('python3')
|
||||
replaces=('python3')
|
||||
options=('!makeflags')
|
||||
source=(http://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz
|
||||
gdbm-magic-values.patch)
|
||||
sha1sums=('5e654dbd48476193ccdef4d604ed4f45b48c6769'
|
||||
'43bfbe3e23360f412b95cb284ff29b2cbe338be9')
|
||||
source=(http://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz)
|
||||
sha1sums=('3d607dbcfdf100dd659978195ccf3ade9d221823')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/Python-${pkgver}"
|
||||
|
@ -34,10 +32,6 @@ build() {
|
|||
# FS#23997
|
||||
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
|
||||
|
||||
# gdbm has new magic that whichdb does not recognize
|
||||
# http://bugs.python.org/issue13007
|
||||
patch -Np1 -i ../gdbm-magic-values.patch
|
||||
|
||||
# Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
|
||||
# rather than copies shipped in the tarball
|
||||
rm -r Modules/expat
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff -up Python-3.2.2/Lib/dbm/__init__.py.gdbm-1.9-magic Python-3.2.2/Lib/dbm/__init__.py
|
||||
--- Python-3.2.2/Lib/dbm/__init__.py.gdbm-1.9-magic 2011-09-03 12:16:40.000000000 -0400
|
||||
+++ Python-3.2.2/Lib/dbm/__init__.py 2011-09-30 15:47:27.488863694 -0400
|
||||
@@ -166,7 +166,7 @@ def whichdb(filename):
|
||||
return ""
|
||||
|
||||
# Check for GNU dbm
|
||||
- if magic == 0x13579ace:
|
||||
+ if magic in (0x13579ace, 0x13579acd, 0x13579acf):
|
||||
return "dbm.gnu"
|
||||
|
||||
# Later versions of Berkeley db hash file have a 12-byte pad in
|
||||
diff -up Python-3.2.2/Misc/NEWS.gdbm-1.9-magic Python-3.2.2/Misc/NEWS
|
Loading…
Reference in a new issue