mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/rubberband to 1.8.2-1
This commit is contained in:
parent
40a894a5e2
commit
9c48127500
3 changed files with 62 additions and 45 deletions
37
community/rubberband/0001-fix-armv5-build.patch
Normal file
37
community/rubberband/0001-fix-armv5-build.patch
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
From 44dd88d1e683d1695524b0a52712146a2713f031 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Tue, 12 Jun 2018 17:37:24 -0600
|
||||||
|
Subject: [PATCH] fix armv5 build
|
||||||
|
|
||||||
|
---
|
||||||
|
src/system/sysutils.cpp | 14 --------------
|
||||||
|
1 file changed, 14 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/system/sysutils.cpp b/src/system/sysutils.cpp
|
||||||
|
index 64f18bb..c11c2d7 100644
|
||||||
|
--- a/src/system/sysutils.cpp
|
||||||
|
+++ b/src/system/sysutils.cpp
|
||||||
|
@@ -189,20 +189,6 @@ void system_specific_initialise()
|
||||||
|
fesetenv(FE_DFL_DISABLE_DENORMS_ENV);
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
-#if defined __ARMEL__
|
||||||
|
- // ARM32
|
||||||
|
- static const unsigned int x = 0x04086060;
|
||||||
|
- static const unsigned int y = 0x03000000;
|
||||||
|
- int r;
|
||||||
|
- asm volatile (
|
||||||
|
- "fmrx %0, fpscr \n\t"
|
||||||
|
- "and %0, %0, %1 \n\t"
|
||||||
|
- "orr %0, %0, %2 \n\t"
|
||||||
|
- "fmxr fpscr, %0 \n\t"
|
||||||
|
- : "=r"(r)
|
||||||
|
- : "r"(x), "r"(y)
|
||||||
|
- );
|
||||||
|
-#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
void system_specific_application_initialise()
|
||||||
|
--
|
||||||
|
2.16.2
|
||||||
|
|
|
@ -1,28 +0,0 @@
|
||||||
Description: Patch fixing build on armel
|
|
||||||
Author: Jaromír Mikeš <mira.mikes@seznam.cz>
|
|
||||||
Forwarded: yes
|
|
||||||
|
|
||||||
Index: rubberband/src/system/sysutils.cpp
|
|
||||||
===================================================================
|
|
||||||
--- rubberband.orig/src/system/sysutils.cpp 2013-06-05 14:18:50.718456311 +0200
|
|
||||||
+++ rubberband/src/system/sysutils.cpp 2013-06-05 14:22:36.759577185 +0200
|
|
||||||
@@ -219,19 +219,6 @@
|
|
||||||
fesetenv(FE_DFL_DISABLE_SSE_DENORMS_ENV);
|
|
||||||
#endif
|
|
||||||
#endif
|
|
||||||
-#if defined __ARMEL__
|
|
||||||
- static const unsigned int x = 0x04086060;
|
|
||||||
- static const unsigned int y = 0x03000000;
|
|
||||||
- int r;
|
|
||||||
- asm volatile (
|
|
||||||
- "fmrx %0, fpscr \n\t"
|
|
||||||
- "and %0, %0, %1 \n\t"
|
|
||||||
- "orr %0, %0, %2 \n\t"
|
|
||||||
- "fmxr fpscr, %0 \n\t"
|
|
||||||
- : "=r"(r)
|
|
||||||
- : "r"(x), "r"(y)
|
|
||||||
- );
|
|
||||||
-#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
void system_specific_application_initialise()
|
|
|
@ -1,36 +1,44 @@
|
||||||
# $Id$
|
# $Id$
|
||||||
# Maintainer: Ray Rashif <schiv@archlinux.org>
|
# Maintainer: David Runge <dave@sleepmap.de>
|
||||||
|
# Contributor: Ray Rashif <schiv@archlinux.org>
|
||||||
# Contributor: Felipe Machado aka arch_audio <machado.felipe@gmail.com>
|
# Contributor: Felipe Machado aka arch_audio <machado.felipe@gmail.com>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - patch to fix build on v5
|
# - patch to fix build on v5
|
||||||
|
# - makedepend on java 8 instead of 10
|
||||||
|
|
||||||
pkgname=rubberband
|
pkgname=rubberband
|
||||||
pkgver=1.8.1
|
pkgver=1.8.2
|
||||||
pkgrel=4
|
pkgrel=1
|
||||||
pkgdesc="Time-stretching and pitch-shifting audio library and utility"
|
pkgdesc="Time-stretching and pitch-shifting audio library and utility"
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url="http://www.breakfastquay.com/rubberband/"
|
url="https://www.breakfastquay.com/rubberband/"
|
||||||
license=('GPL')
|
license=('GPL2')
|
||||||
depends=('libsamplerate' 'fftw' 'vamp-plugin-sdk')
|
depends=('libsamplerate' 'fftw' 'vamp-plugin-sdk')
|
||||||
makedepends=('ladspa')
|
makedepends=('ladspa' 'java-environment=8')
|
||||||
#source=("http://code.breakfastquay.com/attachments/download/34/$pkgname-$pkgver.tar.bz2")
|
source=("$pkgname-$pkgver.tar.gz::https://github.com/breakfastquay/rubberband/archive/v$pkgver.tar.gz"
|
||||||
source=($pkgname-$pkgver.tar.gz::"https://github.com/breakfastquay/rubberband/archive/v$pkgver.tar.gz"
|
'0001-fix-armv5-build.patch')
|
||||||
'03-fix_build_on_armel.patch')
|
sha512sums=('b70e41fb1f68487d67b3935682100138ba898adeec9c8e7f8caa30f7bc94389c847d72a1b0b04f042d16d4b57019cc82c0fe79c8f302c3174e603e9bd0289abf'
|
||||||
md5sums=('43dc4b3db1bab59f68e494a01d05252a'
|
'a67d567afba2dc5439a58a0e099ad574ccb8c2c7544185a818ce5ae60c344c3affdcfbf69dcbc8db37bed955fb7388bd7981b8172e3ec56986032b8be0828ec2')
|
||||||
'48adb11a751eaf6324167da3a0530095')
|
|
||||||
|
prepare() {
|
||||||
|
cd "$pkgname-$pkgver"
|
||||||
|
[[ $CARCH == 'arm' ]] && patch -p1 -i ../0001-fix-armv5-build.patch
|
||||||
|
autoreconf -vfi
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/$pkgname-$pkgver"
|
cd "$pkgname-$pkgver"
|
||||||
|
|
||||||
[[ $CARCH == 'arm' ]] && patch -p1 -i ../03-fix_build_on_armel.patch
|
|
||||||
|
|
||||||
./configure --prefix=/usr
|
./configure --prefix=/usr
|
||||||
make
|
make
|
||||||
|
export JAVA_HOME=/usr/lib/jvm/java-8-openjdk
|
||||||
|
make jni
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd "$srcdir/$pkgname-$pkgver"
|
cd "$pkgname-$pkgver"
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" install
|
make DESTDIR="$pkgdir" install
|
||||||
|
# docs
|
||||||
|
install -vDm 644 {CHANGELOG,README.txt} \
|
||||||
|
-t "${pkgdir}/usr/share/doc/${pkgname}/"
|
||||||
}
|
}
|
||||||
|
|
Loading…
Reference in a new issue