mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/analitza: drop patch
This commit is contained in:
parent
cf89647975
commit
9ce07a620b
2 changed files with 3 additions and 30 deletions
|
@ -2,8 +2,7 @@
|
|||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to disable opengl for ARM
|
||||
# remove when bumped upstream
|
||||
|
||||
pkgname=analitza
|
||||
pkgver=15.12.0
|
||||
|
@ -16,18 +15,11 @@ depends=('qt5-svg' 'qt5-declarative')
|
|||
makedepends=('extra-cmake-modules' 'kdoctools' 'python' 'eigen')
|
||||
replaces=('kdebase-analitza')
|
||||
conflicts=('kdebase-analitza')
|
||||
source=("http://download.kde.org/stable/applications/${pkgver}/src/analitza-${pkgver}.tar.xz"
|
||||
'analitza-disable-opengl.patch')
|
||||
sha1sums=('a579cf0f2ab409e4190ba7e6c1832059fbfe9d3e'
|
||||
'db4b031c52e10272af54542eebef5b68d8bd0c45')
|
||||
source=("http://download.kde.org/stable/applications/${pkgver}/src/analitza-${pkgver}.tar.xz")
|
||||
sha1sums=('a579cf0f2ab409e4190ba7e6c1832059fbfe9d3e')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
cd "${srcdir}/analitza-${pkgver}"
|
||||
if [[ $CARCH != "aarch64" ]]; then
|
||||
patch -p1 -i ../analitza-disable-opengl.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2015-01-05 13:24:31.000000000 -0700
|
||||
+++ b/CMakeLists.txt 2015-01-24 10:23:32.169332291 -0700
|
||||
@@ -29,14 +29,7 @@
|
||||
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/analitza_version.h"
|
||||
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/Analitza5ConfigVersion.cmake")
|
||||
|
||||
-find_package(OpenGL)
|
||||
-set_package_properties(OpenGL PROPERTIES TYPE OPTIONAL
|
||||
- PURPOSE "Support for 3D graphs in Analitza"
|
||||
- URL "http://opengl.org")
|
||||
-if(OPENGL_FOUND)
|
||||
- find_package(Qt5OpenGL ${QT_REQUIRED_VERSION} REQUIRED NO_MODULE)
|
||||
-endif()
|
||||
-set(HAVE_OPENGL ${Qt5OpenGL_FOUND})
|
||||
+set(HAVE_OPENGL FALSE)
|
||||
|
||||
find_package(Eigen3) # find and setup Eigen3 if available
|
||||
set(HAVE_EIGEN3 ${EIGEN3_FOUND})
|
Loading…
Reference in a new issue