diff --git a/core/linux-rpi/PKGBUILD b/core/linux-rpi/PKGBUILD
index 5190b02b6..0f25ce374 100644
--- a/core/linux-rpi/PKGBUILD
+++ b/core/linux-rpi/PKGBUILD
@@ -5,11 +5,11 @@
 # Contributer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
 
 pkgbase=linux-rpi
-_commit=f5035e6c8927aa53d478ba1aedffed26b62ce218
+_commit=2cca267016006654836c46bdd8efa8f9b6402e5d
 _srcname=linux-${_commit}
 _kernelname=${pkgbase#linux}
 pkgver=5.15.38
-pkgrel=1
+pkgrel=2
 pkgdesc='Linux'
 url="http://www.kernel.org/"
 arch=(armv7h aarch64)
@@ -27,15 +27,15 @@ source=("linux-$pkgver-${_commit:0:10}.tar.gz::https://github.com/raspberrypi/li
         60-linux.hook
         90-linux.hook
 )
-md5sums=('0276072b580075f68c640bf145570b3f'
+md5sums=('88ce62525834c71cee5fabc92359af7a'
          '31c02f4518d46deb5f0c2ad1f8b083cd'
          'f66a7ea3feb708d398ef57e4da4815e9'
          '86d4a35722b5410e3b29fc92dae15d4b'
          '0a5f16bfec6ad982a2f6782724cca8ba'
          '441ec084c47cddc53e592fb0cbce4edf')
-md5sums_armv7h=('51efdae880559643a227f7c389cb285d'
+md5sums_armv7h=('5084c58ac60b4f0c26a725ed4b98c5f5'
                 'a9a05a9e8487584b10a0191dd53e5170')
-md5sums_aarch64=('5c8ae606f85860016b75807368ffbcd7'
+md5sums_aarch64=('187dc4b315270fe8f27aae8b15b99a13'
                  'a9a05a9e8487584b10a0191dd53e5170')
 
 # setup vars
diff --git a/core/linux-rpi/config b/core/linux-rpi/config
index 0e74379a8..96b3c6152 100644
--- a/core/linux-rpi/config
+++ b/core/linux-rpi/config
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/arm 5.15.36 Kernel Configuration
+# Linux/arm 5.15.38 Kernel Configuration
 #
 CONFIG_CC_VERSION_TEXT="gcc (GCC) 11.2.0"
 CONFIG_CC_IS_GCC=y
@@ -3974,6 +3974,7 @@ CONFIG_SENSORS_SHTC1=m
 # CONFIG_SENSORS_DME1737 is not set
 # CONFIG_SENSORS_EMC1403 is not set
 # CONFIG_SENSORS_EMC2103 is not set
+CONFIG_SENSORS_EMC2305=m
 # CONFIG_SENSORS_EMC6W201 is not set
 # CONFIG_SENSORS_SMSC47M1 is not set
 # CONFIG_SENSORS_SMSC47M192 is not set
diff --git a/core/linux-rpi/config8 b/core/linux-rpi/config8
index ac07a2138..f34b7d1a5 100644
--- a/core/linux-rpi/config8
+++ b/core/linux-rpi/config8
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/arm64 5.15.36 Kernel Configuration
+# Linux/arm64 5.15.38 Kernel Configuration
 #
 CONFIG_CC_VERSION_TEXT="gcc (GCC) 11.2.0"
 CONFIG_CC_IS_GCC=y
@@ -3988,6 +3988,7 @@ CONFIG_SENSORS_SHTC1=m
 # CONFIG_SENSORS_DME1737 is not set
 # CONFIG_SENSORS_EMC1403 is not set
 # CONFIG_SENSORS_EMC2103 is not set
+CONFIG_SENSORS_EMC2305=m
 # CONFIG_SENSORS_EMC6W201 is not set
 # CONFIG_SENSORS_SMSC47M1 is not set
 # CONFIG_SENSORS_SMSC47M192 is not set