mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
added extra/libdrm
This commit is contained in:
parent
21f297bdea
commit
9cf24ee88e
3 changed files with 204 additions and 0 deletions
48
extra/libdrm/COPYING
Normal file
48
extra/libdrm/COPYING
Normal file
|
@ -0,0 +1,48 @@
|
||||||
|
Copyright 2005 Adam Jackson.
|
||||||
|
|
||||||
|
Permission is hereby granted, free of charge, to any person obtaining
|
||||||
|
a copy of this software and associated documentation files (the
|
||||||
|
"Software"), to deal in the Software without restriction, including
|
||||||
|
without limitation on the rights to use, copy, modify, merge,
|
||||||
|
publish, distribute, sub license, and/or sell copies of the Software,
|
||||||
|
and to permit persons to whom the Software is furnished to do so,
|
||||||
|
subject to the following conditions:
|
||||||
|
|
||||||
|
The above copyright notice and this permission notice (including the
|
||||||
|
next paragraph) shall be included in all copies or substantial
|
||||||
|
portions of the Software.
|
||||||
|
|
||||||
|
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
||||||
|
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
||||||
|
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
||||||
|
NON-INFRINGEMENT. IN NO EVENT SHALL ADAM JACKSON BE LIABLE FOR ANY
|
||||||
|
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
|
||||||
|
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
|
||||||
|
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
||||||
|
|
||||||
|
------------------------------------------------------------------------
|
||||||
|
|
||||||
|
Copyright 1999 Precision Insight, Inc., Cedar Park, Texas.
|
||||||
|
Copyright 2000 VA Linux Systems, Inc., Sunnyvale, California.
|
||||||
|
All Rights Reserved.
|
||||||
|
|
||||||
|
Permission is hereby granted, free of charge, to any person obtaining
|
||||||
|
a copy of this software and associated documentation files (the
|
||||||
|
"Software"), to deal in the Software without restriction, including
|
||||||
|
without limitation the rights to use, copy, modify, merge, publish,
|
||||||
|
distribute, sublicense, and/or sell copies of the Software, and to
|
||||||
|
permit persons to whom the Software is furnished to do so, subject to
|
||||||
|
the following conditions:
|
||||||
|
|
||||||
|
The above copyright notice and this permission notice (including the
|
||||||
|
next paragraph) shall be included in all copies or substantial
|
||||||
|
portions of the Software.
|
||||||
|
|
||||||
|
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
||||||
|
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
||||||
|
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
||||||
|
NONINFRINGEMENT. IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS
|
||||||
|
SUPPLIERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
||||||
|
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
||||||
|
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
|
||||||
|
DEALINGS IN THE SOFTWARE.
|
50
extra/libdrm/PKGBUILD
Normal file
50
extra/libdrm/PKGBUILD
Normal file
|
@ -0,0 +1,50 @@
|
||||||
|
# $Id: PKGBUILD 162833 2012-07-01 07:57:51Z andyrtr $
|
||||||
|
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - enabled OMAP and Exynos APIs
|
||||||
|
# - extended no-pthread-stubs.patch for OMAP/Exynos Makefiles
|
||||||
|
|
||||||
|
pkgname=libdrm
|
||||||
|
pkgver=2.4.37
|
||||||
|
pkgrel=1.1
|
||||||
|
pkgdesc="Userspace interface to kernel DRM services"
|
||||||
|
arch=(i686 x86_64)
|
||||||
|
license=('custom')
|
||||||
|
depends=('glibc' 'libpciaccess')
|
||||||
|
makedepends=('cairo' 'valgrind')
|
||||||
|
replaces=('libdrm-new' 'libdrm-nouveau')
|
||||||
|
options=('!libtool')
|
||||||
|
url="http://dri.freedesktop.org/"
|
||||||
|
source=(http://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2
|
||||||
|
no-pthread-stubs.patch
|
||||||
|
COPYING)
|
||||||
|
sha256sums=('e4ea39a901d4a8e59064f10f413bb037dad7790f7c16a5986e7cc1453b36488f'
|
||||||
|
'b1f3ae7f2cf80de3451c3f2bc576dbbf8d3a44e5d1f2608f3ebd276c4c32227c'
|
||||||
|
'9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93')
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd $pkgname-$pkgver
|
||||||
|
patch -Np1 -i ../no-pthread-stubs.patch
|
||||||
|
|
||||||
|
#libtoolize --force
|
||||||
|
autoreconf --force --install
|
||||||
|
./configure --prefix=/usr \
|
||||||
|
--enable-udev \
|
||||||
|
--enable-vmwgfx-experimental-api \
|
||||||
|
--enable-omap-experimental-api \
|
||||||
|
--enable-exynos-experimental-api
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
check() {
|
||||||
|
cd $pkgname-$pkgver
|
||||||
|
make -k check
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd $pkgname-$pkgver
|
||||||
|
make DESTDIR="$pkgdir" install
|
||||||
|
install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
|
||||||
|
install -m644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/"
|
||||||
|
}
|
106
extra/libdrm/no-pthread-stubs.patch
Normal file
106
extra/libdrm/no-pthread-stubs.patch
Normal file
|
@ -0,0 +1,106 @@
|
||||||
|
diff -urN a/configure.ac b/configure.ac
|
||||||
|
--- a/configure.ac 2012-06-29 12:08:00.000000000 -0600
|
||||||
|
+++ b/configure.ac 2012-07-02 09:23:15.765231785 -0600
|
||||||
|
@@ -47,10 +47,6 @@
|
||||||
|
LT_INIT([disable-static])
|
||||||
|
|
||||||
|
|
||||||
|
-PKG_CHECK_MODULES(PTHREADSTUBS, pthread-stubs)
|
||||||
|
-AC_SUBST(PTHREADSTUBS_CFLAGS)
|
||||||
|
-AC_SUBST(PTHREADSTUBS_LIBS)
|
||||||
|
-
|
||||||
|
pkgconfigdir=${libdir}/pkgconfig
|
||||||
|
AC_SUBST(pkgconfigdir)
|
||||||
|
AC_ARG_ENABLE([udev],
|
||||||
|
diff -urN a/exynos/Makefile.am b/exynos/Makefile.am
|
||||||
|
--- a/exynos/Makefile.am 2012-06-05 12:26:51.000000000 -0600
|
||||||
|
+++ b/exynos/Makefile.am 2012-07-02 09:23:44.094193309 -0600
|
||||||
|
@@ -2,13 +2,12 @@
|
||||||
|
$(WARN_CFLAGS) \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-I$(top_srcdir)/exynos \
|
||||||
|
- $(PTHREADSTUBS_CFLAGS) \
|
||||||
|
-I$(top_srcdir)/include/drm
|
||||||
|
|
||||||
|
libdrm_exynos_la_LTLIBRARIES = libdrm_exynos.la
|
||||||
|
libdrm_exynos_ladir = $(libdir)
|
||||||
|
libdrm_exynos_la_LDFLAGS = -version-number 1:0:0 -no-undefined
|
||||||
|
-libdrm_exynos_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
|
||||||
|
+libdrm_exynos_la_LIBADD = ../libdrm.la
|
||||||
|
|
||||||
|
libdrm_exynos_la_SOURCES = exynos_drm.c
|
||||||
|
|
||||||
|
diff -urN a/intel/Makefile.am b/intel/Makefile.am
|
||||||
|
--- a/intel/Makefile.am 2012-03-12 21:20:29.000000000 -0600
|
||||||
|
+++ b/intel/Makefile.am 2012-07-02 09:23:15.765231785 -0600
|
||||||
|
@@ -26,7 +26,6 @@
|
||||||
|
$(WARN_CFLAGS) \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-I$(top_srcdir)/intel \
|
||||||
|
- $(PTHREADSTUBS_CFLAGS) \
|
||||||
|
$(PCIACCESS_CFLAGS) \
|
||||||
|
$(VALGRIND_CFLAGS) \
|
||||||
|
-I$(top_srcdir)/include/drm
|
||||||
|
@@ -35,7 +34,6 @@
|
||||||
|
libdrm_intel_ladir = $(libdir)
|
||||||
|
libdrm_intel_la_LDFLAGS = -version-number 1:0:0 -no-undefined
|
||||||
|
libdrm_intel_la_LIBADD = ../libdrm.la \
|
||||||
|
- @PTHREADSTUBS_LIBS@ \
|
||||||
|
@PCIACCESS_LIBS@ \
|
||||||
|
@CLOCK_LIB@
|
||||||
|
|
||||||
|
diff -urN a/nouveau/Makefile.am b/nouveau/Makefile.am
|
||||||
|
--- a/nouveau/Makefile.am 2012-04-21 20:18:55.000000000 -0600
|
||||||
|
+++ b/nouveau/Makefile.am 2012-07-02 09:23:15.765231785 -0600
|
||||||
|
@@ -2,14 +2,13 @@
|
||||||
|
$(WARN_CFLAGS) \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-I$(top_srcdir)/nouveau \
|
||||||
|
- $(PTHREADSTUBS_CFLAGS) \
|
||||||
|
-I$(top_srcdir)/include/drm \
|
||||||
|
-DDEBUG
|
||||||
|
|
||||||
|
libdrm_nouveau_la_LTLIBRARIES = libdrm_nouveau.la
|
||||||
|
libdrm_nouveau_ladir = $(libdir)
|
||||||
|
libdrm_nouveau_la_LDFLAGS = -version-number 2:0:0 -no-undefined
|
||||||
|
-libdrm_nouveau_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
|
||||||
|
+libdrm_nouveau_la_LIBADD = ../libdrm.la
|
||||||
|
|
||||||
|
libdrm_nouveau_la_SOURCES = nouveau.c \
|
||||||
|
pushbuf.c \
|
||||||
|
diff -urN a/omap/Makefile.am b/omap/Makefile.am
|
||||||
|
--- a/omap/Makefile.am 2012-03-29 20:56:27.000000000 -0600
|
||||||
|
+++ b/omap/Makefile.am 2012-07-02 09:23:31.929770653 -0600
|
||||||
|
@@ -2,13 +2,12 @@
|
||||||
|
$(WARN_CFLAGS) \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-I$(top_srcdir)/omap \
|
||||||
|
- $(PTHREADSTUBS_CFLAGS) \
|
||||||
|
-I$(top_srcdir)/include/drm
|
||||||
|
|
||||||
|
libdrm_omap_la_LTLIBRARIES = libdrm_omap.la
|
||||||
|
libdrm_omap_ladir = $(libdir)
|
||||||
|
libdrm_omap_la_LDFLAGS = -version-number 1:0:0 -no-undefined
|
||||||
|
-libdrm_omap_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
|
||||||
|
+libdrm_omap_la_LIBADD = ../libdrm.la
|
||||||
|
|
||||||
|
libdrm_omap_la_SOURCES = omap_drm.c
|
||||||
|
|
||||||
|
diff -urN a/radeon/Makefile.am b/radeon/Makefile.am
|
||||||
|
--- a/radeon/Makefile.am 2012-02-07 03:45:59.000000000 -0700
|
||||||
|
+++ b/radeon/Makefile.am 2012-07-02 09:23:15.765231785 -0600
|
||||||
|
@@ -26,13 +26,12 @@
|
||||||
|
$(WARN_CFLAGS) \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-I$(top_srcdir)/radeon \
|
||||||
|
- $(PTHREADSTUBS_CFLAGS) \
|
||||||
|
-I$(top_srcdir)/include/drm
|
||||||
|
|
||||||
|
libdrm_radeon_la_LTLIBRARIES = libdrm_radeon.la
|
||||||
|
libdrm_radeon_ladir = $(libdir)
|
||||||
|
libdrm_radeon_la_LDFLAGS = -version-number 1:0:0 -no-undefined
|
||||||
|
-libdrm_radeon_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
|
||||||
|
+libdrm_radeon_la_LIBADD = ../libdrm.la
|
||||||
|
|
||||||
|
libdrm_radeon_la_SOURCES = \
|
||||||
|
radeon_bo_gem.c \
|
Loading…
Reference in a new issue