mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/rubberband
This commit is contained in:
parent
40d7363e4c
commit
9d01db007c
2 changed files with 63 additions and 0 deletions
28
extra/rubberband/03-fix_build_on_armel.patch
Normal file
28
extra/rubberband/03-fix_build_on_armel.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
Description: Patch fixing build on armel
|
||||
Author: Jaromír Mikeš <mira.mikes@seznam.cz>
|
||||
Forwarded: yes
|
||||
|
||||
Index: rubberband/src/system/sysutils.cpp
|
||||
===================================================================
|
||||
--- rubberband.orig/src/system/sysutils.cpp 2013-06-05 14:18:50.718456311 +0200
|
||||
+++ rubberband/src/system/sysutils.cpp 2013-06-05 14:22:36.759577185 +0200
|
||||
@@ -219,19 +219,6 @@
|
||||
fesetenv(FE_DFL_DISABLE_SSE_DENORMS_ENV);
|
||||
#endif
|
||||
#endif
|
||||
-#if defined __ARMEL__
|
||||
- static const unsigned int x = 0x04086060;
|
||||
- static const unsigned int y = 0x03000000;
|
||||
- int r;
|
||||
- asm volatile (
|
||||
- "fmrx %0, fpscr \n\t"
|
||||
- "and %0, %0, %1 \n\t"
|
||||
- "orr %0, %0, %2 \n\t"
|
||||
- "fmxr fpscr, %0 \n\t"
|
||||
- : "=r"(r)
|
||||
- : "r"(x), "r"(y)
|
||||
- );
|
||||
-#endif
|
||||
}
|
||||
|
||||
void system_specific_application_initialise()
|
35
extra/rubberband/PKGBUILD
Normal file
35
extra/rubberband/PKGBUILD
Normal file
|
@ -0,0 +1,35 @@
|
|||
# $Id$
|
||||
# Maintainer: Ray Rashif <schiv@archlinux.org>
|
||||
# Contributor: Felipe Machado aka arch_audio <machado.felipe@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix build on v5
|
||||
|
||||
pkgname=rubberband
|
||||
pkgver=1.8.1
|
||||
pkgrel=2
|
||||
pkgdesc="Time-stretching and pitch-shifting audio library and utility"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.breakfastquay.com/rubberband/"
|
||||
license=('GPL')
|
||||
depends=('libsamplerate' 'fftw' 'vamp-plugin-sdk')
|
||||
makedepends=('ladspa')
|
||||
source=("http://code.breakfastquay.com/attachments/download/34/$pkgname-$pkgver.tar.bz2"
|
||||
'03-fix_build_on_armel.patch')
|
||||
md5sums=('6c2b4e18a714bcc297d0db81a10f9348'
|
||||
'48adb11a751eaf6324167da3a0530095')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
[[ $CARCH == 'arm' ]] && patch -p1 -i ../03-fix_build_on_armel.patch
|
||||
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
Loading…
Reference in a new issue