extra/qt6-webengine to 6.6.2-1

This commit is contained in:
Kevin Mihelich 2024-02-16 14:05:51 +00:00
parent fa8dee0ea0
commit 9d0924a356
4 changed files with 15 additions and 64 deletions

View file

@ -1,7 +1,7 @@
pkgbase = qt6-webengine
pkgdesc = Provides support for web applications using the Chromium browser project
pkgver = 6.6.1
pkgrel = 2
pkgver = 6.6.2
pkgrel = 1
url = https://www.qt.io
arch = x86_64
groups = qt6
@ -64,11 +64,7 @@ pkgbase = qt6-webengine
depends = ttf-font
depends = zlib
optdepends = pipewire: WebRTC desktop sharing under Wayland
source = https://download.qt.io/official_releases/qt/6.6/6.6.1/submodules/qtwebengine-everywhere-src-6.6.1.tar.xz
source = libxml-2.12.patch
source = icu-74.patch
sha256sums = 7a6ea228214bd66029ca90549b29021f30f7544abff997b7f831ceac2ce73691
sha256sums = bfae9e773edfd0ddbc617777fdd4c0609cba2b048be7afe40f97768e4eb6117e
sha256sums = 547e092f6a20ebd15e486b31111145bc94b8709ec230da89c591963001378845
source = https://download.qt.io/official_releases/qt/6.6/6.6.2/submodules/qtwebengine-everywhere-src-6.6.2.tar.xz
sha256sums = d61d87b2d2ccf8487e248bd8777d208ba3acd65bd60d6bb7d87dbaafa3850396
pkgname = qt6-webengine

View file

@ -9,9 +9,9 @@
highmem=1
pkgname=qt6-webengine
_qtver=6.6.1
_qtver=6.6.2
pkgver=${_qtver/-/}
pkgrel=2
pkgrel=1
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@ -76,20 +76,13 @@ optdepends=('pipewire: WebRTC desktop sharing under Wayland')
groups=(qt6)
_pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
libxml-2.12.patch
icu-74.patch
0001-ARM-toolchain-fixes.patch
0002-Run-blink-bindings-generation-single-threaded.patch)
sha256sums=('7a6ea228214bd66029ca90549b29021f30f7544abff997b7f831ceac2ce73691'
'bfae9e773edfd0ddbc617777fdd4c0609cba2b048be7afe40f97768e4eb6117e'
'547e092f6a20ebd15e486b31111145bc94b8709ec230da89c591963001378845'
sha256sums=('d61d87b2d2ccf8487e248bd8777d208ba3acd65bd60d6bb7d87dbaafa3850396'
'772aeba76d16387e28ef629285965109a4bfaa02ca2dd466e9526fe2030773ec'
'eff4ebf2e714185ef6e36e30c8d2158da6b41a46e3168d06472d35f6c9977aaf')
prepare() {
patch -d $_pkgfn/src/3rdparty/chromium -p1 < libxml-2.12.patch
patch -d $_pkgfn/src/3rdparty/chromium -p1 < icu-74.patch # Fix build with ICU 74 - patch from Alpine
cd $_pkgfn
if [[ $CARCH == "armv7h" ]]; then
@ -102,6 +95,10 @@ prepare() {
}
build() {
# this uses malloc_usable_size, which is incompatible with fortification level 3
export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
export CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
cmake -B build -S $_pkgfn -G Ninja \
-DCMAKE_MESSAGE_LOG_LEVEL=STATUS \
-DCMAKE_TOOLCHAIN_FILE=/usr/lib/cmake/Qt6/qt.toolchain.cmake \
@ -115,6 +112,10 @@ build() {
}
package() {
# this uses malloc_usable_size, which is incompatible with fortification level 3
export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
export CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
DESTDIR="$pkgdir" cmake --install build
install -Dm644 "$srcdir"/${_pkgfn}/src/3rdparty/chromium/LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE.chromium

View file

@ -1,20 +0,0 @@
See ICU change https://github.com/unicode-org/icu/commit/2e45e6ec0e84a1c01812015a254ea31b286316fb
Similar has happened in the past. See:
https://chromium.googlesource.com/chromium/src/+/e60b571faa3f14dd9119a6792dccf12f8bf80192
diff --git a/third_party/blink/renderer/platform/text/text_break_iterator.cc b/third_party/blink/renderer/platform/text/text_break_iterator.cc
index ddfbd51..247da06 100644
--- a/third_party/blink/renderer/platform/text/text_break_iterator.cc
+++ b/third_party/blink/renderer/platform/text/text_break_iterator.cc
@@ -161,7 +161,9 @@ static const unsigned char kAsciiLineBreakTable[][(kAsciiLineBreakTableLastChar
};
// clang-format on
-#if U_ICU_VERSION_MAJOR_NUM >= 58
+#if U_ICU_VERSION_MAJOR_NUM >= 74
+#define BA_LB_COUNT (U_LB_COUNT - 8)
+#elif U_ICU_VERSION_MAJOR_NUM >= 58
#define BA_LB_COUNT (U_LB_COUNT - 3)
#else
#define BA_LB_COUNT U_LB_COUNT

View file

@ -1,26 +0,0 @@
diff --git a/third_party/blink/renderer/core/xml/xslt_processor.h b/third_party/blink/renderer/core/xml/xslt_processor.h
index d53835e9675793..2eaea31ed29b90 100644
--- a/third_party/blink/renderer/core/xml/xslt_processor.h
+++ b/third_party/blink/renderer/core/xml/xslt_processor.h
@@ -77,7 +77,7 @@ class XSLTProcessor final : public ScriptWrappable {
void reset();
- static void ParseErrorFunc(void* user_data, xmlError*);
+ static void ParseErrorFunc(void* user_data, const xmlError*);
static void GenericErrorFunc(void* user_data, const char* msg, ...);
// Only for libXSLT callbacks
diff --git a/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc b/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
index 133e0b3355d2f0..f424077089da87 100644
--- a/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
+++ b/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
@@ -66,7 +66,7 @@ void XSLTProcessor::GenericErrorFunc(void*, const char*, ...) {
// It would be nice to do something with this error message.
}
-void XSLTProcessor::ParseErrorFunc(void* user_data, xmlError* error) {
+void XSLTProcessor::ParseErrorFunc(void* user_data, const xmlError* error) {
FrameConsole* console = static_cast<FrameConsole*>(user_data);
if (!console)
return;