mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/mythtv fixes
This commit is contained in:
parent
c84fd7834f
commit
9d1cb70547
3 changed files with 6 additions and 34 deletions
|
@ -1,7 +1,7 @@
|
|||
From 6c3a0ad55021370f645d41cf3997b61510b796ad Mon Sep 17 00:00:00 2001
|
||||
From 7531c19a2971645e5bae952d2c3e156c93a79e21 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 8 May 2016 14:22:20 -0600
|
||||
Subject: [PATCH 1/2] libudfread: set HAVE_PTHREAD_H
|
||||
Subject: [PATCH] libudfread: set HAVE_PTHREAD_H
|
||||
|
||||
---
|
||||
mythtv/external/libudfread/libudfread.pro | 2 +-
|
||||
|
@ -21,5 +21,5 @@ index 14a9af3..09f2256 100644
|
|||
inc.path = $${PREFIX}/include/mythtv/
|
||||
inc.files = blockinput.h udfread.h
|
||||
--
|
||||
2.8.2
|
||||
2.8.3
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From 8e1d4a498e02ac2398aa4b5478e3d265319f0e41 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 8 May 2016 14:56:39 -0600
|
||||
Subject: [PATCH 2/2] visualisations: fix ambiguous abs call
|
||||
|
||||
---
|
||||
mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp b/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp
|
||||
index 1140372..554b1f9 100644
|
||||
--- a/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp
|
||||
+++ b/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp
|
||||
@@ -23,7 +23,7 @@ void VideoVisualCircles::DrawPriv(MythPainter *painter, QPaintDevice* device)
|
||||
painter->Begin(device);
|
||||
for (int i = 0; i < count; i++, rad += m_range, red += incr, green -= incr)
|
||||
{
|
||||
- double mag = abs((m_magnitudes[i] + m_magnitudes[i + count]) / 2.0);
|
||||
+ double mag = fabs((m_magnitudes[i] + m_magnitudes[i + count]) / 2.0);
|
||||
if (mag > 1.0)
|
||||
{
|
||||
pen.setWidth((int)mag);
|
||||
--
|
||||
2.8.2
|
||||
|
|
@ -35,15 +35,13 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$p
|
|||
mythtv-fix-segfault.patch::"https://github.com/MythTV/mythtv/commit/c3a79298.patch"
|
||||
mythtv-gcc6.patch::"https://github.com/MythTV/mythtv/commit/e4f6e011.patch"
|
||||
'mythbackend.service' '99-mythbackend.rules'
|
||||
'0001-libudfread-set-HAVE_PTHREAD_H.patch'
|
||||
'0002-visualisations-fix-ambiguous-abs-call.patch')
|
||||
'0001-libudfread-set-HAVE_PTHREAD_H.patch')
|
||||
sha256sums=('7b3476c0ec0fc17d6b734f0440383815e81850a70b78c12ee40d61a408eba340'
|
||||
'60696991fcaa24fb61392401bd27cfa35a15b54f4bcc01aee54dc84440c6df99'
|
||||
'd35c4738f331ffff7d26d4cb98965689bdc72bd5b9776c1b31e5d97d06be724e'
|
||||
'ecfde779ded8332cc62c86fac6b432b09cbf5d254135798287ada688af9a1302'
|
||||
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
|
||||
'cd337cdf4de86c9343c1bcb6635ded717359cb249fde8eea4879b4abc7ee3c6b'
|
||||
'61cd9c37dc086131f41aea58e7a436acc76f79aa9dd0d5691941a3a8a16d3558')
|
||||
'c15efbcc7d8db4a185ef908861f48633353173012b18dada44df4c200fea8072')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver/$pkgname
|
||||
|
@ -56,8 +54,7 @@ prepare() {
|
|||
# Fix build with GCC 6
|
||||
patch -p1 -i "$srcdir"/mythtv-gcc6.patch
|
||||
|
||||
patch -p2 -i "${srcdir}/0001-libudfread-set-HAVE_PTHREAD_H.patch"
|
||||
patch -p2 -i "${srcdir}/0002-visualisations-fix-ambiguous-abs-call.patch"
|
||||
patch -p1 -i "${srcdir}/0001-libudfread-set-HAVE_PTHREAD_H.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue