core/glibc to 2.18-12

This commit is contained in:
Kevin Mihelich 2014-01-08 15:03:12 +00:00
parent dce3da1e11
commit 9d438825c2
2 changed files with 28 additions and 3 deletions

View file

@ -16,7 +16,7 @@ noautobuild=1
pkgname=glibc
pkgver=2.18
pkgrel=11
pkgrel=12
pkgdesc="GNU C Library"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/libc"
@ -39,6 +39,7 @@ source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
glibc-2.18-ptr-mangle-CVE-2013-4788.patch
glibc-2.18-getaddrinfo-CVE-2013-4458.patch
glibc-2.18-getaddrinfo-assertion.patch
glibc-2.18-xattr-compat-hack.patch
local-soname-hack.diff
fix-hf-ld.so.cache.patch
nscd.service
@ -56,6 +57,7 @@ md5sums=('88fbbceafee809e82efd52efa1e3c58f'
'd4d86add33f22125777e0ecff06bc9bb'
'01d19fe9b2aea489cf5651530e0369f2'
'4441f6dfe7d75ced1fa75e54dd21d36e'
'7ca96c68a37f2a4ab91792bfa0160a24'
'589d79041aa767a5179eaa4e2737dd3f'
'ad8a9af15ab7eeaa23dc7ee85024af9f'
'd5fab2cd3abea65aa5ae696ea4a47d6b'
@ -93,6 +95,9 @@ prepare() {
# hack fix for strstr issues on x86
patch -p1 -i $srcdir/glibc-2.18-strstr-hackfix.patch
# hack fix for {linux,sys}/xattr.h incompatibility
patch -p1 -i $srcdir/glibc-2.18-xattr-compat-hack.patch
# ALARM: patch for hard-float ld-linux soname
if [[ $CARCH == "armv6h" || $CARCH == "armv7h" ]]; then
patch -p1 -i ${srcdir}/local-soname-hack.diff
@ -178,8 +183,9 @@ package() {
${srcdir}/glibc-${pkgver}/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
# remove the static libraries that have a shared counterpart
# note: keep libc, libdl, libm, libpthread for binutils testsuite
rm $pkgdir/usr/lib/lib{anl,BrokenLocale,crypt,nsl,resolv,rt,util}.a
# libc, libdl, libm and libpthread are required for toolchain testsuites
# in addition libcrypt appears widely required
rm $pkgdir/usr/lib/lib{anl,BrokenLocale,nsl,resolv,rt,util}.a
# ALARM: symlink ld-linux.so.3 for hard-float
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && ln -s /lib/ld-${pkgver}.so ${pkgdir}/usr/lib/ld-linux.so.3

View file

@ -0,0 +1,19 @@
diff -Naur glibc-2.18-orig/misc/sys/xattr.h glibc-2.18/misc/sys/xattr.h
--- glibc-2.18-orig/misc/sys/xattr.h 2013-08-11 08:52:55.000000000 +1000
+++ glibc-2.18/misc/sys/xattr.h 2014-01-07 15:45:50.533969040 +1000
@@ -26,13 +26,8 @@
/* The following constants should be used for the fifth parameter of
`*setxattr'. */
-enum
-{
- XATTR_CREATE = 1, /* set value, fail if attr already exists. */
-#define XATTR_CREATE XATTR_CREATE
- XATTR_REPLACE = 2 /* set value, fail if attr does not exist. */
-#define XATTR_REPLACE XATTR_REPLACE
-};
+#define XATTR_CREATE 1
+#define XATTR_REPLACE 2
/* Set the attribute NAME of the file pointed to by PATH to VALUE (which
is SIZE bytes long). Return 0 on success, -1 for errors. */