mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/chromium to 20.0.1132.57-1
This commit is contained in:
parent
63534dcb2e
commit
9d543c828b
2 changed files with 43 additions and 3 deletions
|
@ -15,7 +15,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=20.0.1132.47
|
||||
pkgver=20.0.1132.57
|
||||
pkgrel=1
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -38,17 +38,22 @@ source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgna
|
|||
chromium.default
|
||||
chromium.sh
|
||||
chromium-gcc47.patch
|
||||
chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
|
||||
sqlite-3.7.6.3-fix-out-of-scope-memory-reference.patch)
|
||||
sha256sums=('a34e87ae916c1146b506090d30ac901dbfa88a55db90f8b2250eb29eaca3a1e5'
|
||||
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
|
||||
sha256sums=('1225c6b6306e89c8892bc0d18e94567d6081d777dee9b8c90efd0da9f6f2641b'
|
||||
'0137e738cad095aeb03da0e4eb92df4ab8f4693c81d462eb5a413de6ecd875d1'
|
||||
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
|
||||
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
|
||||
'f607347ba8477d3c8e60eb3803d26f3c9869f77fd49986c60887c59a6aa7d30d'
|
||||
'c1baf14121502efbc2a31b64029dcafa0e28ca5b71ad0e28a3c6342d18198615'
|
||||
'a700aa054800d1b21d84eaba27c38a703dfa023e9226d11a942690c2a0630aff')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/chromium-$pkgver"
|
||||
|
||||
# Fix build with glibc 2.16
|
||||
patch -Np1 -i "$srcdir/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch"
|
||||
|
||||
# Fix build with gcc 4.7 (patch from openSUSE)
|
||||
patch -Np2 -i "$srcdir/chromium-gcc47.patch"
|
||||
|
||||
|
|
|
@ -0,0 +1,35 @@
|
|||
diff -upr chromium-20.0.1132.57.orig/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h chromium-20.0.1132.57/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
|
||||
--- chromium-20.0.1132.57.orig/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h 2012-07-10 10:48:31.000000000 +0300
|
||||
+++ chromium-20.0.1132.57/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h 2012-07-11 23:44:11.000000000 +0300
|
||||
@@ -243,14 +243,13 @@ struct kernel_rusage {
|
||||
long ru_nivcsw;
|
||||
};
|
||||
|
||||
-struct siginfo;
|
||||
#if defined(__i386__) || defined(__arm__) || defined(__PPC__)
|
||||
|
||||
/* include/asm-{arm,i386,mips,ppc}/signal.h */
|
||||
struct kernel_old_sigaction {
|
||||
union {
|
||||
void (*sa_handler_)(int);
|
||||
- void (*sa_sigaction_)(int, struct siginfo *, void *);
|
||||
+ void (*sa_sigaction_)(int, siginfo_t *, void *);
|
||||
};
|
||||
unsigned long sa_mask;
|
||||
unsigned long sa_flags;
|
||||
@@ -287,13 +286,13 @@ struct kernel_sigaction {
|
||||
unsigned long sa_flags;
|
||||
union {
|
||||
void (*sa_handler_)(int);
|
||||
- void (*sa_sigaction_)(int, struct siginfo *, void *);
|
||||
+ void (*sa_sigaction_)(int, siginfo_t *, void *);
|
||||
};
|
||||
struct kernel_sigset_t sa_mask;
|
||||
#else
|
||||
union {
|
||||
void (*sa_handler_)(int);
|
||||
- void (*sa_sigaction_)(int, struct siginfo *, void *);
|
||||
+ void (*sa_sigaction_)(int, siginfo_t *, void *);
|
||||
};
|
||||
unsigned long sa_flags;
|
||||
void (*sa_restorer)(void);
|
Loading…
Reference in a new issue