mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/linux-raspberrypi: aufs fix
This commit is contained in:
parent
e49a407109
commit
9d66939958
2 changed files with 15 additions and 0 deletions
|
@ -26,6 +26,7 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
|
|||
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
|
||||
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
|
||||
'https://github.com/raspberrypi/tools/raw/master/mkimage/mkknlimg'
|
||||
'aufs-fix.patch'
|
||||
'config.txt'
|
||||
'cmdline.txt'
|
||||
'config.v6'
|
||||
|
@ -36,6 +37,7 @@ md5sums=('433725a2c2a8dcfee1ec8678ae286a0c'
|
|||
'a81346cce95baeac2c56cf60d3c7e5b6'
|
||||
'8f2743651280f5a022e541f4e95e5546'
|
||||
'69d50a4604a587ae770e4be244e293bd'
|
||||
'305ee224eb761a7aeacc3dae6ad1987b'
|
||||
'02bdc293e3fefe067a0aae2635c3220b'
|
||||
'60bc3624123c183305677097bcd56212'
|
||||
'acfc869522fd9078a4e1e471183a4391'
|
||||
|
@ -54,6 +56,7 @@ prepare() {
|
|||
patch -Np1 -i ../aufs3-standalone/aufs3-base.patch
|
||||
patch -Np1 -i ../aufs3-standalone/aufs3-mmap.patch
|
||||
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
|
||||
patch -Np1 -i ../aufs-fix.patch
|
||||
|
||||
msg2 "Add BFQ patches"
|
||||
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
|
||||
|
|
12
core/linux-raspberrypi/aufs-fix.patch
Normal file
12
core/linux-raspberrypi/aufs-fix.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff --git a/fs/aufs/super.c b/fs/aufs/super.c
|
||||
index a069370..9c5d95a 100644
|
||||
--- a/fs/aufs/super.c
|
||||
+++ b/fs/aufs/super.c
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <linux/mm.h>
|
||||
#include <linux/seq_file.h>
|
||||
#include <linux/statfs.h>
|
||||
+#include <linux/vmalloc.h>
|
||||
#include "aufs.h"
|
||||
|
||||
/*
|
Loading…
Reference in a new issue