extra/thunderbird to 60.0-4

This commit is contained in:
Kevin Mihelich 2018-08-20 12:35:15 +00:00
parent e45dec9692
commit 9da2550783
2 changed files with 35 additions and 1 deletions

View file

@ -14,7 +14,7 @@ highmem=1
pkgname=thunderbird
pkgver=60.0
pkgrel=3
pkgrel=4
pkgdesc="Standalone mail and news reader from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@ -27,9 +27,11 @@ optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
$pkgname.desktop
bz1482248.patch
https://hg.mozilla.org/mozilla-central/raw-rev/537f4d1d837a)
sha256sums=('bd7da88dcc03c448a4e975b5a1d3e9bf466ec9151b1059392bcdb50955a22056'
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
'8d944e6f5b8935843da1acb3c7b2670b217cd7ce7501738e02354b8702857aaa'
'9fa42f3a4ccd255b56f4157119c08ff19df9f972aa25af4cbb685e3683139c24')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@ -93,6 +95,10 @@ ac_add_options --disable-crashreporter
ac_add_options --disable-updater
END
cd comm
# https://bugzilla.mozilla.org/show_bug.cgi?id=1482248
patch -p1 -i "$srcdir/bz1482248.patch"
if [[ $CARCH == "armv7h" ]]; then
echo "ac_add_options --disable-elf-hack" >> .mozconfig
echo 'ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"' >> .mozconfig

View file

@ -0,0 +1,28 @@
diff --git a/mailnews/local/src/nsMsgLocalStoreUtils.cpp b/mailnews/local/src/nsMsgLocalStoreUtils.cpp
--- a/mailnews/local/src/nsMsgLocalStoreUtils.cpp
+++ b/mailnews/local/src/nsMsgLocalStoreUtils.cpp
@@ -23,16 +23,19 @@ nsMsgLocalStoreUtils::AddDirectorySepara
path->GetLeafName(leafName);
leafName.AppendLiteral(FOLDER_SUFFIX);
return path->SetLeafName(leafName);
}
bool
nsMsgLocalStoreUtils::nsShouldIgnoreFile(nsAString& name)
{
+ if (name.IsEmpty())
+ return true;
+
char16_t firstChar = name.First();
if (firstChar == '.' || firstChar == '#' ||
name.CharAt(name.Length() - 1) == '~')
return true;
if (name.LowerCaseEqualsLiteral("msgfilterrules.dat") ||
name.LowerCaseEqualsLiteral("rules.dat") ||
name.LowerCaseEqualsLiteral("filterlog.html") ||