mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/cairo to 1.15.10+54+g1ed124ace-1
This commit is contained in:
parent
c27d401dbb
commit
9db72dd97c
2 changed files with 79 additions and 10 deletions
|
@ -6,28 +6,47 @@
|
|||
# - drop valgrind makedepend
|
||||
|
||||
pkgname=cairo
|
||||
pkgver=1.15.10
|
||||
pkgver=1.15.10+54+g1ed124ace
|
||||
pkgrel=1
|
||||
pkgdesc="2D graphics library with support for multiple output devices"
|
||||
url="https://cairographics.org/"
|
||||
arch=(x86_64)
|
||||
license=('LGPL' 'MPL')
|
||||
depends=('libpng' 'libxrender' 'libxext' 'fontconfig' 'pixman' 'glib2' 'lzo')
|
||||
makedepends=('librsvg' 'gtk2' 'poppler-glib' 'libspectre' 'gtk-doc' 'git')
|
||||
source=(https://cairographics.org/snapshots/cairo-$pkgver.tar.xz)
|
||||
sha1sums=('de180498ac563249b93ee5e17ba9aa26f90644b3')
|
||||
license=(LGPL MPL)
|
||||
depends=(libpng libxrender libxext fontconfig pixman glib2 lzo)
|
||||
makedepends=(librsvg gtk2 poppler-glib libspectre gtk-doc git)
|
||||
_commit=1ed124ace201946177eab962d3b07bb2fedf9026 # master
|
||||
source=("git+https://anongit.freedesktop.org/git/cairo#commit=$_commit"
|
||||
utf-8.diff)
|
||||
sha1sums=('SKIP'
|
||||
'3f680dea8533bcce4ca2af5d25c546235ef7b339')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
git describe --tags | sed 's/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
|
||||
# Fixup tag for pkgver()
|
||||
git tag -f 1.15.10 5e6b9aeb5e3402ff17ae8ee8548ae2341c2f7d59
|
||||
|
||||
# Fix non-UTF-8 sources giving gtk-doc trouble
|
||||
patch -Np1 -i ../utf-8.diff
|
||||
|
||||
# Update gtk-doc
|
||||
cp /usr/share/aclocal/gtk-doc.m4 build/aclocal.gtk-doc.m4
|
||||
cp /usr/share/gtk-doc/data/gtk-doc.make build/Makefile.am.gtk-doc
|
||||
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
./configure --prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--disable-static \
|
||||
--disable-lto \
|
||||
--disable-gl \
|
||||
--enable-tee \
|
||||
--enable-svg \
|
||||
|
@ -39,7 +58,13 @@ build() {
|
|||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname
|
||||
# https://people.gnome.org/~federico/blog/helping-cairo.html
|
||||
#make check
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
|
|
44
extra/cairo/utf-8.diff
Normal file
44
extra/cairo/utf-8.diff
Normal file
|
@ -0,0 +1,44 @@
|
|||
src/cairo-quartz-image.h | 2 +-
|
||||
src/cairo-quartz.h | 2 +-
|
||||
src/cairo-vg.h | 4 ++--
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git c/src/cairo-quartz-image.h i/src/cairo-quartz-image.h
|
||||
index dae234dac..0dd5abb4f 100644
|
||||
--- c/src/cairo-quartz-image.h
|
||||
+++ i/src/cairo-quartz-image.h
|
||||
@@ -1,6 +1,6 @@
|
||||
/* cairo - a vector graphics library with display and print output
|
||||
*
|
||||
- * Copyright © 2008 Mozilla Corporation
|
||||
+ * Copyright © 2008 Mozilla Corporation
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it either under the terms of the GNU Lesser General Public
|
||||
diff --git c/src/cairo-quartz.h i/src/cairo-quartz.h
|
||||
index 9be5f9ae5..9e11e876f 100644
|
||||
--- c/src/cairo-quartz.h
|
||||
+++ i/src/cairo-quartz.h
|
||||
@@ -1,6 +1,6 @@
|
||||
/* cairo - a vector graphics library with display and print output
|
||||
*
|
||||
- * Copyright © 2006, 2007 Mozilla Corporation
|
||||
+ * Copyright © 2006, 2007 Mozilla Corporation
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it either under the terms of the GNU Lesser General Public
|
||||
diff --git c/src/cairo-vg.h i/src/cairo-vg.h
|
||||
index f9a62e51c..a2701db3b 100644
|
||||
--- c/src/cairo-vg.h
|
||||
+++ i/src/cairo-vg.h
|
||||
@@ -1,8 +1,8 @@
|
||||
/* -*- Mode: c; tab-width: 8; c-basic-offset: 4; indent-tabs-mode: t; -*- */
|
||||
/* cairo - a vector graphics library with display and print output
|
||||
*
|
||||
- * Copyright © 2007 * Mozilla Corporation
|
||||
- * Copyright © 2009 Chris Wilson
|
||||
+ * Copyright © 2007 * Mozilla Corporation
|
||||
+ * Copyright © 2009 Chris Wilson
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it either under the terms of the GNU Lesser General Public
|
Loading…
Reference in a new issue