extra/x265 to 2.1-1

This commit is contained in:
Kevin Mihelich 2016-10-02 14:45:31 +00:00
parent 751d5215de
commit 9dd5f2774a
2 changed files with 10 additions and 10 deletions

View file

@ -1,13 +1,13 @@
# $Id$
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: kfgz <kfgz@interia.pl>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to attempt fixing ARM hackery by bandwagoning developers
pkgname=x265
pkgver=2.0
pkgver=2.1
pkgrel=1
pkgdesc='Open Source H265/HEVC video encoder'
arch=('i686' 'x86_64')
@ -18,8 +18,8 @@ makedepends=('yasm' 'cmake')
provides=('libx265.so')
source=("https://bitbucket.org/multicoreware/x265/downloads/x265_${pkgver}.tar.gz"
arm.patch)
md5sums=('a4f16c0f054f002d6d8c9c6f7fb03026'
'6b7074bb7a250d0cb7de33905996dd5c')
md5sums=('c2657ab0925bee1fe7f3675b3f199ac0'
'5efb341e1422cb1d02790a3838ffb353')
prepare() {
cd x265_${pkgver}

View file

@ -1,6 +1,6 @@
diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
--- a/source/CMakeLists.txt 2016-07-13 07:53:26.000000000 -0600
+++ b/source/CMakeLists.txt 2016-07-23 09:47:41.615318333 -0600
--- a/source/CMakeLists.txt 2016-09-27 03:05:59.000000000 -0600
+++ b/source/CMakeLists.txt 2016-10-02 08:43:12.796597758 -0600
@@ -41,7 +41,7 @@
# System architecture detection
string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" SYSPROC)
@ -30,8 +30,8 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
else()
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}")
@@ -186,18 +194,6 @@
add_definitions(-march=i686)
@@ -190,18 +198,6 @@
endif()
endif()
endif()
- if(ARM AND CROSS_COMPILE_ARM)
@ -50,8 +50,8 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
if(INTEL_CXX)
add_definitions(-prof-gen -prof-dir="${CMAKE_CURRENT_BINARY_DIR}")
diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
--- a/source/common/cpu.cpp 2016-07-13 07:53:26.000000000 -0600
+++ b/source/common/cpu.cpp 2016-07-23 09:39:15.075352729 -0600
--- a/source/common/cpu.cpp 2016-09-27 03:05:59.000000000 -0600
+++ b/source/common/cpu.cpp 2016-10-02 08:43:12.796597758 -0600
@@ -37,7 +37,7 @@
#include <machine/cpu.h>
#endif