core/linux-aarch64-rc to 4.10.rc8-1

This commit is contained in:
Kevin Mihelich 2017-02-13 01:11:15 +00:00
parent 59b4c02d1b
commit 9df32200dd
3 changed files with 6 additions and 34 deletions

View file

@ -1,7 +1,7 @@
From 844ea6381384a3565d9f9d3eb94f10fb951809bb Mon Sep 17 00:00:00 2001
From 7e89ba6ecc97cfc35857e84004105d63808c5cd7 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index 831aa33d078a..03625547d794 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.11.0
2.11.1

View file

@ -1,25 +0,0 @@
From 3596276e2c034b2243d5e384e9ffb787f137158a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 13 Jan 2017 13:10:02 -0700
Subject: [PATCH 2/2] i2c: bcm2835: prevent null pointer dereference
---
drivers/i2c/busses/i2c-bcm2835.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/i2c/busses/i2c-bcm2835.c b/drivers/i2c/busses/i2c-bcm2835.c
index c3436f627028..cc840b86caab 100644
--- a/drivers/i2c/busses/i2c-bcm2835.c
+++ b/drivers/i2c/busses/i2c-bcm2835.c
@@ -195,7 +195,7 @@ static irqreturn_t bcm2835_i2c_isr(int this_irq, void *data)
}
if (val & BCM2835_I2C_S_DONE) {
- if (i2c_dev->curr_msg->flags & I2C_M_RD) {
+ if (i2c_dev->curr_msg && (i2c_dev->curr_msg->flags & I2C_M_RD)) {
bcm2835_drain_rxfifo(i2c_dev);
val = bcm2835_i2c_readl(i2c_dev, BCM2835_I2C_S);
}
--
2.11.0

View file

@ -4,7 +4,7 @@
buildarch=8
_rcver=4.10
_rcrel=7
_rcrel=8
pkgbase=linux-aarch64-rc
_srcname=linux-${_rcver}-rc${_rcrel}
@ -19,12 +19,10 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0002-i2c-bcm2835-prevent-null-pointer-dereference.patch'
'config'
'linux.preset')
md5sums=('e22d893f5db640f8ef5877977d66701d'
'40b8809ecbbac362d3e61dea5dd1303b'
'044f34cba214ed2e9f4dbd1c6a4925e4'
md5sums=('ae82bad1cfbb8509daeaaf9d40ac187f'
'1d852d09fa6ec38017b3ebe631c02d32'
'44a337fea317d8a8143a8d6f998a1183'
'25d8f6983c9a616946848c0e075a949c')
@ -33,7 +31,6 @@ prepare() {
# ALARM patches
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0002-i2c-bcm2835-prevent-null-pointer-dereference.patch
cat "${srcdir}/config" > ./.config