core/linux-odroid-c1 to 3.10.107-2

This commit is contained in:
Kevin Mihelich 2017-09-07 23:37:47 +00:00
parent 1726a7a3ea
commit 9e47dc2b1e
2 changed files with 35 additions and 1 deletions

View file

@ -0,0 +1,30 @@
From cc2bf49fc88e52aae8464f8c9876855cb1ab21dd Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 7 Sep 2017 12:50:39 -0600
Subject: [PATCH] disable pie
---
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index ed83376624f..6217f927d55 100644
--- a/Makefile
+++ b/Makefile
@@ -374,11 +374,11 @@ KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
-Werror-implicit-function-declaration \
-Wno-format-security \
-fno-delete-null-pointer-checks \
- -std=gnu89
+ -std=gnu89 $(call cc-option,-fno-PIE)
KBUILD_AFLAGS_KERNEL :=
KBUILD_CFLAGS_KERNEL :=
-KBUILD_AFLAGS := -D__ASSEMBLY__
+KBUILD_AFLAGS := -D__ASSEMBLY__ $(call cc-option,-fno-PIE)
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
--
2.14.1

View file

@ -9,7 +9,7 @@ _srcname=linux-${_commit}
_kernelname=${pkgbase#linux} _kernelname=${pkgbase#linux}
_desc="ODROID-C1" _desc="ODROID-C1"
pkgver=3.10.107 pkgver=3.10.107
pkgrel=1 pkgrel=2
arch=('armv7h') arch=('armv7h')
url="https://github.com/hardkernel/linux" url="https://github.com/hardkernel/linux"
license=('GPL2') license=('GPL2')
@ -17,10 +17,12 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
options=('!strip') options=('!strip')
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz" source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
"git+https://github.com/mdrjr/c1_bootini.git" "git+https://github.com/mdrjr/c1_bootini.git"
'0001-disable-pie.patch'
'config' 'config'
'amlogic.service') 'amlogic.service')
md5sums=('fbdd73c858eae0d4c8b314077a0a16a2' md5sums=('fbdd73c858eae0d4c8b314077a0a16a2'
'SKIP' 'SKIP'
'a2329e6dcdc856559fbd8b0847b3b55d'
'c27274182cbe6e22dcf5b12ad84f4585' 'c27274182cbe6e22dcf5b12ad84f4585'
'b8956789318f49cec5b8bb0b41654a9b') 'b8956789318f49cec5b8bb0b41654a9b')
@ -34,6 +36,8 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging # don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh sed -i '2iexit 0' scripts/depmod.sh
git apply ../0001-disable-pie.patch
} }
build() { build() {