core/linux-raspberrypi sync with upstream, add VETH

This commit is contained in:
moonman 2014-01-21 00:20:20 -07:00
parent d0a877b335
commit 9e7be3a5c8
3 changed files with 8 additions and 55 deletions

View file

@ -4,12 +4,12 @@
buildarch=18
pkgbase=linux-raspberrypi
_commit=ab2ed0dbf37e8d397e60f37621629082da75cd58
_commit=943b563ec9961b53b77a0e7b6c07289826c082a5
_srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi"
pkgver=3.10.27
pkgrel=1
pkgrel=2
arch=('arm armv6h')
url="http://www.kernel.org/"
license=('GPL2')
@ -21,29 +21,20 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
'args-uncompressed.txt'
'boot-uncompressed.txt'
'imagetool-uncompressed.py'
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
'rasclockPCF2127.patch::http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/patch/?id=18cb6368f0b0fc6a28bd49ee547b4f655db97fc3'
'aufs-sources-3.10.26-mmap-aufs3.patch')
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}.x"
'rasclockPCF2127.patch::http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/patch/?id=18cb6368f0b0fc6a28bd49ee547b4f655db97fc3')
md5sums=('d36c4a26b7b8d8e2ec4b51684909f238'
'6a47b587102e6f52ec4fb65b1ecf6856'
md5sums=('46c9af0e6018eb286be295ce7e1c9130'
'011c5901ec2981c24db42f16c53d1183'
'9d3c56a4b999c8bfbd4018089a62f662'
'9335d1263fd426215db69841a380ea26'
'a00e424e2fbb8c5a5f77ba2c4871bed4'
'2f82dbe5752af65ff409d737caf11954'
'SKIP'
'fc75790fbb31312459770c682113c5bc'
'8af486c1597a93f3523dcd628de9288a')
'fc75790fbb31312459770c682113c5bc')
prepare() {
#Remove after this fix is in the tree
cd "${srcdir}/aufs3-standalone"
patch -p1 -i ../aufs-sources-3.10.26-mmap-aufs3.patch
#Evomer
cd "${srcdir}/${_srcname}"
# Set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)

View file

@ -1,38 +0,0 @@
aufs3-mmap.patch | 17 ++++++-----------
1 file changed, 6 insertions(+), 11 deletions(-)
diff --git a/aufs3-mmap.patch b/aufs3-mmap.patch
index 398253b..d9b413c 100644
--- a/aufs3-mmap.patch
+++ b/aufs3-mmap.patch
@@ -215,24 +215,19 @@ index 7905fe7..94cc777 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/fremap.c b/mm/fremap.c
-index 87da359..92bb6f2 100644
+index bbc4d66..7deee2c 100644
--- a/mm/fremap.c
+++ b/mm/fremap.c
-@@ -202,11 +202,12 @@ get_write_lock:
- */
- if (mapping_cap_account_dirty(mapping)) {
- unsigned long addr;
-- struct file *file = get_file(vma->vm_file);
-+ struct file *file = vma->vm_file;
+@@ -211,7 +211,9 @@ get_write_lock:
+ /* mmap_region may free vma; grab the info now */
+ vm_flags = vma->vm_flags;
+ vma_get_file(vma);
- addr = mmap_region(file, start, size,
- vma->vm_flags, pgoff);
-- fput(file);
+ addr = mmap_region(file, start, size, vm_flags, pgoff);
+ vma_fput(vma);
+ fput(file);
if (IS_ERR_VALUE(addr)) {
err = addr;
- } else {
diff --git a/mm/madvise.c b/mm/madvise.c
index 7055883..e6b768d 100644
--- a/mm/madvise.c

View file

@ -1290,7 +1290,7 @@ CONFIG_NETPOLL=y
# CONFIG_NETPOLL_TRAP is not set
CONFIG_NET_POLL_CONTROLLER=y
CONFIG_TUN=m
# CONFIG_VETH is not set
CONFIG_VETH=m
#
# CAIF transport drivers