extra/wolfssl to 5.5.1-1

This commit is contained in:
Kevin Mihelich 2022-09-28 12:53:50 +00:00
parent 3306890a7f
commit 9e996154d0
3 changed files with 19 additions and 19 deletions

View file

@ -4,7 +4,7 @@
# - cmake with -DWOLFSSL_SHA3=ON, required and not set by default for v7
pkgname=wolfssl
pkgver=5.5.0
pkgver=5.5.1
pkgrel=1
pkgdesc="Lightweight, portable, C-language-based SSL/TLS library"
arch=(x86_64)
@ -17,21 +17,21 @@ options=(debug)
source=(
$pkgname-$pkgver-stable.tar.gz::https://github.com/$pkgname/$pkgname/archive/refs/tags/v$pkgver-stable.tar.gz
https://github.com/$pkgname/$pkgname/releases/download/v$pkgver-stable/$pkgname-$pkgver-stable.tar.gz.asc
$pkgname-5.5.0-cmake.patch
$pkgname-5.5.1-cmake.patch
)
sha512sums=('1f9ffd8e83b26f97c3685315790f3f2b451a23e9dad9e2f09142a3e1e136012293ca2d04f46c267f8275ac9e60894c46c7875353765df6d4fdd93ba666228459'
sha512sums=('821bb7b8105d53c614712eb9f7ebb39a5e20f03c1856edad4e4cdaed797f7940fbe7062905d64bd386878abae1ae3275a4b7792db9b1d673f2de5d903b60f32e'
'SKIP'
'44aef4fc39dc81b113563b78c8732e8d1d6371e1c0ad0e73d8b13115e6623d8d92e6162400453fe36473616e2f6f9a283f8a440c94588860e92b204669672be4')
b2sums=('92f2f1c7072cf6bb0ea5007cb4c1662c147534021fe63929202a2c4e46bdd40bc2e61fdec6d3c8720bfd1be8e946588536ba2a7e9c02a84e11be3e01ca2db1c3'
'02e2a6c370b2ad8e737b9d40d435a65babd8ce9c03892e1f1bf484d328f45bda4fe8be82cc051fdcda4946c405f8ea4baa6840d1db5ae54bec0dbc0dcce7da28')
b2sums=('b735beee96bdc9fde6aca5048c732d77bb86ecbe29ba8ad8cd6528fef340859b3017faa4b84e00c476e017dde741e276440408c3ae6fc90d6790961c6ed26001'
'SKIP'
'8179223e2536d672896be7b5afab45df3326a14d6330c031d6631bb8075a666c4106d8a47b56d6640254cf91c75b7a4fc3801a1ef5626f847dd90926472c0370')
'82cee658075ffb8a2e1ebb2b0a8018b7edbacd29727f7aaca026c8d8808e48cfd617c2e22a01601a80d377423f57d7b6c7dc18186c2f59d8a7ab60bf37ce75ff')
validpgpkeys=(
A2A48E7BCB96C5BECB987314EBC80E415CA29677 # wolfSSL <secure@wolfssl.com>
)
prepare() {
# -Werror not even once: https://github.com/wolfSSL/wolfssl/issues/5553
patch -Np1 -d $pkgname-$pkgver-stable -i ../$pkgname-5.5.0-cmake.patch
patch -Np1 -d $pkgname-$pkgver-stable -i ../$pkgname-5.5.1-cmake.patch
}
build() {

View file

@ -1,12 +0,0 @@
diff -ruN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2022-08-30 19:35:13.000000000 +0200
+++ b/CMakeLists.txt 2022-09-08 23:27:01.798347756 +0200
@@ -169,7 +169,7 @@
# Example for map file and custom linker script
#set(CMAKE_EXE_LINKER_FLAGS " -Xlinker -Map=output.map -T\"${CMAKE_CURRENT_SOURCE_DIR}/linker.ld\"")
-set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-unused -Werror ${CMAKE_C_FLAGS}")
+set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-unused ${CMAKE_C_FLAGS}")
####################################################
# Build Options

View file

@ -0,0 +1,12 @@
diff -ruN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2022-09-27 23:21:19.000000000 +0200
+++ b/CMakeLists.txt 2022-09-28 13:26:25.001693738 +0200
@@ -173,7 +173,7 @@
# Windows cl.exe does not support the -Wextra, -Wno-unused and -Werror flags.
set(CMAKE_C_FLAGS "-Wall ${CMAKE_C_FLAGS}")
else()
-set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-unused -Werror ${CMAKE_C_FLAGS}")
+set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-unused ${CMAKE_C_FLAGS}")
endif()
####################################################