extra/mesa to 10.6.4-1

This commit is contained in:
Kevin Mihelich 2015-08-13 00:00:39 +00:00
parent c7ee3a3feb
commit 9eb741abc5
2 changed files with 45 additions and 4 deletions

View file

@ -0,0 +1,33 @@
From e2a696a4cd93c2dbe445243de48ed478fbdb8009 Mon Sep 17 00:00:00 2001
From: Chris Wilson <chris@chris-wilson.co.uk>
Date: Fri, 10 Jul 2015 10:41:35 +0100
Subject: [PATCH] i965: Remove early release of DRI2 miptree
intel_update_winsys_renderbuffer_miptree() will release the existing
miptree when wrapping a new DRI2 buffer, so we can remove the early
release and so prevent a NULL mt dereference should importing the new
DRI2 name fail for any reason. (Reusing the old DRI2 name will result
in the rendering going astray, to a stale buffer, and not shown on the
screen, but it allows us to issue a warning and not crash much later in
innocent code.)
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
---
src/mesa/drivers/dri/i965/brw_context.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/mesa/drivers/dri/i965/brw_context.c b/src/mesa/drivers/dri/i965/brw_context.c
index e8d1396..72f3897 100644
--- a/src/mesa/drivers/dri/i965/brw_context.c
+++ b/src/mesa/drivers/dri/i965/brw_context.c
@@ -1388,7 +1388,6 @@ intel_process_dri2_buffer(struct brw_context *brw,
buffer->cpp, buffer->pitch);
}
- intel_miptree_release(&rb->mt);
bo = drm_intel_bo_gem_create_from_name(brw->bufmgr, buffer_name,
buffer->name);
if (!bo) {
--
2.5.0

View file

@ -9,7 +9,7 @@
pkgbase=mesa
pkgname=('mesa' 'mesa-libgl' 'libva-mesa-driver')
pkgver=10.6.3
pkgver=10.6.4
pkgrel=1
arch=('i686' 'x86_64')
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
@ -19,12 +19,20 @@ url="http://mesa3d.sourceforge.net"
license=('custom')
options=('!libtool')
source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz{,.sig}
LICENSE)
sha256sums=('58592e07c350cd2e8969b73fa83048c657a39fe2f13f3b88f5e5818fe2e4676d'
LICENSE
0001-i965-Remove-early-release-of-DRI2-miptree.patch)
sha256sums=('8f5ac103f0f503de2f7a985b0df349bd4ecdfe7f51c714be146fa5a9a3c07b77'
'SKIP'
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2')
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
'a3f520ea13c923841c646a5b1627927744938ff691aa08e1aeaf14cce12bd1f7')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # Emil Velikov <emil.l.velikov@gmail.com>
prepare() {
cd ${srcdir}/?esa-*
# Should fix FS#45750, tested by heftig - Not merged upstream
patch -Np1 -i ../0001-i965-Remove-early-release-of-DRI2-miptree.patch
}
build() {
cd ${srcdir}/?esa-*