extra/giac to 1.9.0.57-1

This commit is contained in:
Kevin Mihelich 2023-06-26 23:34:17 +00:00
parent 9f892e1ca7
commit 9ebc74ee66
2 changed files with 19 additions and 5 deletions

View file

@ -4,7 +4,7 @@
# - delete shipped x86 binary src/mkjs to force rebuild for ARM
pkgname=giac
_pkgver=1.9.0-53
_pkgver=1.9.0-57
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc='A free computer algebra system'
@ -12,18 +12,21 @@ arch=(x86_64)
url='http://www-fourier.ujf-grenoble.fr/~parisse/giac.html'
license=(GPL3)
depends=(fltk mpfi gsl pari ntl lapack curl glpk libao gmp-ecm libsamplerate)
makedepends=(python libjpeg texlive-core texlive-science hevea nauty)
makedepends=(python libjpeg texlive-mathscience hevea nauty)
optdepends=('perl: for pgiac')
replaces=(libgiac xcas)
provides=(libgiac xcas)
source=(http://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/${pkgname}_$_pkgver.tar.gz
format-security.patch)
sha256sums=('4e538866d72ebdfe62364adf8345709a3b0b2312ed2ef17435b16cf76f4d7340'
'04288944e408807a15aa502e1215087870d8921229c9f9890d862d3c9de337cd')
format-security.patch
fix-build.patch)
sha256sums=('b81f9a24646be4989e68faf12cb8bdae3688f0440bec2e1a62e97af702684c1b'
'04288944e408807a15aa502e1215087870d8921229c9f9890d862d3c9de337cd'
'184e158a59d6a07b03436d7fdc197f1422c0e6786b3d89c7a7231d10b193c5bb')
prepare() {
cd $pkgname-${pkgver%.*}
patch -p1 < ../format-security.patch # Fix -Werror=format-security errors
patch -p1 < ../fix-build.patch
rm -f src/mkjs # force rebuild for ARM
}

View file

@ -0,0 +1,11 @@
diff -ru giac-1.9.0.orig/src/first.h giac-1.9.0/src/first.h
--- giac-1.9.0.orig/src/first.h 2023-06-18 21:23:20.774912898 +0200
+++ giac-1.9.0/src/first.h 2023-06-18 21:24:54.712829079 +0200
@@ -29,6 +29,7 @@
#define GIAC_VERSION VERSION
#endif
//#include <stdint.h>
+#include <tuple>
// mingw now defines x86_64
#if (defined(__x86_64__) || defined(__arm64__)) && !defined __MINGW_H