extra/chromium to 91.0.4472.114-1

This commit is contained in:
Kevin Mihelich 2021-06-18 12:46:09 +00:00
parent 471bf0ed57
commit 9f278e8d69
2 changed files with 43 additions and 6 deletions

View file

@ -15,7 +15,7 @@ buildarch=12
highmem=1
pkgname=chromium
pkgver=91.0.4472.106
pkgver=91.0.4472.114
pkgrel=1
_launcher_ver=7
_gcc_patchset=5
@ -27,7 +27,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
'java-runtime-headless' 'python2' 'python2-setuptools')
'java-runtime-headless' 'python2')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@ -37,16 +37,18 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
fix-crash-in-ThemeService.patch
unbundle-use-char16_t-as-UCHAR_TYPE.patch
make-dom-distiller-protoc-plugin-call-py2.7.patch
extend-enable-accelerated-video-decode-flag.patch
sql-make-VirtualCursor-standard-layout-type.patch
chromium-glibc-2.33.patch
use-oauth2-client-switches-as-default.patch
0001-widevine-support-for-arm.patch)
sha256sums=('545e38cd7dce0008c16ab5736ac9764655149e65d353630adac601da040dbebb'
sha256sums=('c1c7fe783f3250978503d4bd53144039bd818de8a6e89de493f27dd5168f7e71'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
'171525009003a9ed1182cfcb6f407d7169d9a731a474304e263029376719f55a'
'3cfe46e181cb9d337c454b5b5adbf5297052f29cd617cdee4380eeb1943825d8'
'59a59a60a08b335fe8647fdf0f9d2288d236ebf2cc9626396d0c4d032fd2b25d'
'76ceebd14c9a6f1ea6a05b1613e64d1e2aca595e0f0b3e9497e3eeee33ed756c'
'66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
@ -121,6 +123,7 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../fix-crash-in-ThemeService.patch
patch -Np1 -i ../unbundle-use-char16_t-as-UCHAR_TYPE.patch
patch -Np1 -i ../make-dom-distiller-protoc-plugin-call-py2.7.patch
patch -Np1 -i ../extend-enable-accelerated-video-decode-flag.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
@ -129,9 +132,6 @@ prepare() {
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-90-ruy-include.patch
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/

View file

@ -0,0 +1,37 @@
From 359b22d3f775afa33cca9e4f8fb57eadd0ec4118 Mon Sep 17 00:00:00 2001
From: Nico Weber <thakis@chromium.org>
Date: Fri, 23 Apr 2021 16:22:19 +0000
Subject: [PATCH] Make dom distiller protoc plugin explicitly call py2.7
With this, chrome builds with when `/usr/bin/env python` is py3.
Bug: 1202134
Change-Id: Ibbd97a1311ccb34d46f266912c871fd0522f9535
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2848445
Commit-Queue: Nico Weber <thakis@chromium.org>
Commit-Queue: Yaron Friedman <yfriedman@chromium.org>
Commit-Queue: Dirk Pranke <dpranke@google.com>
Auto-Submit: Nico Weber <thakis@chromium.org>
Reviewed-by: Yaron Friedman <yfriedman@chromium.org>
Reviewed-by: Dirk Pranke <dpranke@google.com>
Cr-Commit-Position: refs/heads/master@{#875702}
---
.../dom_distiller_js/protoc_plugins/json_values_converter.py | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py b/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py
index e86a88c759fcb..cae1a998c4650 100755
--- a/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py
+++ b/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py
@@ -1,7 +1,10 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2.7
# Copyright 2016 The Chromium Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
+#
+# TODO(crbug.com/1202134): Switch run line back to just "python"
+# once things are py3-compatible.
"""protoc plugin to create C++ reader/writer for JSON-encoded protobufs