mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed core/kernel26-trimslice
This commit is contained in:
parent
875bfc97c1
commit
9f65f59fd9
5 changed files with 0 additions and 3779 deletions
|
@ -1,228 +0,0 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@plugapps.com>
|
||||
|
||||
# Trim Slice kernel and headers
|
||||
# - note: any other kernel packages should include headers for that march
|
||||
# - there will be no v7 kernel26 package, each march will be tagged individually
|
||||
# - This is built from TS's git repo (gitorious) with minimal patching
|
||||
|
||||
noautobuild=1
|
||||
plugrel=1
|
||||
|
||||
pkgbase="kernel26"
|
||||
pkgname=('kernel26-trimslice' 'kernel26-headers-trimslice')
|
||||
#_kernelname=${pkgname#kernel26}
|
||||
_kernelname=""
|
||||
_basekernel=2.6.38
|
||||
pkgver=${_basekernel}.3
|
||||
pkgrel=6
|
||||
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage' 'make')
|
||||
_patchname="patch-${pkgver}-${_pkgrel}-ARCH"
|
||||
#_patchname="patch-${pkgver}-1-ARCH"
|
||||
arch=(armv7h)
|
||||
CARCH=armv7h
|
||||
KARCH=arm
|
||||
LDFLAGS=""
|
||||
license=('GPL2')
|
||||
url="http://www.kernel.org"
|
||||
source=(http://archlinuxarm.org/builder/src/trimslice-kernel-1.03.tar.bz2
|
||||
http://trimslice.com/download/drivers/firmware/rtl_nic/rtl8168d-1.fw
|
||||
http://trimslice.com/download/drivers/firmware/rtl_nic/rtl8168d-2.fw
|
||||
config
|
||||
armdma.patch)
|
||||
md5sums=('c658f88355e1520ece8aeb56fcfa6758'
|
||||
'500d938ce15d1b0aff8d394aefb7a812'
|
||||
'b14a1a124c2d58fd346ed25ffbbe2959'
|
||||
'bec5a355320f7a82e021667bdfa796bf'
|
||||
'6e7667c6c6348bfeca22eaaa05462d62')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/trimslice-kernel"
|
||||
|
||||
patch -p1 -i ${srcdir}/armdma.patch
|
||||
|
||||
# Copy in our configuration
|
||||
cp ${srcdir}/config ./.config
|
||||
|
||||
# Copy in the ethernet firmware, needed for make!
|
||||
mkdir -p firmware/rtl_nic
|
||||
cp ${srcdir}/rtl8168d-1.fw firmware/rtl_nic/
|
||||
cp ${srcdir}/rtl8168d-2.fw firmware/rtl_nic/
|
||||
|
||||
# set extraversion to pkgrel
|
||||
sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
|
||||
|
||||
# Prepare sources
|
||||
make prepare
|
||||
# Configure the kernel. Replace the line below with one of your choice.
|
||||
#make menuconfig # CLI menu for configuration
|
||||
#make nconfig # new CLI menu for configuration
|
||||
#make oldconfig # using old config from previous kernel version
|
||||
|
||||
# Build!
|
||||
make ${MAKEFLAGS} uImage modules
|
||||
}
|
||||
|
||||
package_kernel26-trimslice() {
|
||||
pkgdesc="The Linux Kernel and modules"
|
||||
groups=('base')
|
||||
depends=('coreutils' 'module-init-tools>=3.12-2')
|
||||
replaces=('kernel24' 'kernel24-scsi' 'kernel26-scsi'
|
||||
'alsa-driver' 'ieee80211' 'hostap-driver26'
|
||||
'pwc' 'nforce' 'squashfs' 'unionfs' 'ivtv'
|
||||
'zd1211' 'kvm-modules' 'iwlwifi' 'rt2x00-cvs'
|
||||
'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm')
|
||||
provides=('kernel26=2.6.38')
|
||||
conflicts=('kernel26' 'kernel26-tegra' 'kernel26-omap')
|
||||
install=kernel26.install
|
||||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
|
||||
KARCH=arm
|
||||
cd ${srcdir}/trimslice-kernel
|
||||
# get kernel version
|
||||
_kernver="$(make kernelrelease)"
|
||||
mkdir -p ${pkgdir}/{lib/modules,lib/firmware,boot}
|
||||
make INSTALL_MOD_PATH=${pkgdir} modules_install
|
||||
cp System.map ${pkgdir}/boot/System.map26${_kernelname}
|
||||
cp arch/$KARCH/boot/uImage ${pkgdir}/boot/uImage
|
||||
|
||||
# set correct depmod command for install
|
||||
sed \
|
||||
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
|
||||
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
||||
-i $startdir/kernel26.install
|
||||
|
||||
# remove build and source links
|
||||
rm -f ${pkgdir}/lib/modules/${_kernver}/{source,build}
|
||||
# remove the firmware
|
||||
rm -rf ${pkgdir}/lib/firmware
|
||||
# gzip -9 all modules to save 100MB of space
|
||||
find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
|
||||
}
|
||||
|
||||
package_kernel26-headers-trimslice() {
|
||||
pkgdesc="Header files and scripts for building modules for kernel26"
|
||||
provides=('kernel26-headers=2.6.38')
|
||||
conflicts=('kernel26-headers' 'kernel26-headers-tegra' 'kernel26-headers-omap')
|
||||
KARCH=arm
|
||||
|
||||
mkdir -p ${pkgdir}/lib/modules/${_kernver}
|
||||
cd ${pkgdir}/lib/modules/${_kernver}
|
||||
ln -sf ../../../usr/src/linux-${_kernver} build
|
||||
cd ${srcdir}/trimslice-kernel
|
||||
install -D -m644 Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/Makefile
|
||||
install -D -m644 kernel/Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/kernel/Makefile
|
||||
install -D -m644 .config \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/.config
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include
|
||||
|
||||
for i in acpi asm-generic config generated linux math-emu media net pcmcia scsi sound trace video xen; do
|
||||
cp -a include/$i ${pkgdir}/usr/src/linux-${_kernver}/include/
|
||||
done
|
||||
|
||||
# copy arch includes for external modules
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH
|
||||
cp -a arch/$KARCH/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-tegra
|
||||
cp -a arch/$KARCH/mach-tegra/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-tegra/
|
||||
|
||||
# copy files necessary for later builds, like nvidia and vmware
|
||||
cp Module.symvers ${pkgdir}/usr/src/linux-${_kernver}
|
||||
cp -a scripts ${pkgdir}/usr/src/linux-${_kernver}
|
||||
# fix permissions on scripts dir
|
||||
chmod og-w -R ${pkgdir}/usr/src/linux-${_kernver}/scripts
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/.tmp_versions
|
||||
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel
|
||||
|
||||
cp arch/$KARCH/Makefile ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
if [ "$CARCH" = "i686" ]; then
|
||||
cp arch/$KARCH/Makefile_32.cpu ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
fi
|
||||
cp arch/$KARCH/kernel/asm-offsets.s ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel/
|
||||
|
||||
# add headers for lirc package
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video
|
||||
cp drivers/media/video/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/
|
||||
for i in bt8xx cpia2 cx25840 cx88 em28xx et61x251 pwc saa7134 sn9c102; do
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
|
||||
cp -a drivers/media/video/$i/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
|
||||
done
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/staging/usbvideo/
|
||||
cp -a drivers/staging/usbvideo/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/staging/usbvideo/
|
||||
# add docbook makefile
|
||||
install -D -m644 Documentation/DocBook/Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile
|
||||
# add dm headers
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
|
||||
cp drivers/md/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
|
||||
# add inotify.h
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/linux
|
||||
cp include/linux/inotify.h ${pkgdir}/usr/src/linux-${_kernver}/include/linux/
|
||||
# add wireless headers
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
|
||||
cp net/mac80211/*.h ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/9912
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core
|
||||
cp drivers/media/dvb/dvb-core/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core/
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/11194
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
|
||||
cp include/config/dvb/*.h ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
|
||||
# add dvb headers for http://mcentral.de/hg/~mrec/em28xx-new
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/13146
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
cp drivers/media/dvb/frontends/lgdt330x.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
cp drivers/media/video/msp3400-driver.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
# add dvb headers
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/20402
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-usb
|
||||
cp drivers/media/dvb/dvb-usb/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-usb/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends
|
||||
cp drivers/media/dvb/frontends/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/common/tuners
|
||||
cp drivers/media/common/tuners/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/common/tuners/
|
||||
# add xfs and shmem for aufs building
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/mm
|
||||
cp fs/xfs/xfs_sb.h ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h
|
||||
# add headers vor virtualbox
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/14568
|
||||
cp -a include/drm $pkgdir/usr/src/linux-${_kernver}/include/
|
||||
# add headers for broadcom wl
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/14568
|
||||
cp -a include/trace $pkgdir/usr/src/linux-${_kernver}/include/
|
||||
# add headers for crypto modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/22081
|
||||
cp -a include/crypto $pkgdir/usr/src/linux-${_kernver}/include/
|
||||
# copy in Kconfig files
|
||||
for i in `find . -name "Kconfig*"`; do
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/`echo $i | sed 's|/Kconfig.*||'`
|
||||
cp $i ${pkgdir}/usr/src/linux-${_kernver}/$i
|
||||
done
|
||||
|
||||
chown -R root.root ${pkgdir}/usr/src/linux-${_kernver}
|
||||
find ${pkgdir}/usr/src/linux-${_kernver} -type d -exec chmod 755 {} \;
|
||||
# strip scripts directory
|
||||
find ${pkgdir}/usr/src/linux-${_kernver}/scripts -type f -perm -u+w 2>/dev/null | while read binary ; do
|
||||
case "$(file -bi "$binary")" in
|
||||
*application/x-sharedlib*) # Libraries (.so)
|
||||
/usr/bin/strip $STRIP_SHARED "$binary";;
|
||||
*application/x-archive*) # Libraries (.a)
|
||||
/usr/bin/strip $STRIP_STATIC "$binary";;
|
||||
*application/x-executable*) # Binaries
|
||||
/usr/bin/strip $STRIP_BINARIES "$binary";;
|
||||
esac
|
||||
done
|
||||
# remove unneeded architectures
|
||||
rm -rf ${pkgdir}/usr/src/linux-${_kernver}/arch/{alpha,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,x86,xtensa}
|
||||
}
|
|
@ -1,122 +0,0 @@
|
|||
diff -urN linux-3.1-rc4-a/arch/arm/include/asm/dma-mapping.h linux-3.1-rc4-b/arch/arm/include/asm/dma-mapping.h
|
||||
--- linux-3.1-rc4-a/arch/arm/include/asm/dma-mapping.h 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/arch/arm/include/asm/dma-mapping.h 2011-09-02 12:09:00.000000000 +0100
|
||||
@@ -205,6 +205,15 @@
|
||||
int dma_mmap_writecombine(struct device *, struct vm_area_struct *,
|
||||
void *, dma_addr_t, size_t);
|
||||
|
||||
+#ifdef CONFIG_ARM_DMA_MEM_BUFFERABLE
|
||||
+#define ARCH_HAS_DMA_COHERENT_WRITE_SYNC
|
||||
+
|
||||
+static inline void dma_coherent_write_sync(void)
|
||||
+{
|
||||
+ dsb();
|
||||
+ outer_sync();
|
||||
+}
|
||||
+#endif
|
||||
|
||||
#ifdef CONFIG_DMABOUNCE
|
||||
/*
|
||||
diff -urN linux-3.1-rc4-a/Documentation/DMA-API-HOWTO.txt linux-3.1-rc4-b/Documentation/DMA-API-HOWTO.txt
|
||||
--- linux-3.1-rc4-a/Documentation/DMA-API-HOWTO.txt 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/Documentation/DMA-API-HOWTO.txt 2011-09-02 12:01:09.000000000 +0100
|
||||
@@ -400,6 +400,22 @@
|
||||
from a pool before you destroy the pool. This function may not
|
||||
be called in interrupt context.
|
||||
|
||||
+Some architectures which supporting DMA coherent memory may still have write
|
||||
+buffering between the CPU and DMA memory. This buffering may delay CPU writes
|
||||
+from reaching coherent memory in a timely manner. These delays in turn can
|
||||
+lead lead to dramatic performance issues in certain cases. An architecture
|
||||
+may mitigate this problem to a large degree by having a write buffer flush
|
||||
+implicit in the MMIO functions used to write to device registers. This works
|
||||
+for the most common cases where a driver needs to write to a register to tell
|
||||
+a device that something was written to the shared coherent memory. There are
|
||||
+other cases where the device polls the dma-coherent memory for data written
|
||||
+by the driver. In such cases, the driver needs to explicity force write buffer
|
||||
+data to memory by calling:
|
||||
+
|
||||
+ dma_coherent_write_sync();
|
||||
+
|
||||
+
|
||||
+
|
||||
DMA Direction
|
||||
|
||||
The interfaces described in subsequent portions of this document
|
||||
diff -urN linux-3.1-rc4-a/Documentation/DMA-API.txt linux-3.1-rc4-b/Documentation/DMA-API.txt
|
||||
--- linux-3.1-rc4-a/Documentation/DMA-API.txt 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/Documentation/DMA-API.txt 2011-09-02 12:03:06.000000000 +0100
|
||||
@@ -418,6 +418,18 @@
|
||||
....
|
||||
|
||||
|
||||
+Part Ie - Write buffering to dma-coherent memory
|
||||
+------------------------------------------------
|
||||
+
|
||||
+Some architectures supporting DMA coherent memory may have write
|
||||
+buffering between the CPU and DMA memory. This buffering may delay
|
||||
+CPU writes from reaching coherent memory in a timely manner.
|
||||
+
|
||||
+ void
|
||||
+ dma_coherent_write_sync()
|
||||
+
|
||||
+Force any outstanding coherent writes to memory.
|
||||
+
|
||||
Part II - Advanced dma_ usage
|
||||
-----------------------------
|
||||
|
||||
diff -urN linux-3.1-rc4-a/drivers/usb/host/ehci-q.c linux-3.1-rc4-b/drivers/usb/host/ehci-q.c
|
||||
--- linux-3.1-rc4-a/drivers/usb/host/ehci-q.c 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/drivers/usb/host/ehci-q.c 2011-09-02 12:17:20.000000000 +0100
|
||||
@@ -114,6 +114,7 @@
|
||||
/* HC must see latest qtd and qh data before we clear ACTIVE+HALT */
|
||||
wmb ();
|
||||
hw->hw_token &= cpu_to_hc32(ehci, QTD_TOGGLE | QTD_STS_PING);
|
||||
+ dma_coherent_write_sync();
|
||||
}
|
||||
|
||||
/* if it weren't for a common silicon quirk (writing the dummy into the qh
|
||||
@@ -404,6 +405,7 @@
|
||||
wmb();
|
||||
hw->hw_token = cpu_to_hc32(ehci,
|
||||
token);
|
||||
+ dma_coherent_write_sync();
|
||||
goto retry_xacterr;
|
||||
}
|
||||
stopped = 1;
|
||||
@@ -753,8 +755,10 @@
|
||||
}
|
||||
|
||||
/* by default, enable interrupt on urb completion */
|
||||
- if (likely (!(urb->transfer_flags & URB_NO_INTERRUPT)))
|
||||
+ if (likely(!(urb->transfer_flags & URB_NO_INTERRUPT))) {
|
||||
qtd->hw_token |= cpu_to_hc32(ehci, QTD_IOC);
|
||||
+ dma_coherent_write_sync();
|
||||
+ }
|
||||
return head;
|
||||
|
||||
cleanup:
|
||||
@@ -1081,6 +1085,7 @@
|
||||
/* let the hc process these next qtds */
|
||||
wmb ();
|
||||
dummy->hw_token = token;
|
||||
+ dma_coherent_write_sync();
|
||||
|
||||
urb->hcpriv = qh_get (qh);
|
||||
}
|
||||
diff -urN linux-3.1-rc4-a/include/linux/dma-mapping.h linux-3.1-rc4-b/include/linux/dma-mapping.h
|
||||
--- linux-3.1-rc4-a/include/linux/dma-mapping.h 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/include/linux/dma-mapping.h 2011-09-02 12:06:06.000000000 +0100
|
||||
@@ -154,6 +154,12 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
+#ifndef ARCH_HAS_DMA_COHERENT_WRITE_SYNC
|
||||
+static inline void dma_coherent_write_sync(void)
|
||||
+{
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* Managed DMA API
|
||||
*/
|
File diff suppressed because it is too large
Load diff
|
@ -1,22 +0,0 @@
|
|||
KERNEL_NAME=
|
||||
KERNEL_VERSION=2.6.38-6-ARCH
|
||||
|
||||
post_install() {
|
||||
# ARM doesn't use mkinitcpio or anything like that
|
||||
# so we skip it here
|
||||
echo -e "\033[1mNotice\033[0m"
|
||||
echo "To complete the installation you will have to copy"
|
||||
echo "/boot/uImage to the proper location, e.g. /dev/mmcblk0p1"
|
||||
echo ""
|
||||
echo "This package is built for the TrimSlice."
|
||||
echo ""
|
||||
/sbin/depmod ${KERNEL_VERSION}
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
op=$1
|
||||
shift
|
||||
$op $*
|
|
@ -1,17 +0,0 @@
|
|||
# mkinitcpio preset file for kernel26
|
||||
|
||||
########################################
|
||||
# DO NOT EDIT THIS LINE:
|
||||
source /etc/mkinitcpio.d/kernel26.kver
|
||||
########################################
|
||||
ALL_config="/etc/mkinitcpio.conf"
|
||||
|
||||
PRESETS=('default' 'fallback')
|
||||
|
||||
#default_config="/etc/mkinitcpio.conf"
|
||||
default_image="/boot/kernel26.img"
|
||||
#default_options=""
|
||||
|
||||
#fallback_config="/etc/mkinitcpio.conf"
|
||||
fallback_image="/boot/kernel26-fallback.img"
|
||||
fallback_options="-S autodetect"
|
Loading…
Reference in a new issue