mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/zynaddsubfx: fix patch
This commit is contained in:
parent
9c07fcc151
commit
9f8efc3b2e
2 changed files with 8 additions and 16 deletions
|
@ -1,20 +1,12 @@
|
||||||
Description: Stop forcing SSE and x86 compiler options in the generic target.
|
diff -urN a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||||
Author: Adam Conrad <adconrad@ubuntu.com>
|
--- a/src/CMakeLists.txt 2015-02-23 16:10:22.000000000 -0700
|
||||||
Forwarded: no
|
+++ b/src/CMakeLists.txt 2015-02-27 05:34:00.436336619 -0700
|
||||||
---
|
@@ -144,7 +144,7 @@
|
||||||
src/CMakeLists.txt | 5 ++---
|
|
||||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
--- zynaddsubfx.orig/src/CMakeLists.txt
|
|
||||||
+++ zynaddsubfx/src/CMakeLists.txt
|
|
||||||
@@ -116,8 +116,8 @@ set (BuildOptions_X86_64Core2
|
|
||||||
)
|
)
|
||||||
|
|
||||||
set (BuildOptionsBasic
|
set (BuildOptionsBasic
|
||||||
- "-O3 -msse -msse2 -mfpmath=sse -ffast-math -fomit-frame-pointer"
|
- "-std=c++11 -Wno-unused-parameter -O3 -msse -msse2 -mfpmath=sse -ffast-math -fomit-frame-pointer"
|
||||||
- CACHE STRING "basic X86 complier options"
|
+ "-std=c++11 -Wno-unused-parameter -O3 -ffast-math -fomit-frame-pointer"
|
||||||
+ "-O3 -ffast-math -fomit-frame-pointer"
|
CACHE STRING "basic X86 complier options"
|
||||||
+ CACHE STRING "basic complier options"
|
|
||||||
)
|
)
|
||||||
|
|
||||||
set (BuildOptionsDebug
|
|
||||||
|
|
|
@ -22,7 +22,7 @@ source=("http://switch.dl.sourceforge.net/sourceforge/$pkgname/zynaddsubfx-$pkgv
|
||||||
'0001-no_sse_generic.patch')
|
'0001-no_sse_generic.patch')
|
||||||
md5sums=('22a3468ead939285b3eb13d92e1109c7'
|
md5sums=('22a3468ead939285b3eb13d92e1109c7'
|
||||||
'6f7e9c3ce3947088a10c99c46a65431f'
|
'6f7e9c3ce3947088a10c99c46a65431f'
|
||||||
'160936412b6123e67f9bb01e56207b27')
|
'f52766f4dd6098269999f33cd18bedf1')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "zynaddsubfx-$pkgver"
|
cd "zynaddsubfx-$pkgver"
|
||||||
|
|
Loading…
Reference in a new issue