mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/calligra to 3.1.0-12
This commit is contained in:
parent
06dd3fa0d5
commit
a046571a68
3 changed files with 139 additions and 70 deletions
|
@ -10,7 +10,7 @@
|
||||||
pkgname=calligra
|
pkgname=calligra
|
||||||
pkgdesc="A set of applications for productivity and creative usage"
|
pkgdesc="A set of applications for productivity and creative usage"
|
||||||
pkgver=3.1.0
|
pkgver=3.1.0
|
||||||
pkgrel=10
|
pkgrel=12
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url='https://www.calligra-suite.org/'
|
url='https://www.calligra-suite.org/'
|
||||||
license=(FDL1.2 GPL2 LGPL)
|
license=(FDL1.2 GPL2 LGPL)
|
||||||
|
@ -40,12 +40,15 @@ for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb n
|
||||||
replaces+=(calligra-l10n-$_lang)
|
replaces+=(calligra-l10n-$_lang)
|
||||||
done
|
done
|
||||||
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
|
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
|
||||||
calligra-qt5.11.patch calligra-poppler-0.69.patch
|
calligra-qt5.11.patch
|
||||||
|
calligra-poppler-0.69.patch::"https://cgit.kde.org/calligra.git/patch/?id=a6157182"
|
||||||
|
calligra-poppler-0.71.patch
|
||||||
'calligra-2.9.11-gcc6_arm.patch')
|
'calligra-2.9.11-gcc6_arm.patch')
|
||||||
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
|
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
|
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
|
||||||
'7a29c220b3871569cb16390261951481341b7e5923ed5c95aa4188286b2ba56d'
|
'b6b3dc44606aa4243cd0da23819f3bad9953d0542b87d3b4e04113f431f2598c'
|
||||||
|
'052adc4ea812d7667812ff7867e703327dbe7c1ecad86094fd6772dc09782d87'
|
||||||
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
|
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
|
||||||
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
|
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
|
||||||
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
|
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
|
||||||
|
@ -58,6 +61,8 @@ prepare() {
|
||||||
patch -p1 -i ../calligra-qt5.11.patch
|
patch -p1 -i ../calligra-qt5.11.patch
|
||||||
# Fix build with poppler 0.69
|
# Fix build with poppler 0.69
|
||||||
patch -p1 -i ../calligra-poppler-0.69.patch
|
patch -p1 -i ../calligra-poppler-0.69.patch
|
||||||
|
# Fix build with poppler 0.71
|
||||||
|
patch -p1 -i ../calligra-poppler-0.71.patch
|
||||||
|
|
||||||
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
|
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,67 +0,0 @@
|
||||||
diff --git a/filters/karbon/pdf/PdfImport.cpp b/filters/karbon/pdf/PdfImport.cpp
|
|
||||||
index c3e96b0cd28..48b08dfa32d 100644
|
|
||||||
--- a/filters/karbon/pdf/PdfImport.cpp
|
|
||||||
+++ b/filters/karbon/pdf/PdfImport.cpp
|
|
||||||
@@ -102,9 +102,6 @@ KoFilter::ConversionStatus PdfImport::convert(const QByteArray& from, const QByt
|
|
||||||
delete globalParams;
|
|
||||||
globalParams = 0;
|
|
||||||
|
|
||||||
- // check for memory leaks
|
|
||||||
- Object::memCheck(stderr);
|
|
||||||
-
|
|
||||||
return KoFilter::OK;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
|
|
||||||
index 931917ae15d..7901317ebd0 100644
|
|
||||||
--- a/filters/karbon/pdf/SvgOutputDev.cpp
|
|
||||||
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
|
|
||||||
@@ -212,7 +212,7 @@ QString SvgOutputDev::convertMatrix(const QMatrix &matrix)
|
|
||||||
.arg(matrix.dx()) .arg(matrix.dy());
|
|
||||||
}
|
|
||||||
|
|
||||||
-QString SvgOutputDev::convertMatrix(double * matrix)
|
|
||||||
+QString SvgOutputDev::convertMatrix(const double * matrix)
|
|
||||||
{
|
|
||||||
return QString("matrix(%1 %2 %3 %4 %5 %6)")
|
|
||||||
.arg(matrix[0]).arg(matrix[1])
|
|
||||||
@@ -402,7 +402,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
|
|
||||||
|
|
||||||
QString str;
|
|
||||||
|
|
||||||
- char * p = s->getCString();
|
|
||||||
+ const char * p = s->getCString();
|
|
||||||
int len = s->getLength();
|
|
||||||
CharCode code;
|
|
||||||
Unicode *u = nullptr;
|
|
||||||
@@ -429,7 +429,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
|
|
||||||
double x = state->getCurX();
|
|
||||||
double y = state->getCurY();
|
|
||||||
|
|
||||||
- double * ctm = state->getCTM();
|
|
||||||
+ const double * ctm = state->getCTM();
|
|
||||||
QMatrix transform(ctm[0], ctm[1], ctm[2], ctm[3], ctm[4], ctm[5]);
|
|
||||||
|
|
||||||
QMatrix mirror;
|
|
||||||
@@ -522,7 +522,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
- double * ctm = state->getCTM();
|
|
||||||
+ const double * ctm = state->getCTM();
|
|
||||||
QMatrix m;
|
|
||||||
m.setMatrix(ctm[0] / width, ctm[1] / width, -ctm[2] / height, -ctm[3] / height, ctm[2] + ctm[4], ctm[3] + ctm[5]);
|
|
||||||
|
|
||||||
diff --git a/filters/karbon/pdf/SvgOutputDev.h b/filters/karbon/pdf/SvgOutputDev.h
|
|
||||||
index 85fe55dfff6..2a4490848bf 100644
|
|
||||||
--- a/filters/karbon/pdf/SvgOutputDev.h
|
|
||||||
+++ b/filters/karbon/pdf/SvgOutputDev.h
|
|
||||||
@@ -84,7 +84,7 @@ public:
|
|
||||||
private:
|
|
||||||
QString convertPath(GfxPath *path);
|
|
||||||
QString convertMatrix(const QMatrix &matrix);
|
|
||||||
- QString convertMatrix(double * matrix);
|
|
||||||
+ QString convertMatrix(const double * matrix);
|
|
||||||
QString printFill();
|
|
||||||
QString printStroke();
|
|
||||||
|
|
131
extra/calligra/calligra-poppler-0.71.patch
Normal file
131
extra/calligra/calligra-poppler-0.71.patch
Normal file
|
@ -0,0 +1,131 @@
|
||||||
|
diff --git a/filters/karbon/pdf/PdfImport.cpp b/filters/karbon/pdf/PdfImport.cpp
|
||||||
|
index 48b08dfa32d..e910dae0756 100644
|
||||||
|
--- a/filters/karbon/pdf/PdfImport.cpp
|
||||||
|
+++ b/filters/karbon/pdf/PdfImport.cpp
|
||||||
|
@@ -88,9 +88,9 @@ KoFilter::ConversionStatus PdfImport::convert(const QByteArray& from, const QByt
|
||||||
|
SvgOutputDev * dev = new SvgOutputDev(m_chain->outputFile());
|
||||||
|
if (dev->isOk()) {
|
||||||
|
int rotate = 0;
|
||||||
|
- GBool useMediaBox = gTrue;
|
||||||
|
- GBool crop = gFalse;
|
||||||
|
- GBool printing = gFalse;
|
||||||
|
+ bool useMediaBox = true;
|
||||||
|
+ bool crop = false;
|
||||||
|
+ bool printing = false;
|
||||||
|
pdfDoc->displayPages(dev, firstPage, lastPage, hDPI, vDPI, rotate, useMediaBox, crop, printing);
|
||||||
|
dev->dumpContent();
|
||||||
|
}
|
||||||
|
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
|
||||||
|
index 5692824bc45..43205170991 100644
|
||||||
|
--- a/filters/karbon/pdf/SvgOutputDev.cpp
|
||||||
|
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
|
||||||
|
@@ -39,7 +39,7 @@ class SvgOutputDev::Private
|
||||||
|
{
|
||||||
|
public:
|
||||||
|
Private(const QString &fname)
|
||||||
|
- : svgFile(fname), defs(0), body(0), state(gTrue)
|
||||||
|
+ : svgFile(fname), defs(0), body(0), state(true)
|
||||||
|
, brush(Qt::SolidPattern) {}
|
||||||
|
|
||||||
|
~Private() {
|
||||||
|
@@ -52,7 +52,7 @@ public:
|
||||||
|
QString defsData;
|
||||||
|
QTextStream * defs;
|
||||||
|
QTextStream * body;
|
||||||
|
- GBool state;
|
||||||
|
+ bool state;
|
||||||
|
QSizeF pageSize;
|
||||||
|
QPen pen;
|
||||||
|
QBrush brush;
|
||||||
|
@@ -62,7 +62,7 @@ SvgOutputDev::SvgOutputDev(const QString &fileName)
|
||||||
|
: d(new Private(fileName))
|
||||||
|
{
|
||||||
|
if (! d->svgFile.open(QIODevice::WriteOnly)) {
|
||||||
|
- d->state = gFalse;
|
||||||
|
+ d->state = false;
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -75,24 +75,24 @@ SvgOutputDev::~SvgOutputDev()
|
||||||
|
delete d;
|
||||||
|
}
|
||||||
|
|
||||||
|
-GBool SvgOutputDev::isOk()
|
||||||
|
+bool SvgOutputDev::isOk()
|
||||||
|
{
|
||||||
|
return d->state;
|
||||||
|
}
|
||||||
|
|
||||||
|
-GBool SvgOutputDev::upsideDown()
|
||||||
|
+bool SvgOutputDev::upsideDown()
|
||||||
|
{
|
||||||
|
- return gTrue;
|
||||||
|
+ return true;
|
||||||
|
}
|
||||||
|
|
||||||
|
-GBool SvgOutputDev::useDrawChar()
|
||||||
|
+bool SvgOutputDev::useDrawChar()
|
||||||
|
{
|
||||||
|
- return gFalse;
|
||||||
|
+ return false;
|
||||||
|
}
|
||||||
|
|
||||||
|
-GBool SvgOutputDev::interpretType3Chars()
|
||||||
|
+bool SvgOutputDev::interpretType3Chars()
|
||||||
|
{
|
||||||
|
- return gFalse;
|
||||||
|
+ return false;
|
||||||
|
}
|
||||||
|
|
||||||
|
void SvgOutputDev::startPage(int pageNum, GfxState *state, XRef */*xref*/)
|
||||||
|
@@ -480,7 +480,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
|
||||||
|
|
||||||
|
void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
|
||||||
|
int width, int height, GfxImageColorMap *colorMap,
|
||||||
|
- int *maskColors, GBool /*inlineImg*/)
|
||||||
|
+ int *maskColors, bool /*inlineImg*/)
|
||||||
|
{
|
||||||
|
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
|
||||||
|
imgStr->reset();
|
||||||
|
@@ -549,7 +549,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
|
||||||
|
|
||||||
|
void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
|
||||||
|
int width, int height, GfxImageColorMap *colorMap,
|
||||||
|
- GBool /*interpolate*/, int *maskColors, GBool inlineImg)
|
||||||
|
+ bool /*interpolate*/, int *maskColors, bool inlineImg)
|
||||||
|
{
|
||||||
|
drawImage(state, ref, str, width, height, colorMap, maskColors, inlineImg);
|
||||||
|
}
|
||||||
|
diff --git a/filters/karbon/pdf/SvgOutputDev.h b/filters/karbon/pdf/SvgOutputDev.h
|
||||||
|
index 2a4490848bf..cdb1d4e43b1 100644
|
||||||
|
--- a/filters/karbon/pdf/SvgOutputDev.h
|
||||||
|
+++ b/filters/karbon/pdf/SvgOutputDev.h
|
||||||
|
@@ -44,11 +44,11 @@ public:
|
||||||
|
explicit SvgOutputDev(const QString &fileName);
|
||||||
|
virtual ~SvgOutputDev();
|
||||||
|
|
||||||
|
- GBool isOk();
|
||||||
|
+ bool isOk();
|
||||||
|
|
||||||
|
- virtual GBool upsideDown();
|
||||||
|
- virtual GBool useDrawChar();
|
||||||
|
- virtual GBool interpretType3Chars();
|
||||||
|
+ virtual bool upsideDown();
|
||||||
|
+ virtual bool useDrawChar();
|
||||||
|
+ virtual bool interpretType3Chars();
|
||||||
|
virtual void startPage(int pageNum, GfxState *state, XRef *xref);
|
||||||
|
virtual void endPage();
|
||||||
|
|
||||||
|
@@ -63,10 +63,10 @@ public:
|
||||||
|
// images
|
||||||
|
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
|
||||||
|
int width, int height, GfxImageColorMap *colorMap,
|
||||||
|
- int *maskColors, GBool inlineImg);
|
||||||
|
+ int *maskColors, bool inlineImg);
|
||||||
|
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
|
||||||
|
int width, int height, GfxImageColorMap *colorMap,
|
||||||
|
- GBool interpolate, int *maskColors, GBool inlineImg);
|
||||||
|
+ bool interpolate, int *maskColors, bool inlineImg);
|
||||||
|
|
||||||
|
// styles
|
||||||
|
virtual void updateAll(GfxState *state);
|
Loading…
Reference in a new issue