mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/linux-mvebu to 3.12.0-3
This commit is contained in:
parent
1c46c42e14
commit
a07ab5ecea
2 changed files with 21 additions and 28 deletions
|
@ -9,7 +9,7 @@ _srcname=linux-3.12-rc1
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="Marvell SOCs with Device Tree support"
|
||||
pkgver=3.12.0
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -21,7 +21,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/testing/${_srcname}.tar.xz"
|
|||
md5sums=('f407382ea56f0831690e91d3c782bde1'
|
||||
'75136dbdc9153a90f419ae04a5a7a854'
|
||||
'8eb20ef02a6e25da0604848e3ed8f139'
|
||||
'8c5c265be2e8a640b1e0bde3326e5a6b')
|
||||
'911bffe9c261ca5b91dd0a083d99e81f')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
|
|
@ -1,27 +1,20 @@
|
|||
--- a/arch/arm/boot/dts/armada-370-mirabox.dts 2013-09-16 14:17:51.000000000 -0600
|
||||
+++ b/arch/arm/boot/dts/armada-370-mirabox.dts 2013-09-21 02:16:27.355026066 -0600
|
||||
@@ -114,11 +114,12 @@
|
||||
pinctrl-0 = <&sdio_pins3>;
|
||||
pinctrl-names = "default";
|
||||
status = "okay";
|
||||
+ bus-width = <8>;
|
||||
/*
|
||||
* No CD or WP GPIOs: SDIO interface used for
|
||||
* Wifi/Bluetooth chip
|
||||
*/
|
||||
- broken-cd;
|
||||
+ non-removable;
|
||||
};
|
||||
|
||||
usb@50000 {
|
||||
--- a/arch/arm/boot/dts/armada-370-xp.dtsi 2013-09-16 14:17:51.000000000 -0600
|
||||
+++ b/arch/arm/boot/dts/armada-370-xp.dtsi 2013-10-05 18:51:22.198159452 -0600
|
||||
@@ -209,8 +209,6 @@
|
||||
clocks = <&gateclk 17>;
|
||||
bus-width = <4>;
|
||||
cap-sdio-irq;
|
||||
- cap-sd-highspeed;
|
||||
- cap-mmc-highspeed;
|
||||
status = "disabled";
|
||||
};
|
||||
--- a/drivers/mmc/host/mvsdio.c 2013-09-16 14:17:51.000000000 -0600
|
||||
+++ b/drivers/mmc/host/mvsdio.c 2013-10-21 01:36:10.000000000 -0600
|
||||
@@ -97,7 +97,7 @@
|
||||
tmout_index = fls(tmout - 1) - 12;
|
||||
if (tmout_index < 0)
|
||||
tmout_index = 0;
|
||||
- if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX)
|
||||
+// if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX) //by steven, try to setup the timeout to maximum value
|
||||
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
|
||||
|
||||
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
|
||||
@@ -600,6 +600,8 @@
|
||||
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
|
||||
if (m > MVSD_BASE_DIV_MAX)
|
||||
m = MVSD_BASE_DIV_MAX;
|
||||
+ if(ios->clock==50000000 ) //by steven
|
||||
+ m=1;
|
||||
mvsd_write(MVSD_CLK_DIV, m);
|
||||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
|
|
Loading…
Reference in a new issue