extra/xine-lib to 1.2.9-5

This commit is contained in:
Kevin Mihelich 2018-04-24 12:20:04 +00:00
parent d2938c2483
commit a08ec8c463
2 changed files with 28 additions and 8 deletions

View file

@ -6,16 +6,16 @@
pkgname=xine-lib
pkgver=1.2.9
pkgrel=3
pkgrel=5
pkgdesc="A multimedia playback engine"
arch=('x86_64')
url="http://www.xine-project.org"
license=('LGPL' 'GPL')
depends=('libxvmc' 'ffmpeg' 'libxinerama')
makedepends=('wavpack' 'faad2' 'libmng' 'libmagick6' 'mesa' 'libmodplug'
depends=('libxvmc' 'ffmpeg' 'libxinerama' 'libnsl')
makedepends=('wavpack' 'faad2' 'libmng' 'libmagick' 'mesa' 'libmodplug'
'vcdimager' 'jack' 'aalib' 'libdca' 'a52dec' 'libmad' 'libdvdnav'
'libmpcdec' 'libcaca' 'libbluray' 'glu' 'gdk-pixbuf2')
optdepends=('libmagick6: for using the imagemagick plugin' \
optdepends=('libmagick: for using the imagemagick plugin' \
'jack: for using the jack plugin' \
'vcdimager: for using the vcd plugin' \
'glu: for using the opengl plugin' \
@ -27,19 +27,26 @@ optdepends=('libmagick6: for using the imagemagick plugin' \
'libdca: for using the dca plugin' \
'a52dec: for using the a52 plugin' \
'libmad: for using the mp3 plugin' \
'libdvdnav: for using the dvd plugin' \
'libmpcdec: for using the musepack plugin' \
'libcaca: for using the caca plugin' \
'libbluray: for using the bluray plugin' \
'smbclient: for using the samba plugin' \
'gdk-pixbuf2: for using the gdk-pixbuf plugin')
source=(https://downloads.sourceforge.net/project/xine/xine-lib/$pkgver/xine-lib-$pkgver.tar.xz)
sha1sums=('ad6e72b7d8ff6172a8a170ab1bc38577ae321371')
source=(https://downloads.sourceforge.net/project/xine/xine-lib/$pkgver/xine-lib-$pkgver.tar.xz
xine-lib-imagemagick7.patch)
sha1sums=('ad6e72b7d8ff6172a8a170ab1bc38577ae321371'
'7604ce72297f5b123a0bb53ebf5f1606e2ec0bad')
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../xine-lib-imagemagick7.patch # PLD linux patch
}
build() {
cd ${pkgname}-${pkgver}
PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig" \
./configure --prefix=/usr --with-wavpack --disable-vdpau --with-external-dvdnav \
--disable-optimizations
--disable-optimizations
make
}

View file

@ -0,0 +1,13 @@
http://git.pld-linux.org/?p=packages/xine-lib.git;a=blob;f=imagemagick7.patch;h=d050323cdf509c9bb5f8edbad90084e8ce5c1b38;hb=HEAD
--- xine-lib-1.2.6/src/video_dec/image.c
+++ xine-lib-1.2.6/src/video_dec/image.c
@@ -39,7 +39,7 @@
#define LOG
*/
-#include <wand/magick_wand.h>
+#include <MagickWand/MagickWand.h>
#ifdef PACKAGE_NAME
#undef PACKAGE_BUGREPORT
#undef PACKAGE_NAME